
Introduction 

Small, simple and affordable, ELIWELL data loggers can measure and record data at specified intervals 
ranging from once every 2 seconds, to once every 12 hours. ELIWELL's DataLogger Manager requires 
no programming skills, and enables the user to effortlessly select reading rate, specify the user's ID, and 
initiate the start of data collection. For immediate use of the data logger refer to the Quick Start Guide. 

In addition, all data can be saved in a format easily read by spreadsheet applications such as "Microsoft 
Excel." or "Lotus 1-2-3.". It is our goal to bring you accurate, low-cost, easy-to-use data loggers that 
integrate easily into the user's working environment. To better understand your needs and to better serve 
you, we welcome and appreciate your feedback. 

Thank you for choosing ELIWELL for your data logging requirements. 

 
Warranty 

Products manufactured by ELIWELL, are warranted against defective material and workmanship for a 
period of one year, starting from the date of shipment. In the event that a ELIWELL product is found to 
be defective, ELIWELL will repair or replace the product at its sole discretion. Such repair or 
replacement shall be the sole remedy of this warranty. 

This warranty extends only to the original purchasing customer and does not apply to any unit, which in 
our sole judgment, has been subjected to: 

a)Operating or environmental conditions in excess of our written specifications or recommendations; 
b) Damage, misuse or neglect; 
c) Improper installation, repair or alteration. 

This warranty excludes batteries. 

Except as to title, this is our only warranty for the products. ELIWELL expressly disclaims all other 
warranties, guarantees or remedies�whether expressed or implied or statutory�including any implied 
warranty of merchantability or fitness for a particular purpose. We also disclaim any implied warranty 
arising out of trade usage or out of a course dealing or course of performance. We do not guarantee the 
integrity of data or warranty that the products will operate uninterrupted or error-free. ELIWELL data 
loggers and their associated software have been thoroughly tested and the documentation reviewed. 
However, ELIWELL does not warrant the performance of its products, or that the products or their 
associated software will operate as described in this manual.  

 
Battery Warning  

Most ELIWELL data loggers contain a lithium battery. Do not cut the battery open, incinerate, or 
recharge. Do not heat lithium batteries above 85ºC unless the battery is specifically rated for higher 
temperatures. Dispose the battery in accordance with local regulations. 

 
Hardware 
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Package Inspection 
Verify that the data logger(s) was not damaged in transit by carefully unpacking all items in the shipping 
carton and looking for obvious signs of physical damage. If the data logger is damaged, repack it in its 
original container and contact ELIWELL Customer Service. Any damage noted upon receipt must be 
documented to file a claim against the carrier. 

System Requirements 
ELIWELL DataLogger Manager requires an IBM or compatible PC with the following:  

Pentium or higher processor  
Windows 95/98/2000/XP/NT  
128 MB RAM  
Color 800 X 600 monitor  
30 MB free disk space  
3.5" disk drive or CD-ROM  
Available 9 pin male serial (COM) port  

NOTE: Although the software is designed to work with the Windows Operating Systems listed above, ELIWELL cannot 
guarantee operation on OS's no longer supported by Microsoft Support Life Cycle Policy. 

 
Quick Start Guide  

For immediate use of the data logger, follow these six simple steps:  

1. Install the software (see Software Installation, if help needed with this step).  
2. Attach the logger to the host computer using the interface cable, as shown in the diagram below.  
3. From the Communication Menu, select Auto Configure port.  
4. From the Device Menu, select Start Device.  
5. Select the Reading Rate to be used.  
6. Click on Start Device.  

After a brief pause while the software communicates with the device, the user will see the message 
Device Started. The device is now running and taking measurements. Place it in the elected environment 
to perform its measurements. When the user is ready to view the measurements, simply connect it to the 
computer and select Read Device Data from the Device Menu.  

 
Interface Cable Installation
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Insert the male connector of the PDLUSBIF interface cable into the female receptacle of the data logger. 
Insert the female USB connector into the USB. 

NOTE: Most ELIWELL data loggers can use both PDLUSBIF interface cables, some do not. 

 
Battery Replacement  

Most ELIWELL miniature data loggers contain a user-replaceable 3.6 volt or 3.0 volt lithium battery. 
Replacement batteries may be purchased from the factory along with installation instructions. Then click 
the link for the specific data logger to ensure the device has a user-replaceable battery. If the device does 
not have a user-replaceable battery, or the customer simply does not wish to replace the battery 
themselves, the device may be returned to the factory for service. In this case, the customer should 
contact the company from which the unit was purchased for an Return Merchandise Authorization 
(RMA) number and return the product as instructed by customer service. ELIWELL will replace the 
battery and return the data logger promptly. 

 
Software 

Getting Started 
For simplicity and ease of use all ELIWELL data loggers operate similarly. The ELIWELL DataLogger 
Manager automatically configures itself specifically for each class of logger by reading the device type. 
Each class of logger has a unique device type and identifies itself when queried by the host computer. 
This has been implemented to minimize confusion and to eliminate the need to learn different software 
packages. Therefore, only one software package and only one manual is required for all ELIWELL Data 
Loggers. In certain instances where differences occur, an attempt is made in this manual to bring 
clarification and avoid confusion. Most examples used in this manual are for the PDL10T, but can be 
extended to all devices.  

 
Software Installation  

Installing from CD ROM 
Insert the CD ROM labeled ELIWELL DataLogger Manager into the host computer's CD ROM drive. 
From the Windows Start Menu, choose the Run command and type d:\autorun.exe into the Open field 
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and click OK., it will bring the installation menu window ELIWELL CD Contents as shown below.  

If the host computer's CD ROM Drive is not the D: drive, use the correct letter for the instructions above. 

 

Install ELIWELL 
The selected language will be displayed on the installation windows. 

  

The following screens are examples of the installation windows:
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Install USB Interface Drivers (for use with PDLUSBIF) 
The USB interface drivers can be installed when the host computer has USB drivers. After the 
installation the data logger will communicate with the PC through USB port. The host computer must 
have USB drivers to install the USB interface drivers. 

Select the Install button to install USB interface drivers. 
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NOTE: A pop up box may appear explaining This software may impair or destabilize the correct operation of your 
system either immediately or in the future. The drivers have been tested and will not interfere with the operation of the 
host computer. Select "continue" to proceed with the installation. 

Installation Documents 
View ELIWELL Read Me, View ELIWELL Software Manual and View ELIWELL Quick Start 
Guide are documents about ELIWELL data loggers, software, and more. After installation, the software 
will be listed under the default ELIWELL software program group and saved under the default 
C:\Program Files\ELIWELL\ directory. 

To begin immediately, see the Quick Start Guide. 

 
Running the Software 

Run the software by selecting the ELIWELL icon in the ELIWELL Software program group. The 
software will open and is immediately ready for starting a device or downloading data. The tool bar and 
menu items will appear as shown below. All toolbar commands are also menu commands. 

NOTE: Throughout this manual, when a menu command has a corresponding toolbar command, the toolbar icon is 
included with the description of the menu command. 

 
The File Menu 

The File Menu will appear as follows: 
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File Menu: New  
Select this command to create a new graph window. It will not discard any information that is already on 
the screen or in existing windows. Multiple windows may be created and displayed simultaneously, and 
may be manipulated using the Window Menu.. 

File Menu: Open  
Select this command to open previously saved data files, loading them into the current window. If no 
windows are open, a new one will be created. Data in the current window is not discarded, the new data 
is added as an additional dataset. Multiple windows may be created and displayed simultaneously, and 
may be manipulated using the Window Menu. 

Open Dialog Box  
Select the Open command for the following window:
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There are three types of files that may be opened with this software. These file formats are described in 
Save. 

File Menu: Close 
This command closes the currently active window. If the data displayed in the window has not been 
saved, the user will be prompted to save it at this time. This command will not discard data from or close 
any other existing windows.  

File Menu: Save  

File Menu: Save As 
Select Save As from the File Menu to save a copy of data under an alternate name, in any of the three 
file types discussed on the following page.  

File Menu: Save All  
Select Save or Save All from the File Menu to display the window as shown below:  
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Data may be saved as any of three types of files. These files are as follows: 

*.dat  
This is our own internal ASCII data format. This format can be viewed by most text editing or word 
processing software.  

*.txt  
Files stored in this format contain tab delimited text and can be viewed by most word processing and 
spreadsheet programs.  

*.csv  
Files stored in this format contain comma separated values and are directly readable by Microsoft Excel. 
and many other spreadsheet programs.  

NOTE: In order to save a dataset, it must be displayed in the Graph or Data tab. 
NOTE: To read data in an external program use the Export Data command. 

File Menu: Save All As 
Select Save All As from the File Menu to save all copies of datasets under alternate names, in any of the 
three file types discussed. 

NOTE: The user will be prompted to save each individual dataset as a different file. The software does not upload one 
file as multiple datasets; they are required to be uploaded individually. 

File Menu: Export Data 
Select Export Data from the File Menu to export a copy of the data in a format that is designed for easy 
import into programs such as Excel. . Data can be read in the same units displayed on the screen. The 
three file types are the same as those provided with the Save command, except data which is specific to 
the software, such as graph colors, is stripped out. Use Export to open the file in another program. 

File Menu: Save Memory Dump 
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Select Save Memory Dump from the File Menu to download the entire memory contents of the attached
device and save it in binary format. This command is useful to the factory for troubleshooting problems 
in the field and recovering data from a malfunctioning device. The user will typically not use this 
command unless directed to do so by our tech support department.  

File Menu: Page Setup 
Select Page Setup from the File Menu to bring up the window below. This window allows the user to 
select the printer and printing options. The options will vary according to the particular printer and 
network. Consult the printer manufacturer for details about the printer's options.  

  

File Menu: Print Summary 
Select Print Summary from the File Menu to print the statistics for currently selected device.  

File Menu: Print Graph  
Select Print Graph from the File Menu to print the currently selected graph to the host printer. The 
single dataset file can be printed by viewing the Graph tab. Printing out the composite graph can be 
achieved through the Composite Graph tab. 

File Menu: Print Data 
Select Print Data from the File Menu to print the device data in table format. The amount of data will 
vary depending upon the device and the number of data points.  

Select one of the choices from above Print Summary, Print Graph, and Print Data from the File 
Menu to bring up the following window: 
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File Menu: Print Device Configuration 
Select Print Device Configuration from the File Menu to print information that relates to the dataset 
file currently displayed on the screen. 

NOTE: The message unable to print device configuration will inform the user if there is no dataset file open. 

File Menu: Print Preview 
Select Print Preview from the File Menu to place a check mark next to it. When this menu item is 
checked, the result of Print Graph, Print Data, Print Summary and Print Device Configuration will 
display on the screen, rather than on the host printer. This allows a preview of the data to be printed. To 
uncheck this menu item select Print Preview again. 

File Menu: Exit 
Select Exit from the File Menu to close all open files and exit the program. There will be a prompt to 
save all files that have been changed. 

 
The Edit Menu 

The Edit Menu will appear as follows: 

 

Edit Menu: Cut, Copy & Paste 
The Edit Menu toolbar is currently disabled.  
The Cut, Copy and Paste functions are not available for use.
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The View Menu 

The View Menu will appear as follows: 

 

View Menu: Toolbar 
The Toolbar option is used to show or hide the toolbar located at the top of the screen. Hiding the 
toolbar allows more room for the graph being displayed. 

View Menu: Status Bar 
The Status Bar option is used to show or hide the status bar located at the bottom of the screen. Hiding 
the status bar allows more room for the graph being displayed.  

View Menu: Preferences 
Select Preferences to display the window shown below. 

The following six tabs are found in this window: File, Communications, Display, Data, Graph, and 
Calculations. Each tab creates the ability to set preferences for a part of the program. 
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File Tab 
Select the File tab from Preferences Form, to set the default file locations. 

Default Log File Location 
The Default Log File Location from the Preferences Form refers to the log files that are created while 
the software is running. Not all data loggers create a log file. The software appends a log file for each 
wireless transmitter when it receives a transmission. Through this option the user can change the default 
location where the log files are saved. 

Default INI File Location 
Select the Default INI File Location from the Preferences Form to refer to the initial settings the 
software will apply when it starts up. For those without read/write privileges, the INI File Location can 
be changed to a public folder for multiple users. 

Default Data File Type 
Select the Default File Type to choose from the list of file types in the drop down menu . The type can 
be changed when the file is saved, it is simply convenience setting. When checked, the data will be 
automatically be saved to the default file location that was selected in the file tab. 

NOTE: This is limited to the data that was downloaded from the device to the computer (see Read Device Data).  

Default Data File Location 
Select the Default Data File Location from the Preferences Form to refer to the folder that the datasets 
are saved to. When the user Saves a file, the chosen directory will be the default save location. This can 
be changed when the user saves the file, it's simply a convenience setting. 

Communications Tab 
This tab sets various Communications preferences. 

  

Autoconfigure Comm Port 
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Check this option to automatically configure the correct COM port in use to the host computer's . Leave 
this item checked unless the software is having trouble identifying the host computer's COM port (this 
happens rarely, usually only on older PCs). If this item is unchecked, the user must configure the Comm 
settings manually. See Select Comm Port.  

Autoconfigure Baud Rate 
Check this option to automatically configure the correct communications speed. Leave this item checked 
unless the software is having trouble identifying the host computer's COM port (this happens rarely, 
usually only on older PCs). If this item is unchecked, the baud rate must be configured manually. See 
Select Baud Rate.  

Accept Wireless Input 
Check this option to accept real time readings from the RF series of data loggers. To accept these 
readings the computer must have an RFC101A interface cable connected to an available COM port and 
the wireless RF logger or extender radios must be enabled to transmit. 

Communications Redundancy 
This refers to the number of times the PC will try to communicate with the logger. Setting the tab closer 
to the left will decrease the number of times it will try to communicate and setting the tab further to the 
right will increase the number of times it will try to communicate with the logger. 

Communications Timeout 
This refers to the length of time the PC will wait for the response from the data logger. Setting the tab 
closer to the left will decrease the amount of time the PC waits for a response, while setting the tab 
further to the right will increase the length of time the PC will wait. This setting is used when the user is 
has a device that takes a longer time to respond to the PC. 

Display Tab 
The Display Preferences Tab sets display time and language settings.  

  

Use 24 Hour Time Format 
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Check this box to use a 24-hour format. Leave it unchecked to use a 12-hour format. 

Use UTC Standard Time 
Check this box to use Universal Coordinated Time (UTC). Formerly known as Greenwich Mean Time 
(GMT).  

Use UTC Abbreviation Time 
Check this box to display the time zone that is relative to UTC time. If both the Use UTC Standard 
Time box and Use UTC Abbreviation Time box are unchecked then the system time of the PC will be 
displayed. 

Select Display Language 
Choose the language to be displayed on the software from the language drop down list. The software 
toolbar command also offers the language choice. 

Automatically Select Language  
Check the Automatically Select Language box to choose the restarted software language as the 
computer system language and ignore the selected language. Unchecked the restarted software language 
is always the selected language.  

Data Tab 
The Data Preferences tab can set various data preferences. 

  

Title Preferences 
The Title Preferences settings determine which items appear in the Title of the dataset. If all boxes are 
unchecked untitled dataset will appear as their title name. The Device Type, Device Serial Number, 
Device ID, Download Date, and Download Time can be selected or unselected. Check the Prompt for 
Title box to prompt for a title each time, rather than generating its own title. These features must be 
enabled prior to downloading the data for them to apply.
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Units Preferences 
The Units Preferences settings determine the units used for the various types of measurements. In Select 
Unit Type, select the type of measurement from the dropdown list, then Select Preferred Units to use 
from the second dropdown list. The high point and low point range can be defined on the graph. This 
defines the Preferred Scale. See Set Graph to Preferred Scale. 

Clear Unit Preferences 
Select the Clear Unit Preferences button to set all unit preferences to the [No Preference] setting. 

Automatically update units 
Check the Automatically update units option to allow preferred units to change when the corresponding 
units are changed on the screen. 

Apply units to all open data 
Check the Apply units to all open data option to trigger all corresponding units to change datasets on 
the screen. From this tab the graph preferences can be selected. 

Graph Tab 
In the Graph Preferences tab the graph preferences can be selected. 

  

Autoscale Graph 
Check the Autoscale Graph option to automatically optimize the vertical scale of the graph to match the 
minimum and maximum data points shown on the graph. This provides maximum resolution for viewing 
the graph. 

NOTE: The Composite Graph will have the Autoscale Graph option applied if there are multiple datasets that have the 
Autoscale Graph option applied and un- applied. 

Smart Autoscale 
Check the Smart Autoscale option to round the vertical and horizontal scales to a tenth of a decimal 
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point providing a slightly wider scaled range. If the option is off then the horizontal and vertical scales 
will be rounded to the thousandth. 

NOTE: The Composite Graph will have the Smart Autoscale option applied if there are multiple datasets that have the 
Smart Autoscale option applied and un- applied. 

Buffer Vertical Scale 
Check Buffer Vertical Scale option to add an extra 10 measurements to the beginning and end ranges of 
the vertical scale, making the plotted lines more centered in the graph. 

Autoscale on Zoom 
Check Autoscale on Zoom option to automatically scale the graph when zooming in using the horizontal 
zoom tool only. 

Synchronize Time 
Check Synchronized Time option to view multiple graphs which only affects the composite graph tab. 
When checked, multiple datasets will be shown over a scaled period of time through the composite 
graph. When unchecked the multiple datasets will instead overlap each other and the time shown is 
directly related to which graph the cursor has selected. 

Synchronize Vertical Scale 
Check Synchronize Vertical Scale option to view multiple graphs which only affects the composite 
graph tab. When checked multiple datasets are shown with scaled vertical ranges, meaning each 
parameter (temperature, humidity, etc.) will have one default set range for each parameter. When the 
option is unchecked each plotted graph will have its own individual scaled vertical range. 

Annotate Data 
Check Annotate Data option to permit all annotations be viewed on the computer screen, this option is 
beneficial when printing the annotations. When this option in unchecked, the data can still be annotated, 
yet it is not visible on the screen unless that data point has been clicked, whereas the annotation appears 
in the top left hand corner of the graph. 

Animate Graph 
Check the Animate Graph option to create blinking maximum and minimum alarm setting lines on the 
screen. 

Calculations Tab 
In Calculations Preferences tab various calculations preferences can be set. 

Edit Calculation 
Select the Edit Calculation button, the following window will appear:
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F0 
Select the F0 button to display the settings for F0, a common unit of sterilization. 

PU 
Select the PU button to display the settings for the Pasteurization Units. 
Select the Example button to show the user an example. The window will appear as follows: 

Example Calculation Screen 

  

View Menu: Engineering Units (Software level) 
This is a ELIWELL software feature which allows the customization of engineering units. These units 
are software level units (saved in the software specific to user's PC not the device) and their functions are 
the same as non-customized units. 

NOTE: There are two types of engineering unit levels (software and device). The user can manipulate the software level 
engineering units whenever the software is on, but the device level is only available to edit when the connected device 
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has engineering units attribute. See Device Level Engineering Units for details. 

Select Engineering Units from the View Menu to display the following window: 

  

Create Engineering Units by using the Engineering Units Wizard button or Create a new unit button 
on bar below. 

  

Engineering Units Wizard 
Select the Engineering Units Wizard button to bring up the Engineering Units Wizard window in the 
following screen. 
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The wizard will calculate the engineering unit based on the input. 

Edit Engineering Units 
If the box below is enabled the engineering units can be edited directly. Otherwise, choose the Create a 
new unit button or highlight a record from the Engineering Units List to enable this part first. 

  

Definition Graphs 
The Definition Graph compares Recorder Units and Scaled Engineering Units when data is input for the 
engineering units. 

Recorder Units 
Select a Recorder Unit must be selected, then input the low/high reference values. When no specific 
unit is displayed the Select a Recorder Unit dropdown list (Fig. 1) will contain all available units, 
otherwise, it will only contain the unit that relates to the displayed unit (Fig. 2) as shown below.
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Fig.1  

   
Fig.2  

Scaled Engineering Units 
The Scaled Engineering Units, screen shot of Edit Engineering Units, requests the description, label, 
and low/high unit values of the engineering unit. The description field allows the full name of the 
parameter to be displayed in the software. Examples of this are Volts, Milliamps, pH, Gallons, etc. This 
name is displayed on the graph and data table as the description of the data. The label field allows the 
label of the parameter to be displayed in the software. Examples are V, mA, pH, G, etc. The gain and 
offset fields are the equivalent of the "m" and the "b" respectively in the "Y = m * X + b" equation. X is 
the raw data from the device and Y is the data displayed by the software. Choose the Scaled 
Engineering Units dropdown list to select THE unit ID. If Use Next Available Unit ID is set as the 
default, the software will assign the next available unit ID to the created unit.  
If the checkbox Save these units when program closes, screen shot bottom of Edit Engineering Units, , 
is checked when the program closes, the created unit will be saved in the software after the software is 
closed. Otherwise, the created unit will be lost after the software closes. 

Engineering Units List 
The Engineering Units List tab will display all the customized engineering units. To Edit a record 
highlight it. The information will be displayed in the Edit Engineering Unit's Recorder Units section. 
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NOTE: The Show all units checkbox defines the status of both Engineering Units List tab and Use Next Available 
Unit ID dropdown list box. If checked, all available unit ID's will be displayed on both fields. The unit ID range is 0-
255. 

Standard Units List 
The Standard Units List tab will display all the available unit type(s) that can be used to make 
customized engineering units. 

 

 
The Communication Menu  

The Communication Menu displayed below: 

  

Communication Menu: Auto Configure Port 
Select Auto Configure Port from the Communication Menu to automatically indicate which 
COM/USB port the device is attached and which baud rate the device uses to communicate. This 
command operates only when an interface cable is connected to an available COM/USB port and a 
functioning data logger. If this command fails to find the device, then the device is not functioning 
properly or the interface cable is not properly connected. Once the software has identified the 
COM/USB port and the proper baud rate, the information will be stored in the configuration file. This 
command only needs to be activated once. If a different COM/USB port is later used, or if a device with 
a different baud rate is used, then re-select the command. 

Communication Menu: Select Comm Port 
Select the Comm Port to manually set/choose the communication/USB port in which to connect the data 
logger. The correct COM/USB port must be selected, or the software will not to communicate with the 

Página 24 de 60Software Help File

20/04/2007mk:@MSITStore:C:\Archivos%20de%20programa\Eliwell\Eliwell2.chm::/software.h...



data logger. To automatically configure this option, refer to Auto Configure Port. 

Communication Menu: Select Baud Rate 
Select the Baud Rate from the Communication Menu to manually set the speed to use to communicate 
with the data logger. The correct baud rate must be selected, to allow the software to communicate with 
the data logger. To automatically configure this option, refer to Auto Configure Port. 

 
The Device Menu 

The Device Menu will appear as shown: 

  

Device Menu: Identify Device and Read Status  
Select Identify Device and Read Status from the Device Menu to allow software to communicate with 
the attached data logger and display a window similar to this one: 
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Device Status Tab 
The Device Status tab displays the device type, revision number, serial number, Extender (user) ID, and 
operating parameters of the particular device in the Device Status dialog box. The serial number is set at 
the factory and cannot be changed by the software. The user ID can be selected when starting the device. 
This command will also verify that the software is able to communicate with the device and that the 
correct COM/USB port has been selected. If the device does not communicate, verify the following: 

1. Are the COM port and baud rate correct? 
2. Is there another device using the selected COM port, such as a modem or PDA? 
3. Is the device's battery dead? 
4. Is the PDLUSBIF cable connected to the correct COM port? 

In addition, this command will read and indicate the current status and all pertinent information of the 
device that is connected. This provides a quick method for determining the current state or status of a 
particular device. 

Device Detail Tab 
The Device Detail tab displays the details of the device. An example of a PDL10T data logger is seen in 
the screen below: 

  

The details include device type (device name as heading), revision number, subtype, and channel 
information. Information about Alarm Setting, Thermocouple Type, Engineering Units, Trigger Settings, 
Wireless Configuration, Wrap Around and Calibration will be displayed when the device supports these 
features. 

NOTE: When these features exist, a corresponding button will be displayed on the lower right side of the screen. An 
Alarm Settings & Calibration button are displayed in the example on the screen above. 

The following details are described as follows:
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Alarm Settings 
Select Alarm Settings to display an alarm setting screen that will permit the alarm range to be changed 
(see Alarm Settings for full operating instructions). 

Thermocouple Type 
Select Thermocouple Type to display a thermocouple type screen to specify which type of 
thermocouple is being used (see Thermocouple Type for full operating instructions). 

Engineering Units 
Select Engineering Units to display an engineering units screen to permit the type of units to be 
displayed on the graph to be defined (see Engineering Units for full operating instructions). 

Trigger Settings 
Select Trigger Settings to display a trigger setting screen that will permit the trigger range to be changed 
(see Trigger Settings for full operating instructions). 

Calibration 
Select Calibration to display a calibration screen to permit the device to be calibrated (see Calibration 
for full operating instructions). 

Thermocouple Type 
Select Thermocouple Type to display a thermocouple type window to request the input of the 
thermocouple type being used. This command is only available for devices that use thermocouples as the 
sensing element, such as the TC4000, TC110, QuadTemp, and OctTemp. The device will configure itself 
appropriately for the chosen type of thermocouple. The device requires this information to properly make 
temperature measurements and automatically perform the thermocouple cold junction compensation. 
Upon activation of this command, the software communicates with the device to determine if it has a 
programmable thermocouple attached. If it does, the following window appears: 

  

To change the thermocouple type, select the Change button. To commit the change, select Save to store 
the thermocouple type in the device. After selecting the thermocouple type, the temperature range for the 
chosen thermocouple is automatically displayed. 

Engineering Units (Device/Software level)  
The Engineering Units command is only available when a data recorder with this feature is connected to 
the host computer. Multiple engineering units can then be defined into multi-channel recorders. 

NOTE: If the software level engineering units does not have the record of device engineering unit, a new software level 
record of device engineering unit with an unique unit ID will be created when Identify Device and Read Status are 
performed. 
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1. Device Units 
The Device Units tab contain the engineering unit(s) of the device connected to the host PC. The Device 
Units Wizard button (1) will automatically edited the device's engineering units or it can be done 
manually using the Change device settings button (2). Save the changes into the device select the Save 
changes to device button (3). 

  

  

A. Device Units Wizard 
The Device Units Wizard will calculate the Device unit(s) based on the user's inputs. 
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B. Edit Device Units 
When Edit Device Units is enabled, the engineering units of the device can be edited directly. Otherwise 
the user needs to select the Change device settings button (2) (see buttons above) to enable this part first. 

NOTE: The Use portable units on this device checkbox defines the status of two dropdown list in the Device Units 
field. If it is checked then two dropdown lists will show all channels and portable units respectively. 

  

Enable Engineering Units 
The Enable engineering units on this device option indicates if the units programmed into the device 
should be displayed when data is downloaded. 

Prompt for unit selections on download 
The Prompt for unit selections on download option allows the stored information to be edited each 
time the data is uploaded. 

Portable Units 
The Portable Units tab contains description, label, gain, and offset fields. The description field is used to 
enter the full name of the parameter to be displayed in the software. Examples of this are Volts, 
Milliamps, pH, Gallons, etc. This name is displayed on the graph and data table as the description of the 
data. 
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The label field is used to enter the label of the parameter that is to be displayed in the software. Examples 
are V, mA, pH, G, etc. The gain and offset fields are the equivalent of the "m" and the "b" respectively in 
the "Y = m * X + b" equation. X is the raw data from the device and Y is the data displayed by the 
software. 

Device Units List 
The Device Units List tab shows all channels and their corresponding unit. 

  

NOTE: To assign the engineering unit to the specific channel select the channel and choose the record from Engineering 
Units List below. If the unit assigned to the channel is a software level (not device level) engineering unit then the Use 
portable units on this device option in Portable Units will be unchecked. 

  

Engineering Units List 
The function of the Show all units checkbox is described in Software Level Engineering Units List, see 
Engineering Units (software level). 

Página 30 de 60Software Help File

20/04/2007mk:@MSITStore:C:\Archivos%20de%20programa\Eliwell\Eliwell2.chm::/software.h...



  

Standard Units List 
The Standard Units List tab will display all the available unit types that can be used to make 
customized engineering units. 

  

2. Engineering Units 
The Engineering Units tab will be the same as Engineering Units Software level.  

  

NOTE: The edibility of the Device Units and Engineering Units tabs will be opposed so they cannot be edited at same 
time. 

Trigger Settings 
Select Trigger Settings from the Device Menu: Start Device or Identify Device and Read Status. This 
command is only available when the data recorder has the Trigger feature (PRTrans1000 and SVR101). 
The trigger screens offered depend on the type of data recorder connected to the host computer. Trigger 
screen samples are shown below. 

Trigger formats with one mode of operation fall into two types: With or Without settable sample count. 
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To edit trigger values, click the Change button. The values can be typed in directly, or changed using the 
slider control . 

NOTE: The high and low triggers cannot be disabled simultaneously.  

The values for the high or low trigger points can be set. Enable the high trigger to allow the acquisition of 
data to begin if the point is greater than the high set point. Enable the low trigger to allow the acquisition 
of data to begin if the trigger level is less than the low set point. The trigger sample can be set up to count 
by; 

1. Typing in their readings count number or  
2. Select Fill Memory on First Trigger option to get the maximum reading counts on a single 

event. 

Trigger formats with two trigger mode options fall into two types: Window and Two Point . 

Trigger Form 1: 
with 
sample count 

Trigger Form 2: 
without 
sample count 
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The values for the high or low trigger points can be enabled and set manually. Enabling the high trigger 
allows the acquisition of data if the pressure level is greater than the start high point and be stopped at the 
stop high point. Enabling the low trigger allows the acquisition of data if the pressure level is less than 
the start low point and be stopped at the stop low point.  

Two Point Mode allows for a High Trigger and Low Trigger. There will be two separate areas of 
pressure that can enable a trigger. 

Device Menu: Read Device Data  
To download the data from the device to the computer, select Read Device Data from the Device Menu. 
This command automatically downloads all the stored data from the device and displays it in both 
graphical and tabular format. The standard PDL10T will download data at approximately 120 readings 
per second. A progress bar located near the bottom of the screen gives a visual indication of how long the 
download will take. 

Trigger Form 3:  
Window, the function  
of this form is similar to Trigger 
Form 1. 

Trigger Form 4: 
Two Point Mode  
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NOTE: The data logger continues to record after the data has been downloaded. Use Stop Device to stop the data logger 
from taking readings. 

Device Menu: Quick Start 
Select Quick Start from the Device Menu to start the device without asking for any settings. It will use 
the previously set user ID and reading rate. This is useful for saving time, especially when programming 
multiple devices with the same parameters. 

Device Menu: Batch Start 
Select Batch Start from the Device Menu to display the following window: 

  

Device Parameters Tab 
The Device Parameters tab have similar functions as Start Device. The availability of Device ID field, 
Extended ID field, Reading Rate, and Wrap Around field (option available depending on device) depends 
on the selections in the Configuration tab. If the device has the alarm setting feature then a corresponding 
button will be displayed on the screen. An Alarm Settings button is displayed on the screen above.
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Configuration Tab 
The Configuration tab has five selectable parameters; Device ID , Extended ID , Reading Rate , Wrap 
Around, and Alarm Settings options. The availability of these fields depends on the features the device 
supports. 

Device ID 
Check the Device ID box to give the device up to a 6-character name in the Device Parameters tab.  

Extended ID 
Check the Extended ID box to give the device an additional 16-character name in the Device 
Parameters tab.  

Alarm Settings 
Click the Alarm Settings button to edit the alarm settings from the Device Parameters tab. 

Reading Rate 
Check the Reading Rate box to choose the reading rate from the Device Parameters tab. 

Wrap Around 
Check the Wrap Around box to choose the wrap around memory feature from the Device Parameters 
tab. 

Device Menu: Start Device  
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Select Start Device from the Device Menu to display the following window: 

  

NOTE: Starting the device will erase all readings currently stored in its memory. 

The Start Device window allows the start time and reading rate to be set. The Start Method setting may 
be used, along with the Start Now radio button, to start the data logger immediately. Alternatively, the 
user can select the Delay Start option to delay the start of data collection. The start time may be delayed 
up to six months from the current time. The Pushbutton Start option can be selected to start the data 
logger by pushing the pushbutton on the device. The push button must be pushed down and held for 
at least 3 seconds. 

When the device has a feature such as alarm setting, thermocouple type, trigger settings, wireless 
configuration and engineering units then a corresponding button will be displayed on the screen. An 
Alarm Settings button is displayed in the example below in the lower right hand portion of the screen.  

The reading rate can be selected to determine its data recording frequency. When selected, the maximum 
recording time will be calculated for the particular device, based on its internal memory capacity, and 
displayed in Log Time box. Once started, the device will continue to record readings until its memory is 
full, unless the Wrap Around feature is enabled. When full, the data recorder will stop recording 
additional readings, then place itself into a low power state to maximize battery life. The data stored in 
the data logger is always preserved (even in the case of battery failure) unless the device is reset or 
started. When re-started the existing readings are then overwritten. 

Device ID 
A Device ID may be entered in the space provided in any combination of six letters and/or numbers. The 
Device ID is written to the device and will appear in graphs or reports when the device is read later. Use 
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it for identification of the device or personnel linked to the device, etc. 

When all parameters/settings are set, press Start Device to program and begin recording data. 

Device Menu: Stop Device  
Select Stop Device from the Device Menu permits the software to communicate with the data logger and 
stop it from taking additional measurements. The data logger will enter a low power state to conserve 
battery life and when the memory is full. When full, the data recorder will stop recording additional 
readings and place itself into a low power state to maximize battery life automatically, this is simply a 
convenient way to extend the life of the battery. This mode is obvious to the user because the device will 
immediately wake up when the host computer communicates with the logger. When the device will not 
be used for a long period of time, stopping the device from collecting more data will conserve power to 
extend battery life. Stopping the device has no effect on the data in memory, the data is always retained.  

Device Menu: Reset Device  
Select Reset Device from the Device Menu to permit the software to communicate with the data logger 
device, and stop it from taking further measurements. This will also erase all readings currently stored 
in memory. Resetting the device will cause the data logger to enter a low power state to conserve battery 
life.  

Device Menu: Calibration 
Select Calibration from the Device Menu. All data logger devices can be calibrated through the 
software. This eliminates the need for opening the device or adjusting potentiometers. Calibration 
parameters, as well as the last calibration date, are stored within the device itself in non-volatile memory. 
This can be accessed through the software. It also allows the device to maintain calibration while being 
used on any computer. Most data loggers can be effectively calibrated using a single point to correct an 
offset. In some cases, two points may used to correct for gain and offset errors. The PDL10T uses a 
single point calibration. The calibration offset is defined as the value the device reads at zero. Thus, if the 
PDL10T reads 0.5ºC when the correct value is 0ºC, the user would enter 0.5ºC for the calibration offset. 
The 0.5ºC would then be subtracted from each reading downloaded from the device, and the data would 
be correct without any further manipulation. The PDL10T Calibration window shown below is displayed 
when the Calibration command is selected, and a PDL10T is connected to the interface cable. To edit 
the calibration values, click on the Calibrate button. The Default button may be used to return all values 
to their default settings (0.000 for offset values, and 1.000 for gain values.)  

Sample Calibration Screen 
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For convenience, a Wizard button is available. Select this button to display the Calibration Wizard, a 
series of screens with fields can be fill in regarding the behavior of the un-calibrated (all values set to the 
default) device. The wizard performs the calculations for the offset and/or gain values and puts them into 
the correct fields in the calibration window. To commit to any changes, select Save to store the 
calibration information in the device. The calibration is then saved, and the new calibration values are 
displayed on the screen. 

The Calibration Wizard 
The Calibration Wizard displays information which correlates to the type of device attached. The 
following screen is an example of a Temperature Gain/Offset calibration on the Temperature channel of a 
PDL10T device. To calibrate the device select the Next button, complete the required fields for each 
channel of the device, and select the Next button again until the Wizard highlights the finished button. 
Select the Finish button and the calculations are made and the correct values are placed into the 
Calibration windows. Select Save to save these values into the device. 

  

Device Menu: Alarm Settings 
From the Device Menu, choose Alarm Settings. This command is only available when a data logger 
with this feature is connected. This command allows the high and low temperature points to be set, this 
will trigger a visual alarm (flashing LED). The time delay can be set to trigger a visual alarm. These 
points should be set in the units indicated, 0 ºC is shown in the example below. To edit these alarm 
values, select the Change button, as shown in the window below:
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Select Save to store the values into the device. When the alarm values are stored into the device, they are 
rounded to the nearest alarm set point for that device. Once the alarm has been tripped (e.g. the 
temperature has gone outside the set limits), the LED will flash at a one second reading rate until the 
device is reset or the alarm is deactivated by the Alarm Settings Disable command. It is important to 
remember that the device only takes readings at its programmed reading rate. 
NOTE: If a temperature travels outside the set limits between readings, it will be missed by the device and the alarm will 
not become active. 

 
The Graph Menu 

The Graph Menu appears like this: 

  

Graph Menu: Show Summary 
Select the Show Summary command from the Graph Menu to display the Summary tab, which will 
appear as follows: 
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Sample Statistics for PDL10T 

Graph Menu: Show Composite Graph 
Select the Show Composite Graph command from the Graph Menu to display the Composite Graph 
tab, which will appear as follows: 
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The Composite tab displays a graph of one or more datasets. Datasets can be loaded by using the Open 
command from File Menu. Once loaded, they are displayed as graphs. 

To display the dataset(s) select one from the dropdown list at the top-right corner of the composite graph 
(see below). Select the checkbox next to the list to select or deselect the dataset(s) for display. 
Deselecting the dataset(s) does not unload it , it remains in memory and can be reselected at any time. 

  

To unload a dataset from the memory, select it from the dropdown list at the top-right corner of the 
composite graph. Select the X button on the right to unload the dataset (see below). Once a dataset is 
unloaded, it cannot be redisplayed without reloading it using the Open command from File Menu. 

  

To manipulate multiple datasets simultaneously select the ellipses (�)button in the middle to open 
Graph Configuration form (see below). 
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Deselect Dataset 
To deselect dataset(s) for display on the composite graph, uncheck them. 

Unload Dataset 
Highlight dataset(s) and press the Remove button to unload them from memory.  

Unload Data Set into Temporary Buffer 
Select the Remove button to place the unloaded dataset(s) in the temporary buffer, rather than unloading 
them permanently. They can be restored or reset. After selecting the Apply button or the OK button, the 
unloaded dataset(s) cannot be redisplayed without reloading them using the Open command from File 
Menu. 

  

Graph Menu: Show Graph 
Select the Show Graph command from the Graph Menu to display the Graph tab. This tab is similar to 
the Composite Graph except that only one dataset can be displayed at a time. 

NOTE: In order to save a dataset, it must be displayed in the Graph or Data tab. 

Graph Menu: Show Data Table 
Select the Show Data Table command from the Graph Menu to direct the software to display the Data 
tab as shown in the window below: 
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Data Tab 
The Data tab displays data in table format, to easily determine the exact value of each data point. 

Graph Menu: Select Graph Tool 
Select the Select Graph Tool command from the Graph Menu to enable the cursor mode which the 
mouse will assume when it is pointed and clicked over the graph. Several cursor modes are available, 
each with a specific function as follows: 

  

Cursor   
When the cursor mode is selected, 

1. Click on a data point of the graph to indicate the value. 
2. Click on or near a data point on the graph to indicate the value of the data point. 

The data point selected can be changed by navigating the cursor or; 
A. use clicking method. 
B. click and drag the mouse horizontally in the graph. 
C. use the functions (move left, move right) on the keyboard. 

Time Cursor   
When this cursor mode is selected, choose one of the following methods; 

1. Click and drag the mouse horizontally over the graph area or  
2. Use the arrow keys (left, right) on the keyboard, to indicate the time and value of each data point 

the cursor passes over. 

Scroll   
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Select the cursor mode to scroll the graph in any direction to view a particular section. To scroll the 
graph, click and hold the mouse button, then drag the mouse in the direction desired. When dragging the 
cursor a line with an arrow is drawn to indicate the direction and amount of the scrolling operation. When 
the mouse button is released, the graph is then scrolled in the direction and by the amount specified. 

Zoom In   
When this cursor mode is selected, click on the graph to Zoom In for a close-up view of a particular area 
of the graph. Multiple zooms may be performed to obtain best view. The software can only zoom in to a 
limited extent. If the zoom limit is reached, the following message will be displayed. 

  
Message Box 1: Warning for Zoom In 

Zoom Out   
When this cursor mode is selected, click on the graph to Zoom Out for an overall view of a particular 
area of the graph. Multiple zooms may be performed to obtain the best view. To avoid zooming out too 
many times a warning message may be set . This will reset the software. 

  
Message Box 2: Warning for Zoom Out 

Box Zoom   
Select the cursor mode, then click and drag on the graph to draw a rectangle. When the mouse button, is 
released the graph will Zoom In to obtain a close-up view of that area of the graph.  

Horizontal Zoom   
Select the cursor mode, then click and drag on the graph to draw a horizontal rectangle. When the mouse 
button is released, the graph will zoom in to get a close-up view of that area of the graph. 

Vertical Zoom   
Select the cursor mode, then click and drag on the graph will draw a vertical rectangle. When the user 
releases the mouse button, the graph will zoom in to get a close-up view of that area of the graph. 

Cancel Zoom   
Select Cancel Zoom to cancel any zoom modes. The graph will be redrawn in its default state. 

Graph Menu: Title Graph 
This feature will be disabled when no dataset is displayed on the screen. Otherwise, there are two ways to 
modify the title graph. 
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1. The title graph can be modified by selecting Title Graph from the Graph Menu or the Right Click 
Pop-Up Menu. The entering screen will appear as follows: 

  

2. Double click the graph title area, to highlight and modify it. 

  

Graph Menu: Annotate Data 
This feature will be disabled if there is no channel selected. Otherwise, there are two ways to annotate 
data. 

1. Select the Annotate Data menu from the Graph Menu or the Right Click Pop-Up Menu. The 
following screen will appear: 

  

2. Double click the annotate data area on the heading of the graph. Type the annotation in the box as 
shown below: 

  

Graph Menu: Autoscale Graph  
Select the Autoscale Graph command from the Graph Menu to optimize the vertical scale of the graph 
to match the minimum and maximum data points shown on the graph. This provides maximum 
resolution for viewing the graph. 
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Graph Menu: Set Graph to Preferred Scale  
Select Set Graph to Preferred Scale command from the Graph Menu to set the graph to the preferred 
scale.  

If no preferences are set, the graph will show on the vertical scale, the measurement range of the device 
(this may differ from the rated operating range shown on the label of the device). The time scale will 
begin when the first reading was taken, and end when last reading was taken. 

Graph Menu: Synchronize Graph Scale  
Select the Synchronize Graph Scale command from the Graph Menu to synchronize the time and value 
axes of the graph. 

Graph Menu: Select Graph Units 
Select the Select Graph Units command from the Graph Menu to select the units to be used when 
displaying the graph. The available units will vary depending on the type of data logger used. For 
example, the PDL10T reads temperature and provides units of degrees Celsius (ºC), Fahrenheit (ºF), 
Rankin (ºR) or Kelvin (K). The PDL10TRH records temperature and humidity and has available 0 ºC, 0 
ºF, 0 ºR, and K for the temperature reading, and %RH, Dew Point and Water Vapor Concentration for the 
humidity reading.  

Graph Menu: Set Graph Scale  
Select the Set Graph Scale command from the Graph Menu to manually change and specify the values 
of the vertical and horizontal axis. The following three screens are shown for each of the tabs: 

Time Tab 

 

Scale Tab 
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NOTE: In order to enter the low value or the high value of the unit a unit from the Select Units dropdown list box must 
be selected first. There is no unit selected if the value of the Select Units dropdown list box is No Units Selected. 

Axis Tab 

 

Different data recorders will show a slightly different window depending on the number of channels and 
the parameters being recorded. Scaling of the horizontal axis is controlled by the Select Time Range 
section. To set the end points of the horizontal axis, select the specified endpoints from the dropdown 
date and time selectors. The vertical axis is set using the Vertical Scale Tab.  

Graph Menu: Format Graph  
Select the Format Graph command from the Graph Menu to show the following window: 
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Edit Formatting Options to apply formatting to the single graph, the composite graph, or both. 

Graph Format Tab 
Select the Graph Format tab to set the background color for the entire graph, as well as the color and 
number of the major and minor grid lines. Changes are applied to the dataset selected at the top of the 
frame. 

The Data Format looks like this: 
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Data Format Tab 
This window allows the user to customize the look of the graphical data for each dataset. First, select the 
dataset to customize from the dropdown list. Choose the channel from the second dropdown list (some 
devices have multiple channels). Then, select the thickness of the line, line color, symbol style, and 
symbol color from the remaining dropdown lists. Finally, select the symbol size and frequency (see 
Manipulate Plotting Symbol) and whether the channel should be visible or not (see Hide Selected 
Channel and Show Hidden Channels).  

Manipulate Plotting Symbol 
The Select Symbol Size slider and the Select Symbol Frequency slider are used to manipulate the 
plotting symbols. The zero setting removes all plotting symbols, and higher settings will approximately 
double the number of symbols on the graph as the slider is moved up one notch. 

Hide Selected Channel 
Uncheck the Channel Visible option to hide the selected channel or choose the Right Click Pop-up 
Menu to hide the selected channel.  

Show Hidden Channels 
Check the Channel Visible option to show the hidden channel. Click OK., the graph will be immediately 
redrawn with the option chosen. Choose The Right Click Pop-Up Menu to show the hidden channel also. 

Graph Menu: Copy Data To Excel.  
Select Copy Data To Excel. to allow the software to launch the Microsoft Excel. spreadsheet program, 
and copy the current dataset to an Excel. worksheet. This command will only work with a compatible 
version of Excel. properly installed on the host computer.
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Graph Menu: Device Detail 
Select the Device Detail command to display the device details of the selected dataset. This will include 
device type, revision number, subtype, and channel information. Information about alarm setting, 
thermocouple type, wireless configuration, wrap around and engineering units may also be displayed if 
the device supports those features. The window is similar to Identify Device and Read Status features. 

Select the Alarm Setting button from the Device Detail tab to display a read-only alarm setting screen to 
show the alarm range. This command is only available when the selected dataset is generated from a 
device that has this feature. 

  

Select Thermocouple Type button from the Device Detail tab to display a read-only thermocouple type 
screen. This command is only available when the selected dataset is generated from a device that has this 
feature. 

  

Select Calibration button from the Device Detail tab to display a read-only calibration form that shows 
the user the device of the selected dataset calibration information. 
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Select the Engineering Units button from the Device Detail tab to display a read-only engineering units 
screen. This command is only available when the selected dataset is generated from a device that has this 
feature. 

  

Graph Menu: Statistics 
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Select the Statistics command to calculate some basic statistics for data on each individual channel. A 
typical screen for some calculated statistics for the temperature channel of a PDL10T might appear as 
follows: 

  

For data recorders with more than one channel, the Next and Previous buttons will be available. This 
allows the user to quickly view the statistics on each channel. In the example for the PDL10TRH, 
activating the Next button will update the dialog box with the statistics for the humidity channel. 

 
The Right Click Pop-Up Menu  

The Right Click Pop-Up Menu incorporates menus from the Graph Menu. It provides a convenient way 
to manipulate the graph. It will show different pop-up menus depending on the position of the mouse on 
the screen. 

The Right Click Pop-up Menu will appear 1 of 2 ways (see window #2): 

Window #1: 
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Submenu A 
Click the Title Graph submenu to modify the title graph (see Title Graph ). 

  

Click the Annotate Data submenu to modify the Annotate Data (see Annotate Data). 
Click the Show Summary, Show Composite Graph, Show Graph, and Show Data options to bring up 
the Summary, Composite Graph, Graph, and Data tabs, respectively. 

Submenu B 

Highlight Select Graph Tool to change the cursor mode (see Select Graph Tool). 
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Highlight Select Graph Units to change the type of scaling units (see Select Graph Units). 

 

Highlight Graph Scale to bring up the following box. 

 

Click the Autoscale Graph option to automatically optimize the vertical scale of the graph (see 
Autoscale Graph). 
Click the Set Time Scale submenu to display a time scale setting form (see Set Graph Scale). 
Click the Set Vertical Scale submenu to display a vertical scale setting form (see Set Graph Scale). 

Highlight Graph Format to bring up the following box: 

 

Click Format Graph to display a graphic format setting form (see Format Graph). 
Click Format Data to display a data format setting form. 
Click the Show Hidden Channels to show all hidden channels in the graph. 
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The Hide Selected Channel is available when there is a channel selected on the screen. The Hide 
Selected Channel function, in the Graph Format menu to hide the selected channel. 

Submenu C 

  
Select the Select Axis Labels to bring up the Set Graph Scale box, under the Axis Labels tab. The user 
can choose which vertical labels are shown and whether they will be shown on the left or right sides. 

Use 24 Hour Time Format, Use UTC Standard Time, or Use UTC Abbreviation to change the way 
the time is viewed (see display preferences).  

Window #2:  

The Right Click Pop-up Menu will appear below if there is no channel selected on the screen by the 
user. 
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Here the Right Click Pop-up Menu is similar to Window #1 with two differences:  
1. The submenu Annotate Data is not available. 
2. The submenu Hide Selected Channel is not available in Graph Format menu. 

 
The Window Menu 

The Window menu looks like this: 

  

Window Menu: Stack 
Choose Stack from the Window Menu to resize all the open graph windows to take up the whole main 
window and are to stack (overlay) on top of each other. 

Window Menu: Cascade 
Select Cascade from the Window Menu to resize all the open graph windows to a medium size, and then 
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positions them in a staggered layer, one on top of the other, to maintain the title bars are visible. 

Window Menu: Tile Horizontal 
Select Tile Horizontal from the Window Menu to rearrange the open graph windows, to make fully 
visible and to align horizontally next to each other with no overlapping. 

Window Menu: Tile Vertical 
Select Tile Vertical from the Window Menu to rearrange the open graphs windows to make fully visible 
and to align vertically next to each other with no overlapping. 

Window Menu: Selected File 
When only one graph menu with multiple data sets is open, the line will show the selected tab that is 
open in the graph menu. 

When multiple open graph menus are open with different data set(s) in each one, all the file names will 
be listed under this option. This method allows a desired graph to be viewed. 

 
The Help Menu 

The Help Menu looks like this: 

  

Help Menu: Contents 
Select Contents from the Help Menu to bring up the Help window, and presents the Table of Contents 
for the online manual. 

Help Menu: About 
Select About from the Help Menu to bring up the About window, and presents information about the 
company and the software version. This screen includes the ELIWELL address, phone number for 
technical information, e-mail address and web site. It also includes the full revision number of the 
software and the date of release. 
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Terms and Conditions 

All products furnished by ELIWELL ("Seller") shall be in accordance with the following terms and 
conditions unless otherwise stated in writing: 

These Terms and Conditions ("Terms and Conditions") govern (a) all sales quotations and sales of 
components, equipment, parts, and other products ("Product") from, and (b) all service proposals and 
provisions of services by Seller to the buyer of the Products ("Buyer"). These Terms and Conditions shall 
take precedence over any terms and conditions which appear on Buyer's order or other form or any other 
writing or electronic transmission from Buyer. Any terms or conditions on any of Buyer's forms, 
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recordings, electronic transmissions, or orders that are different from or in addition to these Terms and 
Conditions are specifically rejected. Any modification to these Terms and Conditions must be agreed to 
and executed in writing by Seller. Seller's failure to object to provisions contained in any communication 
from Buyer shall not be construed as a waiver of these Terms and Conditions or as an acceptance of any 
such provision. Trade custom, trade usage and past performance are superseded by these terms and 
conditions and shall not be used to interpret these terms and conditions. In the event that Product includes 
software, the software is licensed to Buyer in object code form only in accordance with Seller's standard 
Software License Terms that are included below. 
 
Limited Warranty. 

A. Seller Manufactured Products and Seller Provided Services. Seller warrants to Buyer that (i) Seller 
manufactured Software (as defined in Section 23 below) shall execute the programming instructions 
provided by Seller, and (ii) Seller manufactured Product and consumables and Seller provided services 
shall be free from material defects in material and workmanship under normal uses and care, in each case 
until the expiration of the applicable warranty period specified below. Seller manufactured Product is 
warranted for the shorter of twelve (12) months from the date of initial installation or fifteen (15) months 
from the date of shipment by Seller. Seller manufactured consumables and Software, and Seller provided 
services are warranted for a period of ninety (90) days from the date of shipment or completion, as 
applicable. If Buyer discovers any warranty defect and notifies Seller thereof in writing during the 
applicable warranty period, Seller shall, at its option, promptly correct any defects that are found by 
Seller, or repair or replace F.O.B. point of manufacture that portion of the Seller manufactured Products, 
consumables or Software found by Seller to be defective, or refund the price of the defective portion of 
the Seller manufactured Products, consumables or Software, or of the defective portion of the Seller 
provided services. All replacements or repairs necessitated by inadequate maintenance, normal wear and 
usage, unsuitable power sources, unsuitable environmental conditions, accident, misuse, improper 
installation, modification, repair, storage or handling, or any other cause not the fault of Seller are not 
covered by this limited warranty, and shall be at Buyer's expense. Seller shall not be obligated to pay any 
costs or charges incurred by Buyer or any other party except as may be agreed upon in writing in advance 
by an authorized representative of Seller. All costs of dismantling, re-installation and freight, and the 
time and expenses of Seller's personnel for site travel and diagnosis under this limited warranty shall be 
borne by Buyer unless accepted in writing by Seller. Seller manufactured Products, consumables and 
Software, and Seller provided services, repaired, replaced or corrected during the applicable warranty 
period shall be in warranty for the greater of the remainder of the applicable original warranty period or 
ninety (90) days. THE FOREGOING STATES THE SOLE AND EXCLUSIVE WARRANTY AND 
LIABILITY OF SELLER. FOR BREACH OF WARRANTY AND IS IN LIEU OF ALL OTHER 
REPRESENTATIONS, WARRANTIES AND COVENANTS, EXPRESSED OR IMPLIED, IN 
REGARD THERETO. EXCEPT FOR THE EXPRESS LIMITED WARRANTY SET FORTH IN THIS 
SECTION, SELLER DOES NOT MAKE AND HEREBY DISCLAIMS ANY AND ALL OTHER 
REPRESENTATIONS AND WARRANTIES OF ANY KIND WHATSOEVER, WHETHER 
EXPRESSED, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION, ANY 
IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, 
NONINFRINGEMENT OR ACCURACY, ADEQUACY OR COMPLETENESS OF DATA 
MEASUREMENT, WITH RESPECT TO ANY OF THE SELLER MANUFACTURED PRODUCTS, 
CONSUMABLES OR SOFTWARE, OR ANY OF THE SELLER PROVIDED SERVICES. Any 
drawings submitted with the Products are only to show the general style, arrangement, and approximate 
dimensions of the Products.  

B. Equipment, Consumables, Software and Services Manufactured or Provided by Others. SELLER 
DOES NOT MAKE, AND HEREBY DISCLAIMS, ANY AND ALL REPRESENTATIONS AND 
WARRANTIES OF ANY KIND WHATSOEVER, WHETHER EXPRESSED, IMPLIED OR 
STATUTORY, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF 
MERCHANTABILITY PARTICULAR PURPOSE, NONINFRINGEMENT OR ACCURACY, 
ADEQUACY OR COMPLETENESS OF DATA MEASUREMENT, WITH RESPECT TO ANY 
EQUIPMENT, COMPONENTS, PARTS, CONSUMABLES, SOFTWARE OR SERVICES SOLD TO 
BUYER BY SELLER. THAT ARE NOT MANUFACTURED OR PROVIDED BY SELLER. Seller 
shall assign the manufacturer's or service provider's warranty applicable to such equipment, components, 
parts, consumables, Software and services to the extent permitted, to Buyer. Seller will provide Buyer 
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with available warranty information. 

Limitations.  
IN NO EVENT, REGARDLESS OF THE FORM OF THE CLAIM OR CAUSE OF ACTION 
(WHETHER BASED IN CONTRACT, INFRINGEMENT, NEGLIGENCE, STRICT LIABILITY, 
OTHER TORT OR OTHERWISE), SHALL SELLER's LIABILITY EXCEED THE PRICE 
ACTUALLY PAID BY BUYER TO SELLER FOR THE SPECIFIC PRODUCTS, CONSUMABLES 
AND/OR SOFTWARE MANUFACTURED, AND/OR SERVICES PROVIDED, BY SELLER GIVING 
RISE TO THE CLAIM OR CAUSE OF ACTION. SELLER SHALL NOT, UNDER ANY 
CIRCUMSTANCES, BE LIABLE FOR ANY LOSS OF REVENUE, LOSS OF PROFITS OR ANY 
INCIDENTAL, INDIRECT, SPECIAL, EXEMPLARY OR CONSEQUENTIAL DAMAGES, 
WHETHER OR NOT FORESEEABLE. NO ACTION, REGARDLESS OF FORM, ARISING OUT OF 
ANY TRANSACTION GOVERNED BY THESE TERMS AND CONDITIONS, MAY BE BROUGHT 
BY EITHER PARTY MORE THAN TWO (2) YEARS AFTER THE CAUSE OF ACTION HAS 
ACCRUED. The foregoing allocation of risk and limitation of liability has been agreed to by the parties 
and forms the basis of their willingness to enter into any accepted order.  

Software License.  

(A) For purposes hereof, "Software" means the computer programs included in the Product at 
delivery, together with all codes, techniques, software tools, formats, designs, concepts, methods, and 
ideas associated with those computer programs. The term also includes all copies of any part of the 
software, as well as the manual(s) and printed materials provided by Seller.  

(B) Seller grants Buyer a non-exclusive, non-transferable license to use the Software, in object code 
form only, according to the terms set forth below. Buyer may operate the Software only (i) in conjunction 
with and as part of the Product; (ii) in the manner in which it is intended by Seller; and (iii) at Buyer's 
plant site where the Product is first used. Buyer may negotiate with Seller separate licenses to use the 
Software at other plant sites. Buyer's use of Software shall be governed exclusively by Seller's and/or an 
third party owner's applicable license terms. 

(C) Buyer shall not (i) make the Software available to any person or entity other than its employees, 
who must use the Software only as specified above; (ii) modify the Software or merge it with another 
program; (iii) reverse engineer, disassemble, decompile, or make any attempt to discover the source code 
of the Software; (iv) translate or create derivative works based on the Software; (v) remove, obscure, or 
alter any notice of the patent, copyright, or other proprietary rights related to the Software; (vi) sub-
license, sell, lend, rent, or lease any portion of the Software; (vii) copy any portion of the Software; (viii) 
operate the Software other than in conjunction with operation of Product; or (ix) transfer the Software in 
violation of applicable United States Export laws and regulations. 

(D) The Software involves valuable proprietary rights to Seller and others. There is no transfer to 
Buyer of any title to or any ownership of the Software or any patent, copyright, trade secret, trade name, 
trademark, and other proprietary rights related to the Software, regardless of the form in which they exist. 
Seller may at any time replace, modify, alter, improve, enhance, or change the Software.  

(E) Both the license and Buyer's right to use the Software terminate automatically if Buyer violates 
any of these Terms and Conditions. In the event of termination, Buyer must immediately return, or 
destroy, all copies of the Software. 
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