El Setup de instalacion, las actualizaciones de software, librerias y documentacién también se encuen-
tran disponibles en nuestra web www.eliwell.it previo registro en el Area Reservada
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La solucién de software integrada en una tnica Suite para una programacién
sencilla y rapida
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INTRODUCCION [[[ | free]
DESCRIPCION GENERAL

3 N
La herramienta de desarrollo FREE Studio permite realizar y personalizar de .
modo rapido y eficaz nuevos programas para cada tipo de aplicacién IEC, en ‘Illm Stu d Io
particular para las necesidades del sector HVAC/R.
El uso de varios lenguajes de programacién segin las normativas
IEC61131-3 (estandar de programacién para el control industrial), le permite
la posibilidad de desarrollar nuevos algoritmos o programas completos con

total autonomia, que se descargan a los médulos IEC 61 1 31 '3

e  FREE Smart mediante PC o Multi Function key

*  FREE Evolution mediante PC o USB development
garantizando al méximo su confidencialidad mediante las debidas proteccio- .
nes. environment

N J
COMPONENTES

A continuacion se repasan todos los componentes basicos, interfaces, convertidores y accesorios!'l.

Software FREE Studio

La suite de software FREE Studio'?' y sus funciones se exponen en el presente documento.

La suite de software FREE Studio se compone de 5 entornos de desarrollo necesarios para la programacion de los controles

programables FREE Smart, FREE Panel & FREE Evolution:

e  FREE Studio Application, especifico para los desarrolladores, para la creacién / gestion de librerias y aplicaciones IEC y
diagnésticos.

e FREE Studio Device, disefiada para los usuarios, para la gestion de aplicaciones IEC anteriormente desarrolladas, la
descarga de las mismas al dispositivo target® y la modificacién de los pardmetros del instrumento desde serial.

e FREE Studio Simulation, especifico para desarrolladores, para la ejecucion de aplicaciones PLC y paginas HMI (solo
Evolution) en un entorno de simulacién sin necesidad de disponer de un dispositivo target*!

Los siguientes 2 entornos de desarrollo se hallan disponibles solo para FREE Evolution:

e FREE Studio Connection!®!, especifico para desarrolladores, para la configuracién de redes

e  FREE Studio User Interface, especifico para desarrolladores, para la personalizacion de la interfaz gréfica de los termina-
les 'built-in' y de los demas terminales.

DM Interface (DMI)

Componente necesario solo para FREE Smart:

Componente necesario para conexién a PC

La Interfaz de hardware USB/TTL-12C DMI, que se utiliza asociada a la suite de software permite:
e  Eluso del software mismo.

e Conectarse al dispositivo target para su gestién.

e Conectarse al componente Multi Function Key (MFK).

Multi Function Key (MFK)

Componente necesario solo para FREE Smart:

Soporte de memoria que permite:

1. Actualizar el firmware del dispositivo target.

2. Actualizar la aplicacién IEC del dispositivo target.

3. Actualizar los valores de los pardmetros del dispositivo target.
4. Descargar del dispositivo target los valores de los pardmetros.

Cables de conexién

Componentes necesarios solo para FREE Smart:

e Cable de color “amarillo” con terminaciones JST - molex, para su uso ver cap. Modalidad de conexion
e Cable de color “azul” con terminaciones JST - JST, para su uso ver cap. Modalidad de conexion

e Cable de prolongacion USB-A/A de 2 m.

Convertidores

Componentes necesarios solo para FREE Evolution:
e adaptador USB/485
adaptador USB/CAN

Las interfaces y los convertidores se utilizan con Smart o Evolution.

Suite o paquete de software. Ver Abreviaciones y definiciones

Control programable. Ver Abreviaciones y definiciones

Sin la necesidad de disponder de un Smart o Evolution fisico se puede descargar una aplicacién IEC directamente al Simulador.
Solo para Evolution: Connection es ‘el punto de partida' de la Suite software - ver capitulo Target

ARhWN=
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Nota: como alternativa, si dispone de un puerto R§232 se puede conectar Evolution al PC mediante un adaptador RS485/
RS232

Plug-in (Evolution)
Una amplia gamma de mdédulos plug-in con montaje 2DIN permite su integracion en sistemas industriales y BMS y redes

ethernet.
Nota. no disponibles para FREE Panel, que dispone de 3 seriales RS485, CAN y ETHERNET a bordo.

Abreviaciones y definiciones

e Application, Device, Connection, Simulation, Userlnterface: abreviaciones de FREE (Studio) Application, FREE
Device, FREE Connection, FREE Simulation y FREE UserInterface respectivamente. Suite de Software.

e Aplicacién IEC, Aplicacién PLC, PLC: aplicacion realizada segiin normativas IEC61131-3 (estdndar de programacion
para el control industrial) mediante el entorno (tool) de desarrollo Application que se descarga en el target mediante
Application o Device

e dispositivo Target, Target: nombre que se le da al control programable FREE Smart, FREE Evolution o FREE Panel /

(EVP), es decir el “instrumento”

DMI: abreviacién de DM Interface

HMI: acrénimo de Human Machine Interface. Interfaz gréfica desarrollada con UserInterface

Instancia: objeto de una 'clase’ de objetos predefinida (bloque de funcién, plantilla, etc)

Lenguaje IEC: lenguaje de programacién segun la normativa IEC61131-3

Menu BIOS, BIOS: menU de parametros BIOS pre-configurado en fabrica. No es modificablel®!

MFK: abreviacion de Multi Function Key

Quick Start: el presente documento

Smart: abreviacion de FREE Smart; Evolution: abreviacion de FREE Evolution; EVP: abreviacion de FREE Panel

Studio: abreviacion de FREE Studio. Suite de Software descrita en el presente documento.

Tab o pestaiia. El entorno de trabajo se halla dividido en secciones o paneles. Cada panel puede ser subdividido a su

vez en pestanas o tabs (ej. tab Resources)

¢ Template: en el presente documento se entiende que es la plantilla de una péagina realizada con Userlnterface

e Panel o seccion: ver Tab (ej. panel Project)

Nota: Muchas definiciones o abreviaciones son estandar del lenguaje informética y/o PLC y no aparecen en este listado

Por ejemplo una Funcion es un término estandar. Otros términos, como Bloque Funcién sse describirédn en sus correspon-

dientes apartados.

ATENCION:

El presente documento Quick Start (Guia Rapida):

® se ha concebido para proyectistas y desarrolladores y presupone el conocimiento de uno o varios lenguajes estandar
de programacién IEC61131-3.

* se harealizado para proporcionar una panoramica de primer nivel de la instalacion, funciones y utilizacion de la suite
FREE Studio

e presupone la lectura del manual de instalacién FREE Smart cod. 9MAX00036 y/o del manual de instalacion FREE Pa-
nel cod. 9MAxX00046 y/o del manual FREE Evolution cod. 9MAx00042 (x = 0: IT; 1: EN; 3: ES; 5: DE) disponible solo
en formato electrénico (pdf) en nuestra web www.eliwell.it previo registro en el Area reservada.

e esta disponible solo en formato electrénico (pdf) en nuestra web www.eliwell.it previo registro en el Area reservada

RECURSOS DE SISTEMA

El desarrollador dispone de los siguientes recursos disponibles en los target para la programacion IEC

Smart Evolution

CPU
memoria disponible
para Application

memoria disponible
para User Interface

memoria FLASH datos
memoria RAM*
memoria RAM**
variables EEPROM

* mapeado automético
** mapeado Modbus

6 La BIOS no es modificable pero puede actualizarse.
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SISTEMAS OPERATIVOS

Windows XP Home SP2 o SP3 italiano, inglés, espariol y aleman.
Windows XP Professional SP2 o SP3 italiano, inglés, espafiol y aleman.
Windows 7 Home Premium italiano, inglés, espafol y aleman.
Windows 7 Professional italiano, inglés, espafiol y aleman.

Windows 7 Ultimate italiano, inglés, espafiol y aleman!l.

OTROS SOFTWARE
(solo FREE Smart)
Driver AT90USBxxx CDC USB to UART MGM para la utilizacién de la interfaz DMI2!

Ver capitulo Instalacién Interfaz DMI

HARDWARE MINIMO

Resolucion grafica 1024x768

CPU 700MHz

RAM 1GB

HD 5GB de espacio libre en disco

1 puerto USB!3!

Ratén o sistema puntero equivalente.
1 lector CD-RW

Nota. La instalacién tipica (que se halla disponible en idioma inglés, librerias estdndar) requiere unos 500 Mbyte de espacio en
disco. Se necesita un 1GByte de espacio libre adicional en disco para la instalacién de las librerias y aplicaciones especificas.

Para la descarga de la aplicacion se necesitan los siguientes componentes:

HARDWARE FREE SMART Y ACCESORIOS

1 FREE Smart SMD5500/C/S o un dispositivo target de la familia FREE Smart
1 DMI 100-3 Manufacturer + cable amarillo TTL"

1 MFK opcional + cable azul TTL

cableado para alimentacién FREE Smart'®

HARDWARE FREE EVOLUTION Y ACCESORIOS

e 1 FREE Evolution EVD7500/U o pedir el maletin simulador para demostraciones (Demo Case)
e 1 convertidor USB/RS485 o USB/CANOpen o plug-in Ethernet
e transformador 35VA para alimentacién FREE Evolution

INTERNET

El Setup de instalacién se suministra en CD-RW.

El Setup de instalacién, la actualizacion de software, librerias y documentacion también se encuentran disponibles en el sitio
www.eliwell.it previo registro en el Area Reservada (ver capitulo Soporte Tecnico).

Compruebe la disponibilidad de la conexién a Internet para el acceso al software y manuales.

1 Para todos: otros idiomas no han sido explicitamente testados.

2 Disponible en el paquete de instalacion.

3 Para Evolution también se puede utilizar un puerto RS232 mediante el convertidor RS232/RS485.
Para Smart (solo versiones /S) se puede utilizar el puerto RS232 mediante el convertidor R$232/RS485 con velocidad maxima 19200 baudios.
TTL en este caso no es utilizable.

4 Ver capitulo Modalidad de conexién

5 No es necesario alimentar FREE Smart si esta conectado al PC mediante DMI. Utilice cable TTL amarillo.
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INSTALACION FREE STUDIO

Ejecute EliwellFREEStudio_xxx.exe!"! suministrado por Eliwell y a continuacién proceda con el asistente de instalacion (en
inglés) tal como se indica en las pantallas siguientes.

1. Haga click en 'Next’
2. Haga click en 'l accept the agreement’'? es decir acepte las condiciones de uso para la licencia del software
3. Haga click en ‘Next'. Al finalizar la instalacién apareceré el icono FREE Studio en el Escritorio.
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4. Haga click en ‘Install’.
5. Instalacién en progreso
6. Haga click en ‘Finish’.
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ICONOS APLICACIONES
Haga click en el icono FREE Studio del Escritorio; se accedera a una carpeta con los siguientes links.
Iconos D ... Iconos D ...
escripcion escripcion
(link) P (link) P
herramienta desarrollo herramienta desarrollo
L] Application g Connection
para Smart & Evolution para Evolution
herramienta desarrollo herramienta desarrollo
- Device User Interface
para Smart & Evolution para Evolution

herramienta desarrollo
Simulation
para Smart & Evolution

1 Comprobar como precaucién la versién de software con el Soporte Técnico de Eliwell
2 Para proseguir con la instalacién es obligatorio aceptar la licencia de uso.
Lea atentamente las condiciones de uso descritas (End User License Agreement 'EULA') antes de continuar.
Las condiciones de uso también estan disponibles en nuestra web en la direccién http://www.eliwell.it/content.aspx?id=4533
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La Suite de software Studio ha sido disefiada para su utilizacién con los target Smart, Panel y Evolution
La seleccion del dispositivo target adecuado para las necesidades del desarrollador se indican el capitulo Definicién de Re-
quisitos Hardware

FREE WAY

La Suite de software Studio es una sola para Smart, Panel y Evolution.
El sistema conjunto se denomina FREE Way: el software FREE Studio + el hardware FREE Smart, Evolution y Panel
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Smart Panel Evolution

FREE SMART

El desarrollador de Smart tiene a su disposicidn solo los entornos de trabajo Application y Device!"

El desarrollador de Smart para empezar a programar puede lanzar Application.

El usuario de Smart para descargar la aplicacién IEC anteriormente compilada por el desarrollador podra utilizar Device.
Desde Application siempre puede abrir directamente Device sin tener que lanzar el programa con el icono FREE Studio.

FREE EVOLUTION

El desarrollador de Evolution tiene a su disposicién todos los entornos de trabajo.
El desarrollador de Evolution para empezar puede lanzar Connection. Connection es el punto de partida para todas las activi-

dades de desarrollo, desde la programacién PLC , a la creacién del mend HMI hasta la descarga en el target mediante Device.
Desde Connection siempre puede abrir directamente tanto User Interface como Application y Device sin tener que lanzar su
correspondiente programa mediante el icono FREE Studio.

FREE PANEL

El desarrollador de Panel tiene a su disposicion todos los entornos de trabajol?.
El desarrollador de Panel para iniciar podréa lanzar Connection. Connection es el punto de partida para todas las actividades

de desarrollo, desde la programacién PLC , a la creacién del mend HMI hasta la descarga en el target mediante Device. Desde
Connection siempre puede abrir directamente tanto User Interface como Application y Device sin tener que lanzar su corre-
spondiente programa mediante el icono FREE Studio.

1 Incluyendo Simulation
2 Excluyendo Simulation
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INSTALACION DM INTERFACE (DMI)™

CONEXION DE LA INTERFAZ DMI AL PC

Conecte la interfaz DMI a uno de los puertos USB del PC.
Para facilitar la conexién de la interfaz le aconsejamos que use el alargador USB suministrado.

SETUP INTERFAZ DMI

El sistema operativo Windows XP®2l en el momento de la conexién de la interfaz DMI pone en marcha un procedimiento guia-
do para su instalacién. A continuacién le indicamos los pasos a seguir.

—_

En la pantalla de arranque seleccione la opcién “No, no ahora” y pulse “Siguiente".
2. Configure la segunda opcidn, como se indica, y pulse “Siguiente”.

El itinerario que se ha de especificar es el del directorio de instalacién del programa.
3. Pulse ‘Siguiente’ y/o busque con ‘Examinar’ el itinerario indicado.
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4. Elsistema operativo le pediré la confirmacion de la instalacion de los drivers.
Pulse "Continuar”il.
5. Cuando el sistema operativo reconozca el dispositivo (driver) como "AT90USBxxx CDC USB to UART MGMI Y, pulse “Fin”.
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Esta operacion se realiza tras la instalacion de Studio. Instalacion necesaria exclusivamente para Smart

En otros S.0. la instalacién es idéntica

Ignore el mensaje de advertencia sobre compatibilidad con Windows XP

El fichero at90usbxxx_cdc.inf que contiene el driver se coloca en la carpeta C:\Program Files\Eliwell\FREE Studio
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Lectura del puerto COM de la interfaz DMI

Siga los pasos que le indicamos para controlar qué puerto COM ha asignado el sistema operativo a la interfaz DMI.

arOd =

o

Pulse con la tecla derecha del ratéon sobre el icono “Propiedades del Sistema”.
En el menu contextual seleccione “"Hardware”.

En la ventana de la izquierda haga click en “Administrador de Dispositivos”.
En la ventana de derecha abra el desplegable “Puertos (COM y LPT)".

Lea el valor del puerto al final de la secuencia "AT90USBxxx CDC USB to UART MGM" o en todo caso de la secuencia que
contiene los datos de la interfaz DMI.

En el ejemplo de la figura el valor es: COM 3.
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Modificacién de la Configuracién del puerto COM

En caso de conflictos o de necesidad se puede asignar otro puerto a la interfaz tal como se indica en la figura siguiente.

arwd =

Pulse en “Propiedades".

Tecla derecha del ratén sobre el puerto COM examinado.

Seleccione la pestaiia Configuraciones del puerto.
Pulse en la tecla Avanzadas.
Modifique el nimero del puerto COM al valor deseado.
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PEQUENAS APLICACIONES

FREE Smart ha sido disefiado para instalaciones de pequefias dimensiones y en particular para:

Constructores de:

e UTA.(Unidades Tratamiento Aire)
Chiller & Bombas de Calor
Rooftop

Centrales Compresores

Instaladores/integradores de:

e Instalaciones de aire

e Instalaciones hidrénicas

e Instalaciones mixtas (aire/acqua)

CRITERIO SELECCION FREE SMART

Los modelos FREE Smart se encuentran disponibles tanto en su versiéon para montaje en guia DIN, que permite un notable
ahorro en el tiempo de cableado, como en el conocido formato 32x74 de Eliwell para su montaje en panel.

FREE Smart SMP presenta 2 modelos en funcion de las que podemos de 6 entradas digitales,

hasta 5 salidas en relé, hasta una salida TRIAC, 2 salidas analégicas PWM, 3 salidas analégicas 0...10V/0...
20mA/4...20mA configurabbles y una salida digital Open Collector para relé externo.

El formato 32x74mm estandar de Eliwell garantiza la méaxima flexibilidad y facilidad de instalacion.

FREE Smart SMD - SMC presenta varios modelos en funciéon de los cuales podemos disponer de 6 entradas
digitales, hasta 5 salidas en relé, hasta dos salidas TRIAC, hasta 2 salidas analégicas PWM, hasta 3 salidas
analdgicas 0...10V/0...20mA/4...20mA configurables y hasta dos salidas digitales Open Collector para relé
externo.

El formato 4DIN garantiza la méaxima flexibilidad y facilidad de instalacion.

il i -

I Il l '
/]

. Tk

La alimentacidon es a 12-24V~ o 12-24V~/24V=
Para més detalles consulte el manual de instalacién FREE Smart.

CONTINUIDAD CON ENERGY FLEX-

FREE Smart hereda de |a serie Energy Flex las caracteristicas de I/O y las conexiones eléctricas de
los distintos modelos, que se combinan con sus correspondientes expansiones y teclados. Las dos
plataformas utilizan ademas los mismos accesorios.

FREE Smart hereda ademas de la serie Flex la interfaz con el estdindar Modbus RTU de
comunicacion serial y la posibilidad de descargar mapas de pardmetros y aplicaciones mediante
MFK.

1 Téngase en cuenta que la continuidad con Energy Flex No supone la herencia de las aplicaciones.
Las aplicaciones (ej. Unidades de tratamiento de aire) son desarrolladas por Eliwell y estan disponibles para su descarga en nuestra web.
Visite nuestra web y/o contacte con el Soporte tecnico para mas informacién.
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SELECCION DE LA INTERFAZ

Smart se encuentra disponible en 3 versiones, SMP para montaje en panel, SMD/SMC con montaje en guia Din:

[[lfree
T

SMP 32x74 SMD 4DIN con display SMC 4DIN ciego

1=

& @)= »

.
-
b
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G

La aplicacion IEC creada desde Application puede cargarse indistintamente en todas las versiones.

La navegacién del menu es idéntica en todos los modelos.

Los modelos SMP y SMD tienen un display con 7-segmentos de LED de 4 digitos.

Con el modelo SMC, al carecer de display, es indispensabile utilizar un terminal para la configuracion.

Sobre la descripcion de las teclas, la interfaz de usuario y las conexiones consulte el manual de instalacién cod. 9MAx00362

SELECCION DE LOS MODULOS OPCIONALES SMART

A continuacién se exponen algunos accesorios utilizados por el Smart:

Terminal SKW22L
con display LCD
con retro-iluminacién

Terminal SKW22
con display LCD
sin retro-iluminacién

Terminal SKP 10 32x74

Expansiones (varios modelos dispo-
nibles) SE600 4DIN sin dsplay

Terminal SKP22L
con display LCD
con retro-iluminacién

Terminal SKP22
con display LCD
sin retro-iluminacién

2 =0:IT; 1: EN; 3: ES; 5: DE
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El terminal SKP 10 de montaje en panel dispone de una interfaz anéloga a la del médulo principal Smart.

El terminal SKW22 de montaje en pared dispone de una interfaz especifica, en el display LCD con y sin retro-iluminacion.
Para su descripcidn consulte el manual instalacién cod. 8MAx0218!3!

El terminal SKP22 de montaje en panel dispone de una interfaz especifica, en el display LCD con y sin retro-iluminacion.
Para la descripcion consulte el manual instalacion cod. 8MAx021 84!

Las expansiones SE600 - disponibles en varios modelos - tienen las I/O similares a SMD

Para las conexiones y la descripcion de mddulos adicionales y accesorios consulte el manual de instalaciéon cod. 9MAx0036!%!

APLICACIONES COMPLEJAS Evolution

FREE Evolution ha sido disefiado para instalaciones de medianas y grandes dimensiones y en concreto para

Constructores de:

UT.A. (Unidades Tratamiento Aire)
Chiller & Bombas de Calor
Rooftop

Centrales de Compresores

Instaladores/integradores de:

Instalaciones de aire
Instalaciones hidrénicas
Instalaciones mixtas (aire/acqua)

CRITERIO DE SELECCION FREE EVOLUTION

EVD EVC

Los modelos FREE Evolution estan disponibles en la versién con montaje en guia 8 DIN, con display (modelo EVD) o sin di-
splay (modelo EVC) ambos provistos de bornes extraibles lo que facilita un notable ahorro en el tiempo de cableado.

FREE Evolution EVD/EVC presenta varios modelos en funcién de los cuales podemos disponer de 9 entradas digitales, hasta 7
salidas de relé, 5 salidas analdgicas 0...10V/4...20mA configurables

Los modelos /U disponen ademés de un puerto USB y un mini-puerto USB de serie

El formato 8DIN garantiza la méxima flexibilidad y facilidad de instalacion.

La alimentacién es a 24V~/= o 48V=

Para més detalles consulte el manual de instalacion FREE Evolution cod. 9MAx0042!¢!

3-4-5 (x=0:IT; 1: EN; 3: ES; 5: DE)
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[[] [free]
SELECCION DE LOS MODULOS OPCIONALES Y ACCESORIOS EVOLUTION

A continuacién se muestran algunos accesorios utilizados por el Evolution:

Terminal EVK1000 EVK1000 montaje en pared

:

mrErer Saa o
 E N NN EE NN R RN NN
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-

™
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L

Expansion FREE Evolution EVE Plug-in EVS

e  FREE Evolution EVD esta disponible con un terminal de usuario gréfico integrado (built-in) mientras que el FREE Evolution
EVC es un modulo ciego al que se conecta un terminal de usuario grafico EVK1000 para la configuracién de los parame-
tros de BIOS

e EVK1000 esta disponible en la version con montaje en panel: una base especifica, disponible como accessorio, permite su
montaje en pared

e Llaintegracién en sistemas industriales, BMS y redes Ethernet resulta posible gracias a los médulos plug-in EVS, disponi-
bles en formato 2DIN y que se conectan de modo rapido a los médulos principales

La expansién FREE Evolution EVE, sin display, tiene el mismo formato y dispone del mismo 1/O del médulo principal

CRITERIO DE SELECCION FREE PANEL

FL & i &

EVP3300/C EVP3500/C/RH Base montaje en pared

Los modelos FREE Panel (EVP) estén disponibles en la versién con montaje en panel: una base especifica, disponible como

accessorio, permite su montaje en pared

Los modelos FREE Panel (EVP) son dos.

1. FREE Evolution EVP 3300/C dispone de serial CANopen, RS485 Modbus RTU y ETHERNET Modbus TCP, 3 entradas (1 a
bordo NTC + 1 remota configurable NTC/De +1 remota configurable en corriente/tensién)

2. FREE Evolution EVP 3500/C/RH dispone de serial CAN, RS485 y ETHERNET, 3 entradas (1 médulo humedad a bordo + 1
a bordo NTC + 1 remoto configurable NTC/De)

FREE Studio - Quick Start pag. 11



EVP dispone de un terminal de usuario gréfico 128x64px integrado (built-in)
La alimentacion es a 24V~/= o 48V=

Para méas detalles consulte el manual de instalacion FREE Panel cod. 9MAx0046!7!

CONECTIVIDAD

La caracteristica fundamental de Evolution es su amplia conectividad

FREE Panel (EVP) se utiliza como control de sistema, con funciones de gateway, usado en combinacién con los controles FREE

Evolution y FREE Smart o de terceras partes, garantizando prestaciones elevadas por lo que respecta a memoria, conectividad e

interfaz de usuario. Resulta ademas de sencilla programacién, mantenimiento y servicio.

Los modelos FREE Panel se encuentran todos disponibles con CANOpen RS-485 y ETHERNET de serie.

EVP permite:

e gestionar un mend local realizado con FREE Studio User Interface

e gestionar hasta 10 mends remotos, realizados con FREE Studio User Interface, cargados por los respectivos FREE Evolution
conectados en red

e compartir variables de red (binding)

Los modelos EVD/EVC se encuentran todos disponibles con CANOpen de serie.

Se encuentran ademas disponibles las seriales RS485 o MPBUS a bordo, de serie, dependiendo del modelo.

Cada EVD/EVC se conecta a 12 expansiones EVE mediante serial CANOpen o RS485

La integracidn en sistemas industriales, BMS y redes Ethernet puede realizarse gracias a los médulos plug-in, disponibles en
formato 2DIN y que se conectan rapidamente a los médulos principales.

Cada Evolution puede conectarse hasta a dos terminales para visualizar el menu en el display situado a bordo de la méaquina.
También se puede, mediante la red RS485 conectar un sistema Smart que sirve de Esclavo a una red donde Evolution sirve
de Maestro. El terminal EVK1000 se halla disponible con CANOpen de serie. El terminal EVK1000 puede leer el menl desde
EVD/EVC. Se hallan ademas disponibles las seriales RS485 o MPBUS a bordo, de serie, en funcién del modelo.
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APLICACIONES [|] |free|

Eliwell pone a su disposicién en su pagina webl" aplicaciones y librerias de objetos para la plataforma FREE Way.
Las aplicaciones y librerias de objetos le permiten agilizar su trabajo, haciendo que FREE Studio resulte ain mas facil de usar.

Aplicaciones Smart

Pueden descargarse, por ejemplo, distintas aplicaciones para UTA, que se diferencian segun la complejidad de las maquinas
que pueden controlar, desde simples unidades con canal de aire Unico y una bateria hasta unidades méas complejas con doble
canal, baterias multiples y recuperador.

Dichas aplicaciones, ademés de estarya /"~
preparadas para su uso (siendo con-
formes a las reglas de su arquitectura),
pueden modificarse facilmente, para
responder a necesidades maés especifi-
cas o particulares.

4 ) La seccién de la web contiene ademaés la documentacidn:

Manual de Arquitectura o Desarrollador
Manual del Desarrollador que contiene las reglas de arqui-
tectura, pensado especificamente para los desarrolladores.

Manual User
Manual de Usuario de la
aplicacion.

J

1 En la direccién (visible previo registro y/o login en el 4rea reservada http://www.eliwell.it/filedownload.aspx?id=20151
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DEFINICIONES PANELES APPLICATION [|| [free

El entorno de trabajo Application presenta varias secciones para el desarrollo de la aplicaciéon IEC; programa-
cién en lenguaje compatible IEC 61131-3 , tests, depuracion y descarga de la aplicacion IEC al dispositivo target.
IMPORTANTE: Application descarga solo la aplicacion IEC.

La descarga de los parametros (BIOS y PLC) y sus valores por defecto se realiza desde el Device y no desde
Application.

A continuacién detallamos el listado de las secciones (paneles):
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Esta seccion muestra las herramientasde trabajo

mediante iconos.

Para visualizar o no las barras de herramientas basta con
Barras (bar) hacer click con la tecla derecha del ratén y seleccionar o

A / de herramientas deseleccionar las herramientas deseados.

Algunos instrumentos se pueden seleccionar
mediante combinaciones de teclas (shortecuts). Ver su
correspondiente capitulo para mas detalles

En este seccion aparecen las variables globales y locales
B / Variables del cédigo visualizado en la seccién D ‘Edit’ (programas,
bloques de funcién y funciones)
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Nombre Panel /
Seccién Seccién Panel Descripcién
Application

El panel Proyecto se subdivide en 3 pestaiias (tabs):
* Project - para la gestion del cédigo aplicacion
e Definitions - para la gestion y definiciones de

¢ Project Proyecto variables complejas definidas por el desarrollador
* Resources - para la gestion del ment del dispositivo
target
D / Edit Esta seccion permite escribir el programa

Este panel permite gestionar la depuraciéon de las
Visualizacion de variables con | variables mediante la visualizacion de su estado en
aplicacion ejecutandose formato numérico cuando la aplicacién esté ejecutandose
y conectada al dispositivo target

E Watch

Este panel (de igual modo que en el panel Watch)
permite gestionar la depuracién de las variables

F Oscilloscope Visualizacién grafica de variables mediante la visualizacion de su estado en formato grafico
cuando la aplicacion esté ejecutandose y conectada al
dispositivo target

Este panel permite gestionar las librerias de funciones
por defecto y/o creadas por el desarrollador.

El panel se subdivide en varias pestafas (tabs), cada una
para una libreria.

Estan siempre disponibles las pestaiias de:

e Operator and standard blocks: operadores

G Library Libreria de funciones estandar (AND, OR, etc)
e Target variables: variables especificas del dispositivo
target
e Target blocks: funciones especificas del dispositivo
target

Otras pestanas adicionales se gestionan mediante el
menu desplegable Project > Library manager

Este panel muestra los mensajes correspondientes al
desarrollo del proyecto (apertura de fichero, errores de
compilacién, estado de conexidn al dispositivo target etc.)
Nota: |la conexidn al dispositivo target también puede
verse abajo a la derecha de la pantalla con mensajes de
color (ver Download Aplicacién)

H Output Mensajes

Los paneles aparecen o no (ver capitulo Shortcuts) y pueden organizarse por lo que respecta a su disposicién y dimensiones
a gusto del usuario.
Studio memoriza las Ultimas configuraciones realizadas

Iconos

Los instrumentos de trabajo se hallan disponibles mediante los menus desplegables o con shortcuts (atajos de teclado).
El panel A presenta una serie de iconos que facilitan al desarrollador la creacién de la aplicacion.

Las barras de herramientas se visualizan con el menu View > Toolbars

A continuacion detallamos un listado de los iconos maés utilizados para las Toolbar Main y Project

Main Toolbar

W0 Lwa A F

S ™ & BB b s RIGESERIEE

Project Toolbar

Li ¢ Ca%Sico Dc |ns Dl
A PR

Los iconos son 'self-explaining' es decir intuitivos. Ademés de los primeros iconos, que resultan andlogos a los iconos estandar
(Abrir proyecto, Guardar proyecto, Copiar, pegar, etc) se hallan los iconos identificados por algunas letras situadas arriba:
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pestaia Project

pestaiia Definitions

pestaia Resources

Barra Herramientas Funcién Funcién Atajo teclado ‘
F Main Pantalla completa Full Screen CTRL+U
W Main Visualiza panel proyecto WORKSPACE CTRL+W ‘
o Main Visualiza / oculta OUTPUT CTRL+R
el panel de mensajes
L Main Visualiza / oculta LIBRARY CTRL+L
el panel libreria
Wa Main Visualiza / oculta WATCH WINDOW CTRL+T
panel ventana watch
: Visualiza / oculta ASYNC GRAPHIC
A el panel osciloscopio WINDOW CTRL+K
C PROJECT Compelizdion ¢ proyese COMPILE F7
-solo el seleccionado-
Ca PROJECT Compilacién proyectos COMPILE ALL - ‘
si PROJECT Apertura del simulador SIMULATION MODE .
Ver capitulo Simulation
CONNECTS TO THE
Co PROJECT Conectados al target TARGET F5
Dc PROJECT Descarga codigo a la aplicacion = DOWNLOAD CODE -
Ins PROJECT Introduce un nuevo registro INSERT RECORD :
(variable, constante, alarma etc)
Del PROJECT Borra un registro DELETE RECORD =
Panel Project
Visualizacion detallada del Panel C / Project!"
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Visualizacién para Smart
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PARA INICIAR [|| [free

Smanrt
PRIMER ARRANQUE:

1. Hagaclick en el icono Launch FREE Studio que se encuentra en el Escritorio
2. Haga click en el icono FREE Studio Application.

dli4ll

1EC A1131-3 developmeant emdnonment

1 2

El programa aparecera tal como se muestra en la figura:
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Ahora podemos:

e Crear un nuevo proyecto ‘'New Project ...’
e téngase en cuenta que el programa sugiere la seleccion del target Smart, Evolution o Panel
e endicho caso elija FreeSmart
e |os nimeros situados al lado indican la versidn (méscara) del firmware

e Abrirun proyecto existente ' Open project...’

e  Abrirlos proyectos recientes ‘'Open an existing project ..." seleccionandolos del listado

Los proyectos existentes tienen la extensidn .ppjs

La aplicacién IEC se compone de un proyecto y de uno o varios programas escritos en cédigo IEC

1 El logo 'free Smart' al comienzo de capitulo indica que la herramienta Application esta disponible para el Smart. Todas las herramientas
(incluyendo Application) estan disponibles para Evolution. Para Evolution recomendamos - en el primer Arranque y en la Creacién de un nuevo
programa - que empiece siempre por la herramienta Connection (véase a tal respecto su correspondiente capitulo).

FREE Studio - Quick Start pag. 17



CREACION NUEVO PROYECTO

¢ Haga click en New Project ... o
e desde el ment desplegable seleccione File > New Project!?

Aparece la ventana de didlogo que mostramos a continuacién, donde puede crear y guardar con nombre un nuevo proyecto:
ST d

P
[T R =]

[S RN LT ————— =1
g

(W TR | i p—T] =
g

T Eon i

I:-I Im=m

Nuevo Proyecto

El nuevo proyecto se presenta tal como se muestra en la figura:

[ e ot . e . e o=t il atin
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e  Para la descripcién de los iconos véase el capitulo Shortcuts (atajos de teclado)
e Ladescripcidon de los lenguajes de programacion se encuentra disponible en el Help en linea (Ayuda en Linea, en inglés) -

véase el capitulo Soporte
e Ladescripcion de los paneles del entorno de desarrollo estandar se encuentra en el siguiente capitulo

A continuacién mostraremos cémo crear, desarrollar y testar una nueva aplicacién con ejemplos simples de librerias, bloques
de funciéon y programas sencillos.

2 En la imagen se muestra un ejemplo de proyecto para Smart. En Evolution es idéntico. Las excepciones se indicaran claramente.
Aconsejamos en este caso, empezar siempre por el tool Connection y luego seguir el procedimiento descrito en su correspondiente capitulo
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[|] |free|
CREACION DE UN NUEVO PROGRAMA- Ap

Panel Project / Carpeta Programs.
Haga click en la tecla derecha del ratén y seleccione New Program.
Cada proyecto contiene por defecto el programa main

SELECCION DE LENGUAJE IEC

Aparece la ventana de didlogo:
TR o
| Larguige
|4"'|. o Cw Fst r:n:|

Hime
e |
o |

Nuevo Programa en lenguaje ST

Seleccione el lenguaje de programacién deseado e introduzca un nombre.
La plataforma FREE STUDIO es compatible con los 5 lenguajes de programacién estandar (IEC 61131-3).

ST FBD LD IL

( \ r . \ ( Id true

st blinker.run
i Id true
Main st blinker.run
cal trigger

var2:=var2+1;
if (var2=200) then
var2: =0;

varl: =not varl;

™\

Start

counter: =
if

JA\ A\ =) & J

Cada proyecto puede estar formado por varios programas
El desarrollador puede utilizar uno o varios lenguajes en el mismo proyecto. Cada nuevo programa puede seleccionarlo entre
los 5 lenguajes de programacion, 2 de tipo texto y 3 de graficos:

e ST, Structured Text language de texto
e FBD, Functional Block Diagram language grafico
e LD, Ladder language gréfico
e IL, Instruction List language de texto
[ ]

SFC, Sequential Function Chart language grafico

APERTURA DE UN PROGRAMA EXISTENTE

Si el desarrollador ya tiene a disposicién una aplicacion [EC existente basta con abrir un proyecto .ppjs desde el men File >
Open Project o seleccionarlo del listado.

3 Creacion de un nuevo programa (New program)
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ESCRITURA PROGRAMA |

En el panel Edit escriba el programa que desea desarrollar.

A continuacién le mostraremos de manera general los elementos de la herramienta de desarrollo.

En el Apéndice encontraré algunos ejemplos de programas simples que puede utilizar para crear un proyecto bésico que fun-
cione.

PANEL PROJECT / PESTANA PROJECT

Creacién de variables locales

En el menu desplegable seleccione Variables > Insert (new record) o haga click en su correspondiente icono.

En la seccidn central aparece la variable en amarillo, desde donde podemos definir las caracteristicas haciendo click en las
correspondientes casillas.

En caso de que haya selecciones multiples se puede, haciendo click sobre los puntos suspensivos (...) elegir entre un conjunto
de opciones.

Se abrird una ventana de didlogo

e Name (Nombre)

Type (Tipo) a elegir entre una de las opciones predefinidas o entre las variables definidas por el usuario (ver imagen)
Address (direccién): por defecto es automética

Array: define si la variable es de tipo array (en este caso defina su dimensién) o no

Init value: valor inicial

Description (descripcién)

En el desplegable de navegacién, bajo la carpeta del programa, apareceran las variables locales identificadas con un icono
Nota: Las variables locales No son estaticas.

= " . C S | | e L e
[ TSRS T— == = - -
— — [ pes - Bl
4
."\_"_
[FEe-—_——
i o e
[Py ———
P v | '8 ] n
L. == |
-
e — .ri
e ol | P
— T - e
|

i
i

Creacion Bloque de Funcién / Funcion

Del mismo modo que se crea un programa se puede crear

e unafuncién

e un bloque de funcién

en el lenguaje de programacién deseado.

Nota: La creacion de una funcion se halla disponible en 4 lenguajes de programacién. El lenguaje SFC no esté soportado para
las funciones.

Una funcién o bloque de funcién es un (sub)programa que dispone de entradas y salidas:

e una funcién prevé n entradas y una Unica salida (RESULT) con el mismo nombre de la funcién. La memoria local de la fun-
cién se inicializa a cada llamada de la funcién

e un bloque de funcién prevé n entradas y m salidas. La memoria local de cada instancia del bloque de funcién se conserva
entre una llamada y la posterior (memoria estética)

Cada funcién o bloque de funcién se puede utilizar dentro de un programa simplemente arrastrando (drag & drop) el icono a la
seccién Edit del programa.

La funcidn se utiliza (rellamada) dentro del programa pasando las variables de entrada.
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El bloque de funcién se usa dentro del programa como instancia del mismo modo que se declara una variable.

Ejemplo en lenguaje ST de llamada de funcién y function block

ot = Hara | Twe | Addess | Amay | ndwaiue | asribue |
B Proiscs I--u Hh] - [ ey I _1_|l.|n-clnntvl-u|:l-1l-1m|:-nm untlanitiock Ao [ [
'_F,__h,__, varngull oL Padt @ FaLgE
= vanegu? A 1T aL
1 Frograms ] BOOL FaLid
= [T] i _I-'uwml' BO0L Adn Ha FALSE
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Creacién de Variables Globales

En el menu de navegacion se encuentra la carpeta Global Variables

Desde aqui se pueden crear nuevas:
e Variables (variables globales)
Mapped variables (mapeadas)
Constant (Constantes)

Retain variables¥

Recursos Globales Compartidos

Los recursos globales compartidos (Global Shared) aparecerdn en esta seccion pero se definirdn en el panel Resources.

Actualmente no soportadas en el target Smart y Evolution
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ASOCIACION DEL PROGRAMA A UN TASK m

Para que el programa se ejecute es necesario asociarlo a un ‘task’.

Los task son de varios tipos:

e Boot. Task ejecutado una sola vez cuando arranca el sistema

e Init. Task ejecutado con cada descarga de la aplicacién

e Timed. Task ejecutado a intervalos regulares con intervalo configurable por el desarrollador. Por defecto cada 100ms

e Background. Task ejecutado con prioridad baja en cola de los task Timed (entre el final de un task Timed y el inicio del
siguiente).
Nota Cada nuevo proyecto tiene el programa main asociado al task de background (el programa main puede, en todo
caso, ser eliminado y/o asociado a otros task).

Para activar un task situése sobre el task deseado y con la tecla derecha del ratén seleccione Add program

PANEL PROJECT / PESTANA RESOURCES

La pestafia Resources permite definir los pardmetros EEPROM vy las variables de estado que podréan utilizarse luego en el
codigo de la aplicacién (aparecerén en la seccién Project>Global Shared) y permite construir el mend Prg (Programacion), el
menu Set Estados!® y Alarmas del target FREE Smart / Evolution ademas de la interfaz del proyecto actual que se visualizara
en FREE Studio Device

La pestaiia Resources incluye las siguientes secciones:

MODBUS OBJECTS

Esta seccion permite definir pardmetros EEPROM y variables visualizables en el target, Device y que pueden leerse mediante
protocolo Modbus® RTU. En todas las secciones se pueden afadir o quitar pardmetros/variables igual que en las variables de la
pestafia Project

Smart

F; | = Db Hn—]n Vst AL PROS o aariery =
L——

LTS

Sy —— .
i rehs ey al Aib g

| - I e 2

EEPROM Parameters

En esta seccidn se crean las variables que el desarrollador pretende guardar incluso en caso de fallo de alimentacion en el
dispositivo target.

Nota: el uso de los pardmetros en el cédigo es solo de lectura, la escritura puede realizarse utilizando las funciones correspon-
dientes de FREE Smart.

Estado Variables

En esta seccién definimos las variables de estado que podrén visualizarse en el Menu del dispositivo target.

Cada variable dispone de una transcodificacién en el instrumento debido al display 4 digitos/ 7-segmentos. En la casilla
Display label se puede elegir la transcodificacién y ver la previsualizacién de como aparece en el display haciendo click en los
puntos suspensivos (...)

Nota: algunas letras no se visualizarén (ej. x y ) por lo que en el display quedara un espacio vacio.

Si la etiqueta en el display es zzz en el display no aparece nada

Si la etiqueta en el display es SET en el display aparece SEt.

5 Solo para Smart. Ver manual Instalacion 9MAx0036 (x = 0: IT; 1: EN; 3: ES; 5: DE)
En el Evolution el menu se define desde UserInterface.
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Panel ¢ Evolution
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EEPROM Parameters
Anélogo a Smart

Estado Variables

En esta seccién definimos las variables de estado que podrén visualizarse en el Menu del dispositivo target.

Smart ¢ Panel ¢ Evolution

En la columna target se indican las columnas visibles solo en el target Smart, Panel o Evolution.
Donde no se indica lo contrario se entiende que es para ambos.

Target Columna
IPA

address
Name

Smart display label
Device Type

Default Value /Min/Max

Format
Application Type
Scale/Offset

Panel Size
Evolution
Unit

Smart Access Level
Read only

Description/Note

‘ Descripcién
indice pre-asignado
direccién Modbus® del recurso

nombre del recurso que podra utilizar el desarrollador en el cédigo
aplicacion IEC

nombre eventual visualizado en el menu aplicacion del target (4-digitos)
tipo de dato visualizado en target y Device

valores minimos/méximos por defecto de los recursos visualizados en el
target y Device

formato de visualizacién de los valores Default Value /Min/Max
ej. XXX.Y visualizacion de un entero con punto decimal

tipo de dato que se utiliza en el cédigo aplicacién IEC

coeficientes de conversién entre Device Type y Application Type
Application Type = scale* Device Type + offset

Significativo solo en caso de tipo STRING. Dimension (Longitud) de la
secuencia de caracteres. Por defecto y méximo= 31 caracteres.

Unidad de medicién del Device Type visualizada en Device y si estd
disponible con icono en el target

Ver tabla de Visibilidad. Para Evelution esta columna es irrelevante.
Habilita/deshabilita la modificacidn de Status variables.

texto libre visualizado en Device

FREE Studio - Quick Start pag. 23



Enums
En esta secciéon definimos los tipos de variables adicionales que pueden utilizarse en la columna Device Typel®! L

BIOS parameters
En esta seccién definimos posibles variaciones al mapa pardmetros de BIOS configurados por defecto en fabrica por Eliwell

MENU TARGET

El menu target se halla compuesto por un ment BIOS + un ment Aplicacion
El menu BIOS esta pre-configurado de fabrical.
La tabla siguiente define las principales funciones de las teclas / LED del dispositivo target

tecla pulsacion Descripcién
F5 breve pasar de menu BIOS a mend Aplicacién y viceversa
F1o0F3 breve navegacion en carpetas y modificacién de los valores
F2 breve anula operacion (funcién ESC)
F4 breve acceso al menu set
F2+F4 breve acceso al menu Prg
F1/F2/F3/F4 prolongada gestionada por el desarrollador (mediante target variable sysKeyFunctions|])

Los LED los gestiona el desarrollador mediante target variable sysLocalLeds[])

Menu Prg®

En esta seccion definimos el menu Prg y las carpetas/variables que lo compondran.

El ment Prg puede estar compuesto por una o varias carpetas, definidas por el desarrollador, dentro de las cuales se introducen
e EEPROM parameters

e  Status variables

e BIOS parameters

e entradasy salidas

Menu set!

En esta seccidn definimos el mend sety las carpetas/variables que lo compondréan.
La creacion del mend de set es anédloga a la del Menu Prg
El menu set contiene la carpeta AL - ver abajo

Visibilidad de los recursos del menu

La visibilidad de los recursos creados por el desarrollador se describe en la siguiente tabla:

Columna Access Level Visibilidad en Device Visibilidad en el target Notas
Siempre visible S| S|
Always visible
Nivel 1 Si
S .
Level 1 nivel 1 Objeto asignado a un menu Prg
Nivel 2 S| Si o set
Level 2 nivel 2
Nunca visible
Never visible =l MO
- Sl ) . o
“:3:?::.2:2 Visible en la carpeta NO Shiss mznajlgrnagzgn'ngun
ALL PARAMETERS o

Alarms

Es posible definir variables de alarma cuyo estado ha de gestionar el desarrollador.

En caso de que la variable asuma un valor distinto de cero la etiqueta se visualizara en la carpeta Alarmas (AL)del menu set de
FREE Smart

En el target Evolution es solo una declaracion USINT de tipo Global

6 Ver tabla de definicion EEPROM parameters y Status Variables

7 Ver manual de instalacién

8 Los elementos introducidos en la tablas de esta seccidn se visualizaran en Device
9 Los elementos introducidos en la tablas de esta seccién se visualizaran en Device
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Configuracién FREE Smart
Desde la pestafia Resources haciendo click en FREE Smart accedemos al siguiente panel FREE Smart Configuration
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Mediante el menu desplegable se puede configurar el valor de la variable / pardmetro que se pretende visualizar en el instru-
mento FREE Smart como visualizacion principal (Fundamental state display). Si no selecciona ningun valor (none) el instru-
mento visualizard PLC.

Los valores disponibles son todas los I/0!"% + |os valores definidos por el desarrollador en el Menu set

Execution time

En el mismo panel es posible configurar el tiempo de ejecucion del proyecto en milisegundos (ms).
El valor por defecto es 100ms. El rango se define entre 20ms y 100ms!"1,

I1/0 mapping

En esta seccién definimos los lazos de unién entre variables y las I/O fisicas del FREE Smart.
e Local: variables locales de la base SMD/SMC

e Extended: variables de la expansién SE

* Remote: variables presentes en los terminales SKW / SKP

MENU TARGET

El mend target se crea mediante Userinterface.
El mend BIOS sale pre-configurado de fabrical’? y puede verse en el Device.
Las principales funciones de las teclas / LED del dispositivo target se programan mediante Userinterface!"!

Menus

En esta seccién definimos un Menu 'ficticio' que no aparece en el display, asi como las carpetas/variables que lo compondran.
El menu podré estar formado por una o varias carpetas, definidas por el desarrollador, dentro de las cuales se introducen

e EEPROM parameters

e  Status variables

Alarms
Las alarmas para Evolution se definen Unicamente para permitir la portabilidad de un proyecto Smart

10 Las I/0 son todas las entradas y salidas locales y remotas, incluyendo las de los terminales. Consulte el manual de instalacién para mas detalles.
11 Ver también la seccién Asociaciéon programa a un task

12 Ver manual de instalacion

13 LEDS programables también con Application
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Configuracién FREE Evolution
Desde la pestafia Resources haciendo click en FREEEvolution se accede al siguiente panel FREE Evolution Configuration
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Execution time

En este mismo panel se puede configurar el tiempo de ejecucién del proyecto en milisegundos (ms).
El valor por defecto es 20ms. El rango se define entre 20ms y 100ms!™4l,

I1/0 mapping

En esta seccidn definimos los lazos de unién entre variables y las I/O fisicas del Evolution.
e Local: variables locales de la base EVD/EVC
e Field: variables y/o binding de controles de terceras partes

Nota
Si han sido correctamente definidas!'® todas las variables definidas en Resources apareceran automaticamente en la seccion
Global Shared.

Panel

Configuracion FREE Panel
Desde la pestafia Resources haciendo click en FREEEvolutionEVP se accede al siguiente panel FREE Evolution Configuration
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14 Ver también la seccién de Asociaciéon programa a un task
15 El proyecto ha de guardarse sin errores para que las variables continuen siendo visibles en la pestaiia Project en Global Shared
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Execution time

En este mismo panel se puede configurar el tiempo de ejecucién del proyecto en milisegundos (ms).
El valor por defecto es 20ms. El rango se define entre 20ms y 100ms!*¢1,

I1/0 mapping

En esta seccidn definimos las relaciones entre variables y las I/O fisicas de EVP!7L,
e Local: variables locales de EVP
e Field: variables y/o binding de controles de terceras partes

iy wl

Entradas Analégicas
Téngase en cuenta que las entradas se encontrarén presentes o no dependiendo del modelo.

Entrada Sonda Tipo EVP3300/C  EVP3500/C/RH
AIL1 a bordo NTC a bordo v v
AlL2 remota NTC 103AT/ NTCNK103 / De 4 v
no incluida configurables
AIL3 remota 4...20mA/ 0-5V/ 0-10V configurables v -
no incluida
AlL4 a bordo %HR a bordo - v
Nota

Si han sido correctamente definidas!'® todas las variables definidas en Resources aparecerdn automaticamente en la seccion

Global Shared.

16 Ver también la seccion de Asociacién programa a un task
17 En realidad EVP tiene solo 4 entradas analégicas AIL1...AlL4 y ninguna salida
18 El proyecto ha de guardarse sin errores para que las variables continuen siendo visibles en la pestaiia Project en Global Shared
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GUARDADO PROYECTOS

Una vez completado el proyecto podemos salvarlo en varios formatos y enviarlo a Desarrolladores (Developers) o a Usuarios
(Users) de terceras partes

Tipos de ficheros

Target Tipo de fichero Aplicacién Descripcién
Smart .PPJS Application | Proyecto creado con Application para abrir con Application
Panel .PPJS Application | Proyecto creado con Application que se puede afadir a un dispositivo
Evolution Connection  Evolution con Connection
.PLL Application  Libreria creada por el desarrollador para utilizar en Application o Device
.RSM Application | Proyecto .PPJS compresso
Panel PAJX User Interface Proyecto creado con Userinterface para abrir con Userinterface
Evolution
Panel .PPJX User Interface Anélogo a .PPJS. Proyecto compartido
Evolution
Smart .CFN Device Proyecto creado con Application para abrir con Device

Nota. No estd disponible el cédigo fuente pero el proyecto puede
descargarse en el dispositivo target

Panel .CFN Device Proyecto creado con Application o Connection para abrir con Device.
Evolution Si el dispositivo se crea con Connection contiene tanto la aplicacién PLC
como el mend HMI
Nota. No esta disponible el cédigo fuente pero el proyecto puede
descargarse al dispositivo target

TRANSFERENCIA DE PROYECTOS Y FICHEROS

En la siguiente tabla podemos ver algunas operaciones de transferencia de proyectos de un desarrollador a otro desarrollador
o de un desarrollador a un usuario. La transferencia de datos supone el envio de uno o varios de los ficheros definidos en la
seccion anterior.

Proyecto De -->A Aplicacién Tipo fichero Notas
El desarrollador (Developer) quiere transferir un Desarrollador Application .PPJS
proyecto a otro desarrollador
El desarrollador envia un fichero .ppjs Vv

Desarrollador
El desarrollador que lo recibe puede abrirlo
y modificarlo con Device Application; El
desarrollador se conecta al target, compilay
descarga la aplicacién.

El desarrollador envia un fichero .ppjs a otro Desarrollador Application .PPJS
desarrollador Device

v
El desarrollador que lo recibe puede abrirlo y Desarrollador

modificarlo con Application; El desarrollador
se conecta al dispositivo target y compila la
aplicacion.

Tras la compilacién el desarrollador selecciona
el elemento del ment Developer > Open
with FREE Studio Device y configura la BIOS
del dispositivo target (parametrizacion del
dispositivo target)
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Proyecto ‘ De -->A Aplicacién Tipo fichero Notas

El desarrollador desea transferir un proyecto a Desarrollador Device .CFN Desde el Device
un usuario (User) el usuario No

El desarrollador envia un fichero .CFN v puede compilar la
El usuario que lo recibe puede abrirlo con Usuario aplicacion

Device; El usuario se conecta al dispositivo
target descarga la aplicacién y configura el BIOS
del dispositivo target (parametrizacion)

El desarrollador quiere realizar la depuracién de Desarrollador Application Carpeta
una aplicacion IEC ya presente en el dispositivo proyecto
target, pero no tiene el cédigo fuente. v

El desarrollador recibe la carpeta completa Desarrollador

del proyecto (que incluye los ficheros binarios

y los simbolos de depuracién) utilizado para
descargar la aplicacion IEC al dispositivo target.
Nota: el proyecto no ha sido modificado
(ninguna modificacién a la fuente y ninguna
recompilacion y/o descarga)
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MODALIDAD DE CONEXION

Para descargar las aplicaciones I[EC de Studio desde el Ordenador Personal al dispositivo target Smart se necesitan algunos

maodulos adicionales.

Véanse las siguientes tablas, donde se muestran las posibles operaciones:

Multi Function Key / DMI Multi Function Key Red (Network)
PC > € MFK MFK > € Smart PC > € Smart
’ T7L !f/-\ ; 3 usB * st A-I
= Multi Function Multi Functiot tl ” E & v DMI i ’
——dﬂ:‘" Key ) Kuq " art m-Tsz 3

Utilice cable TTL azul
para la conexién DMI - MFK

Utilice cable TTL amarillo
para la conexiéon MFK - target

Utilice cable TTL amarillo
para la conexién DMI - target

et | > [« [onaen] o [«
Mapa pardmetros - Mapa pardmetros v v
Aplicacién IEC v - Aplicacion [EC ‘ v ‘ -
BIOS v - BIOS 4 -

Nota: en el caso Red (Network) Smart no se conecta a tierra.

Para descargar las aplicaciones IEC de Studio desde el Personal Computer al dispositivo target Evolution se necesitan algu-

nos mddulos adicionales.

Véanse las siguientes tablas donde se muestran las posibles operaciones:

Direccién de la
> €

Descarga Datos
Mapa pardmetros | v v
Aplicacion IEC v -
BIOS v -

Nota: la conexién mediante ETHERNET necesita el médulo plugin EVS
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USB Host USB device USB-RS485
USB > € Evolution PC > € Evolution USB-CANOpen
ETHERNET
PC> € Evolution
USB .=_-.‘ RS485 --
” — USB/Rs485
e R B
--
M-E USB/CAN FReEEvation
Direccién de la > s el el € L p e
Descarga Datos Descarga Datos ﬂ EH 4
, = FREE Evolution
Mapa parametros v v Mapa pardmetros ‘ - - el oo Plugin
Aplicacién IEC v Aplicacién IEC Y Y I':"eccm":et'a > €
o escarga Datos
it _ Aplicacion HMI ‘ v
Aplicacion HMI v P Mapa pardmetros = v/ v
i - . File dat v
Tl liios e datos Aplicacion IEC v
BIOS v = BIOS ‘ - - S
Aplicacion HMI v -
File datos - -
BIOS v -




Panel

Para descargar las aplicaciones IEC de Studio desde el Ordenador Personal al dispositivo target Panel se necesitan algunos

maodulos adicionales.

Véanse las siguientes tablas, donde se muestran todas las posibles operaciones:

USB-RS485
USB-CANOpen
ETHERNET

PC > € Evolution

B

—

Direccién de la
Descarga Datos

>

=G

Mapa pardmetros | v v
Aplicacion IEC v -
Aplicacion HMI v -
File datos -
BIOS v .

Nota: la conexién mediante ETHERNET No necesita ningiin médulo adicional.
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DOWNLOAD APLICACION IEC EN EL TARGET

Las operaciones de conexién y descarga de la aplicacién para Smart y Evolution son diferentes.
A continuacién se expone la modalidad de conexion (ver correspondiente apartado)

e Red (Network) para Smart

e  USB-R85 para Evolution

La descarga propiamente dicha se efectuard del mismo modo para los dos target

Smart

OPERACIONES PRELIMINARES

El usuario, para descargar correctamente la aplicacién, debe:
1. conectar la interfaz hardware DMI al PC.
2. Asegurarse de haber instalado el driver - ver seccién Setup interfaz DMI.

Configuraciones COM!"

Seleccione, en el mend desplegable, Communication > Settings
El puerto COM ha de haber sido leido/configurado previamente en “"Gestion Periféricos” (Ver seccién Lectura del puerto COM
de la interfaz DMI) para que se reconozca el mismo. En caso de errores consulte “Error de conexién con la interfaz DMI".

x
Cumeni selachad proioced | Ewlin

Pactocols | Active |
T Carlpin

T EwDMl Bctive

T Modbus

¥ ModbusTOP

Para Smart seleccione EWDMI o Modbus!?.. Si el protocolo no esté activado pulse la tecla Activate

Una vez seleccionado un valor para el puerto COM, dicho valor se memoriza, y vuelve a presentarse cada vez que se accede
al programa, hasta que se modifica. Las propiedades pueden verse y modificarse en el panel Communication > Settings >
Properties!®!

D8 Lonfguration vl 2
Prstoocod vettng:
P COM3 -

Emxbaie |_w.l:| -|
Fiufrel setngi |Hli|| "']

Pradicol petingi
fukhraa |1
Tirremna |1|'.l'l.'|

] e

Error de conexién con la interfaz DMI

1 Las configuraciones COM se configuran para todos los entornos de trabajo Application, Device y UserInterface
2 En el caso Modbus solo para modelos /S con velocidad maxima 19200 baudios. TTL no utilizable.
3 Naturalmente el protocolo ha de ser Activado (Activate) previamente.

FREE Studio - Quick Start pag. 32



Error de Apertura Puerto Serie

En caso de Aviso "Error de Apertura Puerto Serie” proceda como le indicamos a continuacién:

1. Controle que el nimero del puerto COM configurado en el programa es el mismo que el leido en Lectura del puerto COM

de la interfaz DML.

2. En el caso de que sean efectivamente iguales desconecte y vuelva a conectar fisicamente la interfaz DMI del puerto USB.

Dicha accién deberia conseguir que el sistema operativo reconozca la interfaz.

3. Repita la operacién funcion Identifica DMIL.

TARGET SMART

Smart dispone de algunos pardmetros presentes en la carpeta CF para la gestién de la conexidon entre el target y Studio

Si el target esté 'vacio'®, es decir si no hay ningun aplicacion IEC en el dispositivo, Smart visualiza en el display el mensaje

FrEE:

g vl [ [free]

F2
e, . P
Tﬁi / r'E:L

F3 [0J6)6]0)6]06]0]

Para acceder al ment de pardmetros
hay que pulsar al mismo tiempo la
tecla escy la tecla set. De este modo
accederemos al menu PAr.

fo vl [[ [free [
il esc
oo ]
Fs - Prg
i ~ ‘.' [} - |
F3 @ ©]61016]6]0) F4

El menu de pardmetros PAr contiene
todas las carpetas del instrumento.
Para visualizar las carpetas pulse la

tecla set.

g vl || [frec .
s I~ C brs
L L ] - 1
F3 @ [©16101616]0) F4

La primera carpeta visualizada sera
la carpeta CF de configuracién. Para
visualizar los parametros de la carpeta
pulse la tecla set.

H dlial [ [free [

esc

n
Prg
i F (AN} I
- L -.L.n
F3 (D@@@@@@ F4

El primer pardmetro visualizado sera
CF30. Para visualizar el valor del para-
metro pulse la tecla set.

T mes .,
' Jg

2
-~ vvv-

B 0000060 F4

Utilice las teclas UP y DOWN para
modificar el valor si es necesario. Para
confirmar el valor pulse la tecla set.
Para salir pulse esc

F el [[ | free I
: - -, , .7

Prg

rrC
LI . &

[0Jejelololele; Fa

Con las teclas UP y DOWN desplacese

a los otros pardmetros y repita el pro-

cedimiento para visualizar los valores
y - si es necesario - modificarlos

Pardmetros necesarios para la correcta conexion entre el target Smart y Studio.!

Parametro Descripcion Valores Por defecto Visibilidad Notas
CEO1 seleccién protocolo de la COM1 0 = Eliwell 1 > Es obligatorio configurarlo
(TTL) 1=Modbus en
CF30 direccién control protocolo 1 955 1 3
Modbus
W2 =iouszelo Compruebe que los valo-
j ==199620(§)0Tauu(2?oss res configurados resultan
CF31 baudate protocolo Modbus 5— 38400 baudios 3 3 congruentes con lo que se
6 = 57600 baudios ha definido en el panel
) Communication > Set-
7 = 115200 baudios . q
1= EVEN tings > Properties
CF32 paridad lc\jlmgrgl protocolo 2= NONE 1 3
ocbus 3=0DD
4 En caso contrario (en Smart se halla presente una aplicacién IEC) aparece en el display el mensaje PLC.
Utilice al mismo tiempo las teclas UP y DOWN para visualizar el mensaje FrEE
5 Para los otros parametros y para la gestion de las visibilidades consulte el manual de Instalacién Smart
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Evolution

Configuraciones COM®

Las configuraciones son anélogas a lo ya descrito para Smart:
panel Communication > Settings
Para Evolution No ha de seleccionarse EWDMI

e Seleccione CAnOpen en el caso de conexién USB/CAN
e Seleccione Modbus en el caso de conexion USB/RS485
e Seleccione Modbus TCP en el caso de conexién Ethernet mediante el correspondiente plug-in

Si el protocolo no se halla activado pulse la tecla Activate

Device Link =anager Config w1002 x|

Cument selachad pesiocol | EwDIE

Pactocols | Active |
¥ Calpen

T EWDuI At

T Modbus

¥ ModbusTOP

Deespiaon
Elsell DI

e |

Las propiedades, también en este caso, pueden verse y modificarse en el panel Communication > Settings > Properties
Communication > Settings > Properties!”!. E| panel visualizado depende del protocolo activado:

ENEEETTITE e —— T R— o
Torripm dem e I Coprs i W
P [owEEn - T el [ e
Dwatimin |'::I: Eh '-I i et I‘":
7R - Frkad
Protscal L i Mot A =
fukbwur ||7l __; I~ Bas Wit s ot [102m)
Tl |10 .I.-- = gz oyl
_—
[ = [ N = —
CANOpen Modbus ModbusTCP/IP
TARGET EVOLUTION

Evolution, dispone de algunos pardmetros BIOS para la gestion de la conexién entre el target y Studio pero, a diferencia de
Smart, no tiene un mend por defecto presente en el display on board o remoto.!!

Para visualizar los pardmetros resulta por tanto necesario abrir Device

Pardmetros necesarios para la correcta conexién entre el target Evolution y Studio”:

Se muestran los dos protocolos disponibles on board. Para los protocolos disponibles en el médulo plug-in consulte el manual
de instalacion.

Las configuraciones COM valen tanto en Application como en Device
Naturalmente el protocolo ha de Activarse (Activate) anteriormente

Eliwell le proporciona ejemplos de meni HMI de configuracién parametros BIOS
Para los otros parametros consulte el manual de Instalacién Evolution

0 N O
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MODBUS TCP/IP

TARGET EVOLUTION

Evolution, dispone di alcuni parametri BIOS per la gestione della connessione fra il target e Studio ma, a differenza di Smart,

RS485 on board

Conectar el cable Ethernet del PC a FREE Evolution
Haga doble clic sobre el icono de los PC situado en la
parte inferior derecha de la barra de aplicaciones.
Seleccione el protocolo TCP; clique en Propiedades
Configure el puerto Ethernet de su PC con direc-

cién como se muestra en la imagen (10.0.0.101).
Nota. La configuraciéon por defecto del Evolution es
10.0.0.100: el puerto Ethernet del PC se configura
pues con direccion distinta del valor por defecto (por
ej. 10.0.0.101, los primeros 3 campos han de ser igua-
les y el cuarto diferente)

Haga click en ok: el PC se halla configurado para dia-
logar con el FREE Evolution en el puerto Ethernet.

Parametro Descripcion Valores Por defecto Notas
0=9600 baudios
1=19200 baudios
Baudrate protocolo RS485 2=38400 baudios
R On Board 3=57600 baudios 2
4=76800 baudios
5=115200 baudios
La direccién efectiva viene
Addr RS485_OB Direccién serial RS485 On 1955 1 establecida por la suma
Board de este valor + el valor que
asume el dip-switch
Seleccion protocolo RS485 2~ UNET
Proto_RS485_OB On Board 3= Modbus/RTU 3
Databit_RS485_0B | \Umero bitde datoR5485 8 Figag
On Board
. Ndmero bit de stop RS485 1=1 bitde stop
B On Board 2= 2 bitde stop !
. 0= NULL
Parity_RS485_OB Paridad groéocol; RS485 1=0DD >
n Boar 27— EVEN

FREE Studio - Quick Start pag. 35




Ethernet on board

Parametro Descripcion Valores Por defecto Notas
2=500 Kbaudios
3=250 Kbaudios
Baudrate protocolo CAN 4=125 Kbaudios
ICHE L e On Board 5=125 Kbaudios 2
6= 50 Kbaudios
La direccién efectiva viene
Addr_CAN_OB Direccion serial CAN On 1.197 1 establecida por la suma
Board de este valor + el valor que
asume el dip-switch
Configuraciones COM

Las configuraciones son anélogas a lo ya dicho anteriormente para Evolution:

e Seleccione Modbus TCP en el caso de conexidn Ethernet!19

TARGET PANEL

Panel, dispone de algunos pardmetros BIOS para la gestion de la conexién entre el target y Studio

El ment por defecto presente en el display (ment DIA) puede verse pulsando al mismo tiempo las teclas UP y ESC.
El menu por defecto presente en el display muestra solo los pardmetros para el protocolo CAN.
Para visualizar los demés parametros hay que abrir Device.

Los protocolos RS485 y CAN disponibles on board son anélogos a Evolution.

A continuacién se muestran los pardmetros del protocolo Ethernet.

Ethernet on board

Parametro Descripcién Rango Por defecto notas
IP_1_ETH_OB Ethernet passive On Board 0.255 10 por defecto
IP address (1st part) ETH: 010.000.000.100
e timnagels Ethﬁ’rggtci?:zigngggr%ard 0259 g Direccion MAC
IP_3 ETH OB~ dﬁzzzi‘(’;dogfrgard 0..255 0 L
IP_4_ETH_OB Ethf;';e;g’raei‘(’jtfgai‘;ard 0.255 100 SRR
10 No es necesario un médulo adicional
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HMI management

Ademas de los pardmetros BIOS Panel gestiona el mend HMI

HMI management

Parametro Descripcion Valores Por defecto Notas
Hmi_language Idioma en el display (local o 0. 65535 0
remoto)
0=HMIlremota 1
;: :m: ;2?2: g HMI local es identificada
3= HMIl remota 4 como Network en el
_ display
g: :m: ;2?2: 2 En Connection como HVII
HMIList_current Hmi actual B 11
6=HMl remota 7 ) )
7=HMI remota 8 HMI remota es identificada
8= HMI remota 9 en Connection como
9=HMIremota 10 ARSI
10=no usado
11=HMl local

HMI remote

Son disponibles 10 menu remotos. A continuacién se listan los pardmetros del mend 1. Los otros son anédlogos

Parametro Descripcion Valores Por defecto Notas
HmilList_ID_1 Listado ID navegacion HMI remota 1 0...254 0
1=RTU ( RS485 Modbus RTU)
HmilList_Res_1 | Tipo recurso navegacion HMI remota 1 2=TCP (Modbus TCP) 3=CAN
3=CAN (CANopen)
0 Direccion recurso navegacion HMI re-
Hmilist Addr_1 | 1 ara CAN,RTHy TCP (P parte 1) 0...2%5 0
0 Direccidn recurso navegacion HMI . )
HmilList_Addr_2 e 1| e TERil? sere 2 0...255 0 'ei]..é:SAN’l. %,5288?331
HmiList Addr 3 Direccién recurso navegacién HMI 0. 255 0 el:—Ji'H'OSﬁ)O.OO 000' 100
— - remota 1 para TCP (IP parte 3) T
T8 Direccidén recurso navegacién HMI
HmilList_Addr_4 e 1| e TRl see 4 0...255 0
. - . . normalmente el nombre por
HmiList_File_1 (I?I? nr\waJ\(/egDagléJg ?ml remotﬁ 1) secuencia a:facr;urmerlca de8 . defecto ser
ormato .3 mayusculas caracteres HMIREM.KBD
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CONEXION AL TARGET

Antes de la conexidon abajo a la derecha del panel aparece el mensaje NOT CONNECTED
Desde el menu desplegable seleccione Communication > Connect

Si la conexidn ha sido realizada con éxito en la barra de menus aparece la ventana (reducida a icono)

[ sntn
Temige [T
Hom o amw ]

g | - |

Dicha ventana permanece presente mientras el dispositivo target sigue conectado. Para interrumpir la conexién repita el pro-
cedimiento Communication > Connect

Abajo a la derecha del panel hay una paleta de conexién dividida en 3 secciones
Antes de conectarse al target el panel muestra la falta de conexion

| EDIT MODE | | NOT CONNECTED

Cuando estamos conectados al target se dan varias situaciones, que mostramos a continuacion

| EDIT MODE | DIFF. CODE CONNECTED

e CONNECTED (en verde): si la conexién se ha realizado y la aplicacién del target coincide con la aplicacion de Studio
e DIFF CODE (en amarillo): si la conexién se ha realizado y la aplicacién del target No coincide con la aplicaciéon de Studio

| EDITMODE | NOCODDE CONNECTED

e CONNECTED (en verde): si la conexidn se ha realizado
e NO CODE (en celeste ): si la conexidn se ha realizado y no hay ningun aplicacién en el target

| EDIT MDDE SOURCE DK CONNECTED

e CONNECTED (en verde): si la conexién se ha realizado y la aplicacién del target coincide con la aplicacion de Studio
e SOURCE OK (en verde): si la conexién se ha realizado y la aplicacién del target coincide con la aplicacién de Studio

e ERROR (en rojo): si existe un error de comunicacién

DOWNLOAD

Para descargar la aplicacién basta con pulsar F5 o seleccione en el mend desplegable Communication > Download code
Apareceran las siguientes ventanas de didlogo

A. En caso de que ya esté presente la aplicacion se le pide la confirmacién para sobreescribir la anterior version
B. Mensaje de advertencia de que el PLC se reseteara (pondra a cero) en el target

A B
it o it mppaton i 15—t 1 ere St Appmstim =i
‘_E_, -#;-ﬁh-*-ﬂ-"hw-- _ﬁ P ol o 1 T i, e |

] = | | == o i85

Confirmando con 'Si’ la aplicacién se descargara al target. El proceso podré durar unos segundos: aparece la ventana de
‘Download en progress’ para indicar el estado del download.

Si hay un error de conexién aparece la siguiente ventana de didlogo.

114 1 e e A st

.@ (et 5t o o
(s STRG 5 Cogpae

[ -
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DEFINICIONES PANELES DEVICE [[] [free|
Smart

A continuacion se muestra el entorno de trabajo Device con pantallas y descripcion para Smart. En los casos en

que se considera necesario se muestran las diferencias correspondientes a Evolution.

El entorno de trabajo Device presenta varias secciones para la gestion de una aplicacion IEC generada por un

desarrollador, es decir la configuracién de los pardmetros de FREE Smart, tests, actualizacién de BIOS y descarga de aplicacién
al dispositivo target.

Nota: el codigo fuente de la aplicacion No es visible desde el Device

A continuacion el listado de las secciones (paneles):

R R T T T e —

Esta seccion muestra los instrumentos de trabajo
mediante iconos.

Para visualizar o no las barras de instrumentos basta con
hacer click con la tecla derecha del ratén y seleccionar o
deseleccionar los instrumentos deseados.

Barra de configuracién
(Configurator bar)

Algunos instrumentos se pueden seleccionar mediante
combinaciones de teclas (shortcuts).
Ver su correspondiente capitulo para mas detalles.
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Seccion

H*

Nombre Panel /
Secciéon
Application

Project

Catalog

Connection
Status

Watch

Oscilloscope

Output

Panel

Proyecto

Edit panel

Catalogo aplicaciones

Visualizacion de variables con
aplicacion ejecutandose

Visualizacién grafica variables

Mensajes

*panel no visible al primer arranque.
Para visualizarlo basta con seleccionar en el menu desplegable View > Output

Descripcion

El panel Project permite gestionar uno o varios
dispositivos FREE Smart.

En este seccion aparecen, en base a la seleccion del

panel Project

e |os pardmetros BIOS (parémetros + valores 1/O)

* los pardmetrosy las variables definidas por el
desarrollador en Application asociadas al ment

Este panel muestra todas las aplicaciones disponibles en
el catdlogo

Este panel muestra el estado de conexion de todos los
target presentes en el panel Project

Este panel permite gestionar el test de las variables
mediante la visualizacién de su estado en formato
numeros/letras cuando la aplicacion esté ejecutandose y
conectada al dispositivo target

Este panel (analogamente al panel Watch) permite
gestionar el test de las variables mediante la visualizacidn
de su estado en formato grafico cuando la aplicacion
estd ejecutandose y conectada al dispositivo target

Esta panel muestra los mensajes correspondientes al
desarrollo del proyecto (apertura de fichero, errores de
lectura/escritura, estado de conexién al dispostivo etc.)
Nota: la conexion al dispositivo target es visible también
abajo a la derecha de la pantalla mediante mensajes en
color (ver Download Aplicacion)

Los paneles aparecen o no (ver capitulo Shortcuts) y pueden organizarse por lo que respecta a su disposicién y dimension a
gusto del usuario.
Studio memoriza las Ultimas configuraciones realizadas.
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PRIMER ARRANQUE:

1. Haga click en el icono Launch FREE Studio que se encuentra en el Escritorio
2. Haga click en el icono FREE Studio Device!?.

IR studio
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1 2

El programa se presenta como se muestra en la figura:
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Ahora podemos:

e Crear un nuevo proyecto .CFN ‘New Project ..."3!

e Abrir un proyecto existente ' Open project ...’

e Abrir los proyectos recientes ‘Most recent projects ...’ seleccionandolos de un listado

Los proyectos de Device tienen la extensién .CFN

En el mismo proyecto se pueden afiadir varios 'drive' y asociar a cada 'drive’ una aplicacién IEC creada con Application

1 La herramienta Device esta disponible para Smart. Todas las herramientas (incluyendo Device) estan disponibles para Evolution. Para Evolution
le aconsejamos - para el primer Arranque - empezar siempre con la herramienta Connection (ver correspondiente capitulo)

with FREE Studio Device

siguiente.

Un proyecto puede abrirse con Device también desde la aplicacién Application desde el menu desplegable Developer > Open

A un nuevo proyecto se le afiade un 'drive' presente en el catalogo mediante click en tecla derecha del ratén seleccionando Add. Ver pantalla
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Un nuevo proyecto Untitled esta vacio. Con la tecla derecha del ratén afiada un nuevo 'drive’ al proyecto
existente presente en el catdlogo seleccionando Add.
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APERTURA DE LA APLICACION IEC

Del mismo modo se anade la correspondiente aplicacion IEC PLC presente en el catdlogo.
El catalogo puede contener distintas aplicaciones pero solo una puede asociarse a un proyecto
La aplicacion IEC se afiadira al drive como nombre_1

| = e Sgm—— e B

DdE BOCm i

] === | il |
rpar =u il

a=

N T ES

=4

L I i g,

e e

O L Aks - RN i
= s

| — . [ s e

Un proyecto existente se abre como ya se ha descrito o directamente desde Application:
mediante el menu Developer > Open with FREE Device se pondra en marcha el Device que contiene el proyecto creado por

el desarrollador con el entorno de desarrollo Application
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CONEXION AL DISPOSITIVO TARGET

Device presupone que nos tengamos que conectar de nuevo al dispositivo target (haga click en el correspondiente
icono). El panel central muestra las referencias del protocolo, direccidon etc. El nombre del dispositivo target es por defecto
FREESmart_1t1.

Cuando el dispositivo target estd conectado se pueden leer o escribir pardmetros.

LECTURA PARAMETROS!S!

El proyecto contiene por defecto la lista de los parametros BIOS y valores de I/O! con sus correspondientes valores por defec-
to. El usuario puede leer del target todos o solo algunos pardmetrosl?!

Supongamos que lee todos los pardmetros.
Desde el menu desplegable Parameters>Read all device parameters se leen todos los pardmetros del target conectado.
La operacion requiere algunos segundos.

L
»
r

CdE mpoE Va4 SRR H
-t sl o i .
= S . i . a

(€]

[ L8 =3

1=
B B s & ==

—r

T " L& i | o s - Wissins [Eems m, st | Qe s | o | =0Rsd

Si hay pardmetros de configuracién con valores por defecto distintos de los presentes en el target quedaran resaltados con un
color (en azul®l)

ESCRITURA PARAMETROS

El usuario puede descargar al target todos o algunos pardmetros con sus valores por defecto o con valores modificados por el
usuario

Supongamos que desea descargar todos y solo los parametros CL (BIOS locales).

Seleccione todos los pardmetros - menu desplegable Parameters>Select all (CTRL+A) o mediante su correspondiente ico-
no. Los pardmetros quedan todos resaltados en amarillo. Seleccione en el mend desplegable Parameters>Write selected
(CTRL+SHIFT+W) (0 mediante icono W)

Todos los pardmetros CL se descargaran al target!®l.

4 Con un sencillo copiar-pegar se puede crear un proyecto gemelo FREESmart_2, modificar los parametros de BIOS y descargarlos al target o
en un segundo target

5 En realidad en este caso por parametro se entiende cualquier recurso presente en el dispositivo target es decir parametros propiamente dichos,
1/0 y variables de la aplicacion presente en el target

6 Las entradas y salidas analégicas tienen valor por defecto 0.0; las digitales estan configuradas como FALSE

7 Para leer un parametro basta con seleccionarlo con el ratén y hacer click en el icono R.

Se permiten selecciones multiples (tecla CTRL para selecciones no consecutivas, SHIFT para seleccionar una parte del bloque)
Mediante el correspondiente icono se puede seleccionar el bloque completo. La seleccién se resalta mediante un fondo amarillo
8 Ver tabla valores parametros
9 Ver ejemplo desarrollo proyecto - capitulo especifico.
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Como se indica en las notas se pueden descargar también los valores de las variables de I/O configuradas por el usuario
o por defecto. La descarga de todos los pardmetros (menu desplegable Parameters>Write all device parameters!'?)
conlleva la sustitucion de todos los valores presentes en el target por los valores presentes en la columna Value.

Nota: las entradas son solo de lectura y aparecen en color gris. Véase la siguiente tabla:

Tabla valores parametros

Color

negro

azul

rojo

gris

verde

Columna

value

default

value

name

name

valor columna default distinto
de valor columna value

pardmetros no visibles en el

Descripcién

valor alineado con default

valor No alineado con
default

parametros solo de lectura

(read only)

display del target

Casos

lectura del target ya realizada

lectura del target ya realizada

Device recién abierto

valor modificado por el

usuario

valores de 1/0 (/O values)

entradas analdgicas Al

y digitales De

Ver tabla visibilidad

Al declarar las variables de estado y pardmetros EEPROM en Application se puede definir su nivel de visibilidad en el mend
target Smart!'" tal como se muestra en la imagen:
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BIOS Download
Existe la posibilidad de actualizar el BIOS de Smart desde el Device. Seleccione el nombre del target y haga click con la tecla

derecha del ratén. Seleccione BIOS download!'? y abra el fichero .fwf que desea descargar

La modalidad directa Direct se efectia mediante DMI directamente en PC mientras que la modalidad MultiFunctionKey requie-

re el paso mediante la MFK y luego la descarga en Smart

El ment BIOS por defecto de Evolution aparece visible en la carpeta All Parameters.
En la carpeta All Parameters se ven también los pardmetros de usuario definidos con Application
La descarga de la aplicacion PLC y del mend HMl se realiza solo desde el Device pero se describe en el capitulo Connection

El ment BIOS por defecto de EVP es visible desde la carpeta All Parameters. En la carpeta HMI management se ven los para-

metros de gestion de las paginas HMI locales y remotas.

En la carpeta All Parameters también se ven los parametros de usuario definidos con Application

10
11
12
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Si selecciona Parameters>Write all default values en el target se descargaran todos los valores por defecto, incluyendo las I/0
Irrelevante en el Evolution
Consulte el manual instalacién. BIOS Download no disponible mediante RS485.
No alimente Smart externamente (alimentar solo mediante DMI)



DEFINICIONES PANELES USER INTERFACE [[| |free]

Evolution

El entorno de trabajo User Interface especifico para desarrollador presenta varias secciones para la creaciény
gestion de péaginas personalizadas, es decir, la definicion de la interfaz gréfica de FREE Evolution, uso y creacién de plantillas y
descarga HMI al dispositivo target.

A continuacién les mostramos el listado de las secciones (paneles):

riklog Comgird) Sovparel mee LaspaeE |PLFSE

T

]
-

T RO
Fropidssam 16
Freg fi1kw

Panel

El entorno de trabajo User Interface para EVP prevé que la creacién y gestion de paginas y descarga HMI local se produzca en

EVP.

La caracteristica de EVP consiste en gestionar menus remotos de Evolution creados .. e

con Userlnterface. P

Los menus que el EVP utilizard como HMI remotos se crean expresamente como tales. o=t | |

Ver Creacién nuevo proyecto L S
P |,::= =h |
vl L] -

- i

|

FREE Studio - Quick Start pag. 45




Seccion

H

Nombre Panel /
Seccion
User Interface

Project

Actions

Document bar

Properties

Output

Target vars &
parameters

Templates

Panel

Barra de configuracién
(Configurator bar)

Proyecto

Edit panel

Visualizacion propiedades

Mensajes

Visualizacion de variables y
parametros del target

Visualizacion plantillas
disponibles

Los paneles son visibles o no al primer arranque.
Para la visualizacién basta con seleccionar el correspondiente elemento en el ment desplegable. Ej. View > Templates
Los paneles pueden organizarse, por lo que respecta a su disposicién y dimensiones, a gusto del usuario.

Studio memoriza las uUltimas configuraciones realizadas.
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Descripcién

Esta seccion muestra los instrumentos de trabajo
mediante iconos.

Algunos instrumentos se pueden seleccionar mediante
combinaciones de teclas (shortcuts).
Ver su correspondiente capitulo para mas detalles.

El panel Proyecto se subdivide en 2 pestafias:

* Project: permite gestionar las paginas que se
visualizaran en los terminales gréficos de Evolution

* Resources: permite gestionar las imagenes, listas y
secuencias que podran utilizarse en las paginas

En esta seccion aparecen, dependiendo de la pestana
seleccionada:

e Local Actions

e Global Actions

las 'acciones' referidas a las teclas de la interfaz de
Usuario

Este panel permite definir la grafica de las paginas

Este panel permite definir las propiedades de las paginas
o de los elementos que la componen

Esta panel muestra los mensajes correspondientes al
desarrollo del proyecto (apertura de fichero, errores de
compilacioén, etc.)

El panel se subdivide en 2 o varias pestafias:

e Target vars contiene las variables/pardmetros BIOS
de Evolution

e PLC vars contiene las variables/pardmetros definidas
en la aplicacion PLC de Application residente en la
base del Evolution donde seré descargado I'HMI.

e  Otras pestafias visualizan variables/pardmetros con
direccién Modbus a visualizar en la Interfaz HMI.
Nota: estas aplicaciones han sido descargadas
mediante Studio a otros Evolution conectados en
red al Evolution donde se descargaré el HMI que se
desea desarrollar

Este panel muestra todas las paginas creadas como
'template’ es decir como plantillas para volver a utilizar
que permancen disponibles en el catdlogo



PARA INICIAR USER INTERFACE [|| [free

Panel ¢ Evolution

USERINTERFACE VS CONNECTION

Como ya se ha indicado en el capitulo TARGET y como se ha descrito en el capitulo Connection la apertura de Userlnterface
se lleva a cabo normalmente desde Connection haciendo click sobre el nodo HMI

Le aconsejamos por tanto que lea el capitulo Connection antes de desarrollar un menu en Userinterface

Para efectuar los primeros pasos y crear un menu sencillo 'stand-alone'"! se puede seguir el camino que les mostramos a
continuacién

PRIMER ARRANQUE

1. Haga click en el icono Launch FREE Studio que se encuentra en el Escritorio
2. Haga click en el icono FREE Studio User Interface.

dlivll
IR studio
vsen wrenonce |

1 2

e ==
i L.
Mos = T
.l
e S TR
W WP e R | s esey (W e Rt W
1 Un meni creado de este modo queda enlazado ('linkado') a un proyecto Connection. Ver correspondiente capitulo.
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Ahora podemos:
e Crear un nuevo proyecto ‘'New Project ...’ - CTRL+N U l
e Abrir un proyecto existente ' Open project ...’ - CTRL+O

Los proyectos existentes tienen la extensién .pajx

CREACION NUEVO PROYECTO

e Haga click en New Project... o
e desde el menu desplegable seleccione File > New Project (CTRL+N)

Aparece la ventana de didlogo siguiente donde se puede crear y guardar con nombre un nuevo proyecto:

Nuevo Proyecto Nuevo HMI remoto

El nuevo proyecto se presenta como se muestra en la figura:

LI T T T —
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Pt ISl ] e )
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[FE——— [r— -
mor— § -
e [ ] =
1]

.

e Ladescripcion de losiconos se encuentra disponible en el Help en linea (Ayuda en Linea, en inglés) - véase el capitulo
Soporte

e Ladescripcion de los paneles del entorno de desarrollo standard descrita con anterioridad se desarrolla en el presente
capitulo

A continuacion le mostraremos como crear, desarrollar y testar un nuevo mend con ejemplos sencillos de paginas, plantillas y
programas sencillos.
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CREACION DE PAGINAS

En el panel Document bar se visualizaran todas las paginas creadas que compondran el mend visible en el display del instru-
mento. A continuacién se mostrardn en modo generico los elementos para crear las paginas
En en Apéndice se mostraran algunos simples ejemplos de menud que podran utilizar para definir un mend bésico que funcione.

PANEL PROJECT / PESTANA PROJECT

En esta pestafia se puede utilizar los siguientes elementos (nodos):

e Pages para gestionar las paginas (creacién, borrado, importacién/exportacién, etc)

e Messages para gestionar las paginas 'mensaje’

e Global variables para gestionar las 'variables' comunes a todas las paginas

e Global procedures para gestionar los 'procedimientos' comunes a todas las paginas. Nota: los procedimientos se escriben
en un solo lenguaje.

PAGES

Properties
Desde la pestana Project, nodo Pages se puede, haciendo click con la tecla derecha en Properties editar las propiedades de
las paginas!tal como se ha indicado:

A ETEEE—— A EFTTTEEEE—— L

| B I | | | | ey a0 | s |
Fasipuliy | - e | e _“—.—I ]
s [ | |[p...—
e I
gl ¢ e
ITI | i | ITI e || i | 2 1 e || i |
General System options Language selection

—

Desde la tab General se puede elegir qual es la pagina inicial
2. Desde la tab System options se puede elegir el tipo de font!?, el color del texto y del fondo (2 opciones, blanco y negro)
3. Desde la tab Language selection se pueden gestionar los idiomas:
e con Select se selecciona el idioma actual (indicata en el box Current language),
e con Add se afiade un nuevo idioma
e con Delete se borra el idioma
e con Export se exporta y importa el fichero texto .txt a traducirt®
e con Import se importa respectivamente el fichero de texto .txt traducido!!
4. desde latab Global On timer el desarrollador puede afadir procedimientos globales 'a tempo' creados especificamente

Creacién paginas

Mediante el menu desplegable seleccione Project >Objects (insert page) o haga click en el correspondiente icono New Page
Aparece una ventana donde puede introducir el nombre de la paginal®. La pagina creada aparece en la seccién Document bar
(donde se puede editar y modificar)

Nota: la pagina puede ser configurada como pégina de pop-up'®!

queste propiedades no son de la singola pagina ma comunes a todas las paginas

visible también desde la pestaiia Resources > Fonts

también desde el menu desplegable Project > Export language to file...

también desde el menu desplegable Project > Import language from file...

el nombre de la pagina no ha de contenere spazi (ej. New Page da error; NewPage (sin spazi) o New_Page (con underscore) son nomi
accettati. Otros caracteres pueden no ser accettati (Es. /, <,>, etc)

en el display aparece siempre una pagina a la volta. Una pagina de pop-up es una pagina que aparece en el display sopra un'altra pagina

ABRWN=

o
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Pagina inicial m

Ha de asignarse obligatoriamente la propiedad de péagina 'inicial' (Initial page)”!

La pagina inicial puede ser la pagina utilizada para la 'visualizacién principal' es decir la pagina por defecto que aparece si no si
opera en el instrumento. Por tanto se puede definir como visualizacién principal una imagen!® (ej. logo o nombre de la em-
presa) o una pagina que visualice valores (e]. de temperatura, pulsacién ,setpoint etc) importantes para mostrar a una primera
lectura Nota: si no se selecciona la pagina inicial se producird un error de compilacion.

Gestion de paginas
Haciendo click con la tecla derecha del raton seré posible renombrar, copiar, borrar la pagina, etc.

T sa sESSAD
3 : T
.‘- LE | ; ]
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Insert page New page

Messages

Desde el panel Project, haciendo click con la tecla derecha sobre el nodo Messages y seleccionando Insert new message
page se crea una nueva pagina 'mensaje'l?l

Las paginas de 'mensaje’ son anélogas alle altre paginas ma ciascuna riporta un ID univoco

A continuacién un ejemplo de llamada de pagina “mensaje” y su correspondiente sintaxis.

Llamada desde un script User Interface: dummyboolean:=Video_SendEvent( kWM_MSG, MessagelD );

Llamada desde un program Application: dummyboolean:=sysHmi_Message(MessagelD);

Proyct x
fE] N TPresnct Predect
[ e page ] 5 gnq-.
Il B ruwee o Ha reews g Mg [0 F
-~ e o
| LT [1 E Local vark
I Poers F Ll procachares

= [ Nesbessagerage 2
[ ok | canca | (2 tocal varables
F Locd protedones
#- ] Sobesd veriables
f okl procadures

Pagina mensaje ej. albero paginas mensaje ejemplo pagina mensaje 1

Template

Desde el panel Project, haciendo click con la tecla derecha en una pégina se puede exportar una pagina (sufijo .pex) o selec-
cionando Export page as template se guarda una pagina como pagina 'plantilla'®l. (sufijo .petx)

Desde el menu desplegable Project > Template management se pueden gestionar las plantillas afiadiendo a la Template List
paginas .petx. Las paginas afiadidas se visualizardn también en el panel Templates como libreria y seran utilizables mediante
drag & drop (arrastrar y soltar) en el proyecto seleccionando segin el momento la plantilla deseada.

modificable da seccién (nodo) Pages. La pagina inicial es contraddistinta por un icono stile 'play’ (triangolo rojo).
en gergo definida como 'splash’
identificadas en el albero con un triangolo a fondo amarillo stile 'Avvertenza' (Warning)

&EE Stuu itgrp al.tlfc S énr?dre,lgé:.sg&ma da compilar en base a un struttura predefinita

T 0 N



_ LI f i v ;

o e T
Pl : —_—
i =Sl
e 2z
] :.'.'.“.'.‘.‘.’

A tredsepin e

— ieins

Lista template Libreria template Instancia pagina template

PANEL PROPERTIES

Cada objeto que se disefna en la pagina tiene propiedades configurables con la pestaiia Properties.

Dependiendo del objeto seleccionado de la Page bar en la pestaiia Properties aparecen o no los elementos para la correcta
gestion del objeto dentro de la pagina

La lista completa estd documentada en la Help on line. Aqui solo se listan los més utilizados.

PESTANA PROPERTIES!""!

Cada pégina, indivdualmente, posee las propiedades que pasamos a enumerar:
Default Descripcion Default Descripcion

Introduce un
encabezamiento

CharDimX 6 Define las 'guias' Title bar NO d ~
o e tamafo
de larejilla de la _
P predefinido
pagina
min(1,1) para
CharDimY 8 colocar los objetos Page border NO Introjucelup SIEeiS
e pagina
define el
Font EWP2 8x16 dimensién oo . contenldo‘del
caracteres encabezamiento
(Title bar)
Back color ‘white' Color del fondo Appearance Flat deﬂnle ellbgrde ok
a pagina
Text color ‘black' color del texto

A cada modificacion de estos campos le corresponde la aparicion de un asterisco (*) cerca del nombre de la pagina.
Para guardar la modificacién utilice siempre la tecla RETURN.

PANEL ACTIONS

Este panel permite definir las 'acciones' asignadas a los teclas de Evolution para la navegacién del menu en el display.

Las acciones se subdividen en

e Local Actions: acciones 'locales' especificas de la pagina en cuestion

¢ Global Actions: acciones 'globales' comunes a todas las paginas del mend/proyecto

Las teclas de Evolution son 4: Right (dx), Left (sx), Up, Down y Enter (tecla OK). Se puede asociar ademaés una accién a la pulsa-
cién 'mantenida’ de cada una de las 4 teclas!'? (identificada con el prefijo Long, ej. LongUp).

Ademas de las 4 teclas hay 10 teclas 'virtuales identificadas con VK_F1, ..., VKF10!"3!
Las teclas virtuales se asocian a un procedimiento escrito en lenguaje ST

11 No confundir con el correspondiente elemento 'Properties' de la pestaiia Project, seccién (nodo) Pages
12 Se mantiene pulsada normalmente de 3-5 segundos
13 Ver también manual Userlnterface (Help On Line)
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Por ejemplo deseamos configurar la hora del reloj RTC. Creamos la correspondiente pagina
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A la pagina le hemos asociado una tecla virtual VK_F1 (Close) en las Acciones Locales.
El procedimiento en lenguaje ST es el siguiente

sysClock update := TRUE;
uint ret := Video SendEventM (kWM KEY, kKEY VK_F1);

Para introducir una accién (Action) haga click con la tecla derecha y seleccione Insert action. La accién seleccionada queda
resaltada en amarillo. La seleccién de Remove action borrara la accion resaltada en amarillo
A cada tecla (key) se le pueden asociar las acciones siguientes

Accién (columna Action) Descripcién Notas
para 'llamar' un procedimiento basta
Call llamada de un procedimiento escribir en la columna Link el nombre

del procedimiento a llamar

e abre una baqina escriba en la columna Link el nombre de
P 9 pag la pagina que ha de abrir

asociamos la correspondiente tecla.
cierra la pagina Nota: vuelve automaticamente a la

Close
pagina de inicio
. se coloca sobre el siguiente valor de un
NextField 9
campo
. se coloca sobre el anterior valor de un
PrevField
campo
Edit permite 'Editar' es decir escribir un valor
en un campo
14 Las funciones estandar preconfiguradas como VideoSentEvent, etc (se escriben a mano) se describen en el manual Userinterface
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PARAMETROS APLICACIONES

Desde el MenU Project > Parameter management!'s! se pueden conectar los pardmetros de una aplicacién desarrollada en
Application

T — 5 Not.

* |d=0 esta reservado para EVK1000 o link entre
un proyecto Userlnterface y Application resi-

Bty Dclin dentes en el mismo hardware

* |d#0 que se configura en caso de una conexién
a dispositivo externo (es decir, visualizacién de
datos provenientes de otro dispositivo, es decir
un hardware distinto del dispositivo target don-

Lo | de se ejecuta UserInterface)

Con Add Device se importa el fichero de pardmetros (.parx) deseado. A cada set de pardmetros se le puede asociar el direc-
cionamiento Modbus o EWDMI"¢ 0 Modbus y CANOpenl'7l,
El set de pardmetros se visualiza en su correspondiente pestaiia en el panel Target vars and parameters

PESTANA PROPERTIES/VARIABLE

Para utilizar la variable basta con 'arrastrarla’ (drag and drop) desde la pestafia importada a la paginal'®

La propiedades de la variable se identifican en la pestafia Properties/Variable con la 'sintaxis @'

La variable se identifica como @nombre del file!'?.nomevariabile

Para modificarla basta seleccionar el campo Variable y situdndose en la casilla hacer click sobre los puntos suspensivos (...)
Aparece la ventana Variable parameter selection que muestra los recursos disponibles para asociar a la casilla

Nota: del mismo modo se puede crear una casilla 'progress' y asociarle una variable. En este caso en lugar del valor de la varia-
ble se ve el estado / barra gréfica de progreso de la misma.

VARIABLES PLC

Nota. Valido solo para proyectos con dispositivo target EVD/EVP

El target HMI remote soporta solo la sintaxis @ para la utilizaciéon de pardmetros/estatus variables del correspondiente proyecto
Application.

Desde MenU Project >Link PLC variables file se pueden conectar las variables de una aplicacién PLC desarrollada en Appli-
cation

e Em
— : A e
—
—— - . - .E I

. =
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Se importara el fichero 'EXP variable' (.exp) deseado. El set de pardmetros se visualiza en la correspondiente pestafia PLC vars
en el panel Target vars and parameters

15 O con el correspondiente icono Parameter management

16 Smart

17 Evolution

18 Como alternativa desde el meni Page>New Edit introduzca una casilla a la que asociar la correspondiente variable
19 Sin extensién (ej. freeEvolution_1.plc, .plc no se visualizara)
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GENERACION DE DOCUMENTACION

Mediante el icono Generate Doc. se crea la documentacién referida a los campos Doc (panel Properties, tab Doc)
lucumentation 1]
Dupoumentstion comechy gensrsbed

Lo ke ke

=3

Mediante un navegador!?®! se puede visualizar la documentacién generada haciendo click sobre el link Open documentation.
la documentacién contiene toda la informacién del proyecto:

® nuUmero de paginas

e idiomas del programa

e paginainicial (nombre de la pagina inicial)

e listado visual de las paginas (como aparecen en el display)

Ejemplo de documentacion generada mediante el icono Generate Doc.
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20 Internet Explorer y equivalentes
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PANEL PROJECT / PESTANA RESOURCES

En esta pestana se pueden utilizar los siguientes elementos (nodos):

¢ Fonts para gestionar las paginas (creacion, borrado, importaciéon/exportacion, etc)

e Bitmaps para gestionar las imégenes que se introducen en las paginas

e  String table para gestionar las 'secuencias' que se utilizan en las distintas paginas

e Enumeratives para gestionar conjuntos 'numerables' que se utilizan en las distintas paginas
¢ Image lists

e Sets para gestionar 'set' de 'secuencias' / pardmetros que se utilizan en las distintas paginas
Bitmaps

Userinterface permite importar imagenes (bitmaps , como iconos, logos etc) para utilizarlas en las paginas del menu.
Haga click desde el nodo Bitmaps > Import bitmap. Aparece la correspondiente ventana para importar imagen. Seleccione
mediante la tecla browse y realice la importacion con la tecla Import. Ejemplo de importacion del logo free

— e e

il O ] -

—— —a

Le aconsejamos importar imagenes en blanco/negro con una dimension coherente. El display puede soportar una imagen
100x50px aprox. El bitmap importado se encontraré en el nodo Bitmaps!?"

Para introducir el bitmap en una pagina:

e introducir una casilla 'imagen' (mend Page > New Image o mediante el correspondiente icono)

e definir las dimensiones de la imagen desde el panel Properties mediante XDim y YDim (ej. 100x50px)

e igualmente, desde el panel Properties seleccione el bitmap del campo del mismo nombre.

b L]
P o} o et ] M 0

String table

UserInterface permite definir 'secuencias’ (strings) que podemos utilizar en la creacién de las paginas.

Mediante el menu String>Insert o con el correspondiente icono Insert Record se puede crear una asociacion?? entre una
'secuencia' y su correspondiente descripcidn.

En el campo ID se define la secuencia como IDS_nomestringa. (23

En el campo Caption se introduce la descripcion.

| — e
_———— i = —_ -
T T P g o 1
21 Si no se renombra, como nombre por defecto aparecera el nombre de la imagen precedida por el prefijo bmp (ej. logofree-> bmplogofree)
22 En jerga 'transcodificacién’
23 Le aconsejamos utilizar este prefijo para no confundir las descripciones que aparecen en el display con la transcodificacién en Userinterface
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Desde el ment Project/Project seleccionando la pagina se puede asociar mediante el men( Properties>Caption la secuencia
deseada a un campo de textol?4. El texto que apareceréd en el display seré el que se defina en la descripcion!?®]

Enumeratives

Userinterface permite ademas definir las 'secuencias' mediante conjuntos 'numerables' que se pueden utilizar para la creacion
de las paginas.

Un conjunto numerable es un 'vector' de valores no necesariamente consecutivos. A cada valor se le asocia una descripcidn
que se visualiza en el display del Evolution.

Situdndose sobre el nodo Enumeratives y mediante el menl Record>Insert o con el correspondiente icono Insert Record se
crean los conjuntos a utilizar2l

Cada conjunto se visualizard como subnodo de Enumeratives.

Situdndose sobre el correspondiente nodo y mediante el menl Record>Insert o con el correspondiente icono Insert Record
se introducen los valores del vector.

Tras haber creado (es decir definido) el enumerativo en la pestafia Resources, se pasa a la pestana Project y, seleccionando la
pagina / elemento de la pagina deseada, tendremos que asociar al campo Format el correspondiente Enum

En los tres ejemplos puede apreciarse:

¢ definicién de un enumerativo CelFarEnum de 2 valores para definir los grados de temperatura (0=Celsius, 1=Fahrenheit).
e definicién de un enumerativo de 4 valores no consecutivos para definir comandos USB (valores 8,9,10,12)

e uso de CelFarEnum en una péagina

El orden de los elementos se puede modificar con los iconos Move Up A / Move Down ¥
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Definiciéon de CelFarEnum Enum con valores no consecutivos Uso de CelFarEnum

Image Lists

Igual que con los Enum se pueden crear 'listas' de imdgenes asociadas a 'rangos' de valores. La imagen que aparece en el

display se modificard dependiendo del estado de la variable asociada a la lista.

Se crea la lista y se asocia a cada imagen un bitmap (ver correspondiente nodo) indicando el rango de referencia.

Tras haber creado (es decir definido) la lista en la pestaiia Resources, se pasa a la pestana Project y, seleccionando la pagina /

elemento (creado con 'New animation') de la pagina deseada, se tendré que asociar al campo Imagelist |a lista de bitmap

En los tres ejemplos puede apreciarse:

e definicién de una lista Modeimg de 2 bitmaps para visualizar el modo Cool y el modo Heat. El rango de valores se reduce
a un valor, en este caso (0 para cool, 1 para heat)

e uso de Modeimg en una péagina 'lcons' asociando a la animacién la lista Modeimg. Se le asocia naturalmente una variable
de estado en funcién de la cual cambiaréa la imagen.

Un bitmap 'estético’ se introduce como imagen mediante Page > New Image o mediante su correspondiente icono.

24 En realidad se pueden asociar también imagenes pero aqui por simplificar hablamos solo de campos de texto.
25 Si el campo Descripcién esta vacio aparece la secuencia IDS_xxx
26 Por defecto el nombre es Enum1, Enum2, etc. Situése sobre la casilla para cambiar el nombre.
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Definicién de Modelmg Uso de Modelmg

Sets

A menudo existe la necesidad de crear un grupo de paginas muy similares entre ellas (por ejemplo un menu con desplaza-
miento para visualizar un conjunto de pardmetros de una misma carpeta)

Userlnterface permite definir conjuntos 'Sets' que se pueden utilizar para la creacién de paginas de este tipo sin tener que
replicar la pagina n veces.

Un Set es un 'vector' de secuencias o variables/paradmetros!?”]

Situdndose sobre el nodo Sets y mediante el menu Record>Insert o con el correspondiente icono Insert Record se crean los
conjuntos que se han de utilizarl2®

El tipo del Set puede ser

e String es decir una 'secuencia’ definida en String table

e Variant es decir una 'variable/pardmetro’

Cada conjunto se visualizard como subnodo de Sets.
Situdndose en el correspondiente nodo y mediante el menu Record>Insert o con el correspondiente icono Insert Record se
introducen nuevos items del vector

Strings

En el caso de un Set de tipo String la seleccion de la secuencia se realiza situdndose sobre la casilla y haciendo click sobre los
puntos suspensivos (...)

Aparece la ventana Resource string selection que muestra las secuencias disponibles!?? para asociar al vector.

La visibilidad (columna Visible) para las secuencias es TRUE - no modificable.

Variant

En el caso de un Set de tipo Variant la seleccién de la 'variable'®% se realiza de igual modo, situdndose en la columna Varia-
ble/Parameter

Aparece la ventana Variable/parameter selection que muestra las 'variables' disponibles para asociar al vector

27 Incluyendo posibles alarmas

28 Por defecto el nombre es Set1,Set2, etc. Situése sobre la casilla para cambiar el nombre

29 Definidas anteriormente en la string table (ver)

30 Por 'variable' en este caso se entienden las variables propiamente dichas, parametros PLC, BIOS, alarmas etc
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Mediante la opcién Filter se puede 'filtrar' la visualizacién de las variables/pardmetros

e La columna Format visualiza la U.M. por defecto del pardmetro. El usuario puede asociar manualmente un Enum
e Deigual modo las columnas Min Max visualizan el rango por defecto del pardmetro modificable por el usuariof3!
e La columna Text align alinea la secuencia a la derecha, izquierda o centrada

Tras haber creado el Set desde la pestana Resources, se pasa a la pestafia Project

Anteriormente si se ha creado una pagina que se desea 'replicar' utilizando los Set

(por ejemplo para la gestidn de las salidas Analégicas BIOS_CFG_AO)

Seleccionando el correspondiente campo se tendréd que asociar al campo Assoc_var el correspondiente Set utilizando el prefi-
jo #, y como sufijo (0) para indicar el primer elemento del vector. Nota: El campo ha de ser de tipo Edit

(por ejemplo para la gestion de las salidas Analdgicas #SetParValCfgA0(0))

En los tres ejemplos se ve:

e definicién de un Set Variant SetParValCfgAO de dimension 5 para definir vector de los parametros de configuracion de las
salidas analdgicas

¢ definicién de un enumerativo AnaOutTypeEnum de 3 valores (tensién, corriente, ON/OFF)

e uso de #SetParValCfgA0(0) en una pagina (que produce como resultado 5 paginas que difieren segun la configuracion
del pardmetro SetParValCfgAO(1),..., SetParValCfgA0(5)i2

e téngase en cuenta que el campo Edit 'lO Modulated' esté asociado mediante el campo Format al Enumerativo AnaOutT-
ypeEnum

Téngase en cuenta que en el ejemplo hay otro campo Edit asociado a un Set.
Es posible utilizar varios Set en la misma péagina
Le aconsejamos que defina Set de la misma dimension si se usan en la misma péagina.

ErTEEE——— A

o b W | g e | i T | r—— -
I e | i |

A T e e srmw e E

ad [T E -

- I'i-.r-—. R o — B Y =
= == = - P — s

e o s I

L - a
I [ I e || it |
SetParValCfgAO AnaOutTypeEnum uso de #SetParValCfgAO()
31 Ej. En un parametro que define un Modo de maquina COOL, HEAT y AUTO se pueden ocultar uno o varios valores a nivel Ul aunque a nivel
PLC (es decir Application) haya 3 modos de utilizacién
32 Téngase en cuenta que el vector parte del valor (0), mientras que en la definicién de Set el primer valor es 1 por tanto Set(1) corresponde a #Set(0)
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DEFINICIONES PANELES CONNECTION [|| [free

Panel ¢ Evolution 0

Como se indica en los capitulos anteriores Connection es el punto de partida para empezar a desarrollar los

proyectos
El entorno de trabajo Connection define la estructura hardware de un proyecto Evolution y gestiona los protocolos de red e

intercambio de datos entre Evolution (binding)

El entorno de trabajo Connection , especifico para el desarrollador, presenta varias secciones para la creacién y gestién de
dispositivos Evolution!"], y la compilacién de todo el proyecto,es decir, como se indica en la seccion Target

* |acreacién de la aplicacién PLC mediante Application

e |a definicién de la interfaz gréafica de Evolution mediante Userlnterface

* la compilacion del proyecto Build project

¢ ladescarga del proyecto mediante Device

A continuacion le mostramos el listado de las secciones (paneles): A

q Esta seccion muestra las herramientas de trabajo
Barra de los instrumentos di ;
(Main bar) mediante iconos.
A / Algunas herramientas se pueden seleccionar mediante
combinaciones de teclas (shortcuts).
Ver su correspondiente capitulo para mas detalles
El panel Project permite gestionar el proyecto y uno o
varios dispositivos Evolution*
. e desde el proyecto se puede gestionar la red
8 e O Proyecto (Workspace) (Network list) de dispositivos
e Dentro de cada dispositivo (device) se configuran los
distintos protocolos - ver panel C
1 Incluyendo Panel (EVP) y terminal EVK1000. Por Evolution se entiende EVD con display, EVC (no display)
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Nombre Panel /
Seccién Seccién Panel Descripcién
Application

En esta seccion aparece
e pestaia General gestién proyectos
e pestaiia Network list gestién redes

Dependiendo de la seleccién del dispositivo Evolution
* pestaiia General configuracion Evolution

Dentro del dispostivo (ej. Evolution EVD)

e  PLC configuracién de la aplicacion IEC desarrollado
con Application

HMI configuracién ment User Interface

CANopen configuracién correspondiente protocolo
RS485 configuracion correspondiente protocolo
Plugins configuracion protocolos mediante plug-in

Configuration panel
(Edit)

Este panel muestra todos los dispositivos disponibles en
D Catalog Catalogo dispositivos el catédlogo. Nota. Visibilidad dindmica de los dispositivos
dependiendo de las selecciones (ej: plugins)

Esta panel muestra los mensajes correspondientes al
desarrollo del proyecto (apertura de fichero, errores de
lectura/escritura, estado de conexién al dispostivo etc.)
Nota: la conexién al dispositivo target también es visible
abajo a la derecha de la pantalla mediante mensajes en
color (ver Download Aplicacién)

*Connection gestiona uno o varias Evolution (EVD, EVC, terminal EVK1000) y EVP

Smart puede introducirse en la red como dispositivo slave mediante RS485

La expansién EVE puede introducirse en la red como dispositivo slave mediante RS485 o CANOpen

La visualizacién de los paneles es configurable desde el menu desplegable View > nombre panello y pueden organizarse
por lo que respecta a su disposicion y dimensiones a gusto del usuario.

Studio memoriza las Ultimas configuraciones realizadas.

E Output Mensajes

El panel View > Compiler toolbar =5 es un icono visible o no desde el mend Main

Configuration panel (Edit)

Se muestran los varios device / nodos por defecto disponibles para los varios target. Los device para EVD se indican en la
tabla anterior secciéon €

EVD EVP EVC y EVK son devices disponibles como nodos 'root' del proyecto (ver apartado Panel Project).

——
o =
- L

EVP Panel EVC terminal EVK
e PLC e PLC ¢ CANopen
e HMI e HMI Remote Téngase en cuenta que el Gnico
e CANopen e CANopen protocolo disponible es el CANOpen
e RS485 e RS485 No hay plugins presentes
e Ethernet e  Plugins PLC y HMI se heredan del Evolution
Téngase en cuenta que no hay Téngase en cuenta que HMI es de
plugins Ethernet a bordo tipo remoto
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PARA INICIAR CONNECTION [[] [free]
Panel ¢ Evolution

PRIMER ARRANQUE

1. Hagaclick en el icono Launch FREE Studio que se encuentra en el Escritorio
2. Haga click en el icono FREE Studio Connection.

En este momento podemos:

e Afadir un nuevo dispositivo (device) al proyecto

e Afadir /quitar una red desde la lista network (Network list)
Los proyectos existentes tienen la extension .con

CREACION NUEVO PROYECTO (WORKSPACE)

Para crear un nuevo proyecto, basta simplemente guardar el proyecto Untitled™ renombrandolo a su gusto (CTRL+S)
Para anadir un dispositivo al proyecto haga click en Add new device to the project'?! o simplemente arrastre (drag and drop)

elicono de FreeEvolution desde el panel Catalog sobre el nombre del proyecto.
1 Al guardar el proyecto se crea en su PC una nueva carpeta con el nombre preseleccionado que sirve de Workspace
2 O desde el menii Project, tecla derecha en Untitled (o nombre de proyecto si ya esta guardado) > Add
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Ejemplo Add (Device)

Le aconsejamos renombrar cada Evolution con un nombre adecuado (por defecto FreeEvolution1, FreeEvolution2, etc)
En el workspace se ve el nombre del dispositivo y la version (Version)®!

e

creacién nuevo proyecto CTRL+S

Catalogo de dispositivos

s
e LT
i
- . - as
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anadido Evolution al proyecto
Téngase en cuenta ejemplo afadido de 2 Evolution
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3 En el catalogo pueden haber mas Evolution con versiones distintas (para visualizar todas las versiones

menu Options > Show all versions en catalog o mediante la casilla de chequeo ¥ cuando aparece la ventana de dialogo)
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ejemplo EVD + 2 terminales EVK
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Los dos terminales keyboard EVK se conectan ambos al nodo CANOpen
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Nodo CANOpen canali virtuali canali virtuali
channel1:124; channel2: 123 channel1:124; channel2: 123

El nodo CANOpen prevé por defecto 2 canales 'virtuales' para conectar como maximo 2 terminales EVK1000
Por defecto los canales virtuales son 124 para el primer terminal y 123 para el segundo terminal EVK1000
En todo caso basta con clicar en ? desde el nodo CANOpen para visualizar sus valores.

Por defecto el terminal Keyboard EVK_1 tiene como direccién 127, canal virtual 124 y baudrate CanOpen 500Kb/s
Por tanto conectando fisicamente un terminal EVK1000 con las configuraciones por defecto a un EVD es suficiente con cargar

HMI remote desde el menu BIOS del EVK.

En caso contrario, por ejemplo con un Keyboard EVK_2 (que tiene como direccién 126) hay que configurar desde el ment BIOS

del EVK la direccion 126 y el canal virtual 123.
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PANEL PROJECT

Cada Evolution dispone de los siguientes recursos visualizados como 'nodos' del target

Co

target

EVD
EVC
EVP

EVD
EVP

EVD
EVC

target

EVD
EVC
EVP
EVK

EVD
EVC
EVP

EVP

EVD
EVC

ambiente de
trabajo

PLC

HMI

HMI remote

device

CANOpen*

RS485*

Ethernet

Plugins**

descripcion

proyecto PLC

menu para la creacion de las
paginas

menu para la creacion de las
paginas

descripcion

serial Evolution
a bordo (on board) de serie

serial Evolution
on board de serie modelos
EVD7500 y expansiones
EVE75xx

mddulos opcionales que se
compran por separado

qué hacer

situése sobre el nodo y haga
click con la tecla derecha del
ratén para abrir Application

situése sobre el nodo y haga
click con la tecla derecha
del ratén para abrir User
Interface

situése sobre el nodo y haga
click con la tecla derecha
del ratén para abrir User
Interface

cosa fare

seleccione el modo (Mode) y
anadael dispositivo desde el
catédlogo

* disponibles también como seriales en médulo plug-in

**es plug-in Ethernet

Notas

ver capitulo Para Iniciar
(Application)

ver capitulo Para Iniciar (User
Interface)

ver capitulo Para Iniciar (User
Interface)

Notas

siempre disponible

comprobar disponibilidad

comprobar disponibilidad

comprobar disponibilidad

Tanto PLC como HMI pueden ser creados desde cero o se pueden importar proyectos pre-existentes y desde el catdlogo

Proyecto PLC

Desde el panel Project > nodo PLC haga click con la tecla derecha del ratéon y seleccione Open with Free Studio Application
Por defecto se le pedird que guarde el proyecto FreeEvolution_n_PLC
Ver capitulo Application para el desarrollo. Resumiendo:
e desarrollar el cédigo PLC con Application

e  crear parametros y variables de estado de la aplicacion PLC

e compilar, descargar aplicacion en el Evolution y realizar una eventual depuracién
e cerrar Application y volver a Connection
El proyecto guardado .ppjs se encuentra en la carpeta / workspace de Connection

Proyecto HMI
Desde el panel Project > nodo PLC haga click con la tecla derecha del raton y seleccione Open with Free Studio Userinterfa-

ce

Por defecto se le pedird que guarde el proyecto FreeEvolution_n_HMI
Ver capitulo User Interface para el desarrollo. Resumiendo:
e desarrollar el menu, es decir, las paginas HMI con Userlnterface
® |os pardmetros y las variables de estado de la aplicacién PLC anteriormente creado se enlazan al menU y apareceran en la
secciéon H de Userlnterface Target vars & parameters
e comprobar la modalidad de conexién configurando debidamente los pardmetros de conexion
e compilar, descargar al Evolution las paginas HMI
e cerrar Userinterface y volver a Connection
El proyecto guardado .pajx se encuentra en la carpeta / workspace de Connection
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El dispostivo se afiadira a una lista (se resalta en color amarillo)

Pulse la tecla Reload Device List para llenar la tabla con el listado de los dispositivos conectados al proyecto HMI y para po-
der, si fuera necesario, usar las paginas remotamente.

Proyecto HMI Remote

Anélogo a Proyecto HMI
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PLC Configuration HMI configuration
anadido proyecto existente anadido proyecto existente y Reload lista dispositivos

Download proyecto

Mediante el menu Tools>Build o con F7 se crea el fichero de configuracién .CFN

Desde el panel Tools > Open with Free Studio Device se abre Device

Una vez configurado el dispositivo, es decir los pardmetros BIOS de comunicacién, sera posible descargar:

e aplicacién PLC

®* paginas HMI

e fichero de configuracion Cfg files

mediante la tecla Download All

Nota: cada uno de los 3 ficheros puede ser descargado independientemente de los otros dos. situandose sobre el correspon-
diente icono, haciendo click con la tecla derecha del ratén y ejecutando la correspondiente descarga (download).

GESTION DE PROTOCOLOS

Cada protocolo puede utilizarse de varios modos.
Si el Mode aparece como Not used significa que su correspondiente device no esta siendo usado.

target | CANOpen \ RS485 Ethernet \
o Masrorfed) (oMo MAN Gtleedeie
and binding)
E://g Master (for field) Slave (for binding) Mog:fzgfj;ter -
Evi (for HI\'\/I/llars;fnroting) ) ) )

Para las configuraciones (settings) consulte la Ayuda en Linea (pulsando F1)

En el catdlogo se visualizaran todos y solo los dispositivos que se pueden anadir ('colgar' con drag and drop) al correspondien-
te protocolo.

En el caso Slave y Ethernet se afiade el dispositivo 'Binding'. Para afadir un source device' se selecciona la red (network)

El nimero méaximo de dispositivos que se pueden anadir al nodo es comprobado por el Studio y sefialado con el correspon-
diente mensaje. (Ej. méximo 2 EVK en CANOpen).¥!

En el protocolo RS485 se pueden conectar también dispositivos genéricos Modbus

4 Véase también r I de Instalacion FREE Evolution y FREE Panel
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DEFINICIONES PANELES SIMULATION [|| [free

Smart Evolution

El entorno de trabajo Simulation, especifico para desarrollador, presenta varias secciones para la ejecucién
simultédnea de aplicaciones y paginas (Evolution) en un entorno de simulacién sin la necesidad de un dispositivo
target conectado al PC.

Simulation puede simular la ejecucién de

e aplicacién PLC realizada mediante Application

e Interfaz gréfica HMI de Evolution realizada mediante UserInterface

La ejecucidn por tanto puede realizarse en el mismo PC que se ha utilizado para su desarrollo.

La aplicacién IEC puede ser 'descargada’ en el Simulador en vez de descargarla en el target "fisico".

Le aconsejamos lanzar Simulation desde Application

A continuacion aparecera el listado de las secciones (paneles) tal como se ve en la primera pantalla (empty workspace)™
En tal caso es necesario conectar al Simulador manualmente la aplicacién IEC y/o las paginas HMIZ

%1 simulation - Empty workspace

Ele Edit Help

o
1 —

"Wiorkspace:

Target name;

PLC project:

M project:

1 Respecto a los otros entornos de trabajo (Application, Userinterface etc) no es indispensabile interactuar con la ventana de Simulation. Si no se
-

utiliza puede minimizarse con la tecla ‘&
2 Solo Evolution
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Nombre Panel /
Seccién Seccién Panel Descripcion
Simulation

Esta seccidon muestra los instrumentos de trabajo
mediante iconos.

v para lanzar la Aplicacién [EC (PLC)

© para detener la Aplicacion IEC (PLC)

| o
Barra de herramientas = show HMI window
(Main bar) para visualizar/ocultar HMI (instrumento virtual)

= Show 1I/O panels
para visualizar/ocultar las ventanas I/0

L
¥ 1 Show full control window
para reducir /expandir la ventana

fichero con el nombre preseleccionado que sirve de
entorno de trabajo (workspace)

B Workspace Entorno de trabajo Se pueden crear mas workspaces con diferentes
aplicaciones (Smart+Evolution) y/o paginas HMI
(Evolution)

Nombre del target no modificable por el usuario.
Ejemplos:

e FreeSmart 412.5 para target Smart

(of Target name nombre del Target e  FreeEvolution423.5 para target Evolution

Nota compruebe desde Application >Project > Select
target que el nombre del target dispone de una version
mayor o igual a 5 (ej: FreeEvolution423.5).

PLC Project nombre aplicacién PLC si el campo esté vacio desde Edit > Edit workspace

D

. o haciendo click sobre los puntos suspensivos (...) se
E HMI Project nombre paginas HMI selecciona el correspondiente fichero.
F
G

I1/0 panels paneles I/O gestién de las ventanas de /0

Output window mensajes -

Edit Workspace'

Desde Edit > Edit workspace haciendo click sobre los puntos suspensivos (...) se selecciona

¢ Target name: fichero que contiene tods la informacién para reconstruir el runtime del target (real) file JTGSX!*!
e  PLC Project: aplicacién IEC (PLC) file .PPJS / .PPJX

e HMI Project: paginas HMI file .PAJX
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aplicacion IEC PLC seleccién paginas HMI
ya presente PAJX

3 Edit de tipo manual. Abriendo Simulation desde Application no es necesario 'editar' el entorno de trabajo
4 El fichero .TGSX se crea de manera automatica desde Application en la carpeta de FREE Studio > Catalog > FreeEvolution >Simulation
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SIMULATION [|| [free

Evolution
PRIMER ARRANQUE:

1. Haga click en el icono Launch FREE Studio que se encuentra en el Escritorio
2. Haga click en el icono FREE Studio Simulation.
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1 2

El entorno de trabajo (vacio) se presenta como se muestra en la figura 2
Ahora ya puede:

e Crear un nuevo proyecto (Area de trabajo workspace) WKSX '‘New ...’
e Abrir un proyecto existente ' Open ..." CTRL+0

e Abrir los proyectos recentes ‘Recent file ..." seleccionando de un listado

Los proyectos (Area de trabajo, workspace) de Simulation tienen la extensién WKSX

APERTURA SIMULATION DESDE APPLICATION=

Como alternativa, en el entorno de trabajo Application haga click en el correspondiente icono Simulation Mode!®!
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1. Aparece una ventana de didlogo donde puede:
e  Crear un nuevo workspace
e Abrir un workspace existente (WKSX)
2. Haga click en OK. Apareceran:
¢ el panel Simulation
e conexion TCP/IPSL: conexidn local entre los entornos de desarrollo Application y Simulation

En Application basta con clicar en Download code para 'descargar’ la aplicacién IEC al Simulador

La herramienta Simulation esta disponible para Smart y Evolution. Aconsejamos abrir Simulation directamente desde Application. Ver apartado siguiente
Aconsejamos abrir Simulation directamente desde Application. Disponible para Smart y Evolution.

Funcionamiento toogle. Haciendo click en el icono Simulation mode se abre / se cierra el entorno de trabajo Simulation

Si Simulation no se ejecuta es necesario cambiar el target. Ver secciéon Troubleshooting

Reducida a icono en la barra de herramientas.

AhWN=
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En el panel Al hay dos iconos con los que se visualizan las correspondientes ventanas
e Show IO Windows ventanas que indican el estado de 1/0O
e Show HMI Window representacién gréfica e interactiva de Evolution

Véase el ejemplo para un target Evolution

T ——— T
WIE - AEE el EEEQRCS W
CL TR TS SR

.

10 panels

Haciendo click en el correspondiente icono E aparecen varias ventanas/ventanas correspondientes a las entradas/salidas.
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1/0 panels Analog signal properties

La ventana I/O panels es una ventana 'indice’ que lista todas las ventanas (visibles si la casilla M esté seleccionada)

Desde esta ventana se puede afadir una ventana o eliminar/renombrar las ventanas listadas.

Para afadir una variable basta con 'arrastrar' desde Application a una o varias ventanas el elemento a monitorizar. Las entradas
y las salidas analdgicas!” son todas simulables:

En las entradas hay un cursor para modificar el valor leido.

Para las salidas existe una barra de estado / progreso. Para las digitales, estarad en verde si no esté activa la salida, roja si esté
activa. Los otros elementos que se pueden simular son!®

¢ Global shared

e Target variables

Nota. También se incluyen los pardmetros BIOS y pardmetros EEPROM!?!

La descripcion completa esta disponible en el manual Simulation. Pulse F1 para visualizar el pdf
Para 1/0 digitales ver HMI Window

En general cada objeto que posee una direcciéon Modbus

Solo Evolution

0 N O
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Cada elemento presente en las distintas ventanas tiene propiedades que puede editar mediante el icono

Signal Properties

Desde esta ventana se pueden visualizar/ modificar

e Signal label : etiqueta de la variable / recurso

e  Variable name : no modificable. Indica el nombre presente en el cédigo IEC

e Read only sila casilla M esté seleccionada la variable es solo de lectura

e Min value / Max value: los recursos tienen el rango configurado por defecto. Manualmente, seleccionando la casilla I, se
puede definir / reducir el rango que se visualizara.

HMI Window
Haciendo click en su correspondiente icono aparecera la representacién visual del target Evolution (instrumento virtual)

LA1HTh T

HMI Window

Desde esta ventana se puede simular el estado de las entradas y de las salidas digitales

Si la salida esté activa se colorea en rojo

Los pardmetros EEPROM se pueden resetear con la tecla Rst E2

Ademas, podemos navegar por el menu con las teclas del instrumento virtual como si operdsemos con el dispositivo fisico.

APERTURA SIMULATION DESDE USERINTERFACE:-

Idéntico a Application. Haga click en el correspondiente icono Simulation Mode!""!

Smart

El ejemplo para un target Smart es andlogo en todo.

E = 1]
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)
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10 Le aconsejamos que abra Simulation directamente desde Application. Disponible para Smart y Evolution.
11 Funcionamiento toogle. Haciendo click en el icono Simulation mode se abre el entorno de trabajo, clicando otra vez en Simulation lo cierra
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SOPORTE ELIWELL [|| [free

SOPORTE TECNICO ELIWELL

Eliwell pone a su disposicién personal técnico profesional y preparado para garantizar respuestas precisas y fiables a sus clientes.
Nuestros técnicos estan a su disposicidn cotidianamente para responder a las necesidades técnicas de la instalacion y la utiliza-
cién de todos los instrumentos Eliwell.

Para cualquier pregunta o para obtener soporte, contacte con nuestro soporte de programables Eliwell:

Tel.  +390437 986 250 Tel.  +34963134049
EMail:  eliwell.freeway@invensys.com EMail: freeway@eliwell.es

Antes de contactar con el Soporte Tecnico de Eliwell le rogamos que compruebe la versién software de Eliwell FREE Studio.
Desde el mend desplegable seleccione Help > About
Aparecerd la siguiente pantallal:

dlill

Comunique la Version (Version) del software, el Build y la ID del Ordenador.

AYUDA EN LINEA

En cada fase del desarrollo del programa pulsando la tecla F1 se abre un documento pdf que contiene toda la ayuda en linea
imprimible

<livAll

M) stubio

Development software for free Smart

PROGRAMMABLE CONTROLLERS

S
&
M

FREE Studio proporciona a los desarrolladores Ayuda en linea para dar asistencia el programador en cada fase del desarrollo
del programa

1 Ejemplo en Application. Para Device la pantalla es analoga. Para los usuarios de Evolution analogas pantallas para Userinterface y Connection
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AYUDA EN LINEA - LED=

Desde el panel Project>Resources>Help se accede a la seccion LED reference for the developer'®! donde se describen las
caracteristicas de los iconos de FREE Smart y su gestion mediante |a target variable sysLocallLeds[])
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SITIO WEB AREA RESERVADA

Nuestra pagina web en internet www.eliwell.it Eliwell dispone de un Area Reservada de acceso exclusivo con Contrasefia.
Los usuarios, una vez acreditados para su acceso al drea reservada con Nombre de Usuario y Contrasefia personales, podran
visualizar documentos, informacidn, actualizaciones de producto y software de caracter reservado no visibles abiertamente en
la web.

Haga click aqui para visitar la correspondiente pagina del sitio y tener todas la informacién necesaria para su inscripcion.

- - e S - -

]

La documentacién de FREE Studio esta disponible para usuarios registrados en la seccion Aplicaciones > Programables >
FREE WAY > FREE Studio

Las actualizaciones del software estan disponibles para usuarios registrados en la seccién Soporte Tecnico > Area Programa-
bles > FREE WAY > FREE Studio

Las aplicaciones y librerias estan disponibles para usuarios registrados en la seccién Soporte Tecnico > Area Programables >
FREE WAY > FREE Studio > FREE Aplicaciones

2 Disponible solo para Smart
3 Ver pantalla visualizada a pantalla completa (full screen, CTRL+U)
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A continuacién se muestran algunos casos de mensajes de error y las correspondientes soluciones del problema.
Para casos no sefialados aqui contacte con el Soporte Tecnico Eliwell o consulte nuestra web www.eliwell.it

APPLICATION

Mensaje error

EE—— E
M e e

[T I.

lcono ComServer
no visible en la barra de
aplicaciones

Invalid memory image file.
Please upload memory
image from the target

DEVICE

Mensaje error

invalid connection string

SIMULATION

Mensaje error

no target definition for
simulator (TGSX) found
Unable to run simulator

Panel

Comunicacién

Comunicacién

Output

Panel

Connection Status

Panel

Efecto
target no conectado

Target no conectado

error de compilacion

Efecto

target no conectado

Efecto

Simulation no se ejecuta

Solucién

Verifica las configuraciones
del puerto COM
utilizando el menu
desplegable
Communication > Settings
EWDMI Properties

Desconecte el hardware de
comunicacion (Ejemplo DM,
convertidor USB/485 etc)
Nota.
Desconecte antes el lado
targety luego el lado PC.

conectar el dispositivo target
FREE Smart mediante DMI
al PC

Solucién

Verifica las configuraciones
de comunicacion
utilizando el mend

Communication > Settings
EWDMI Properties

o
modificando la secuencia el
menu
Communication > Advanced

Solucién

desde el panel
Project > Select target

seleccione el target correcto

entre los disponiblesy
confirme con Change
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En tabla se muestran algunas de las combinaciones de teclas disponibles (Shortcuts) para activar/desactivar las principales
funciones de Application. Para Device ver tabla siguiente y/o columna de Notas.

Connection y User Interface disponen de atajos para abrir, guardar y compilar proyectos

El funcionamiento ‘toggle’ indica que la funcidn se activa si estaba desactivada y, lo contrario, se desactiva si estaba activa,
utilizando la misma combinacién de teclas.
Por ej. CTRL+U activa el Full Screen, es decir pantalla completa: pulsando CTRL+U de nuevo la desactivamos!™

La Ayuda En Linea se activa con la tecla F1

Menu Funcién Funcién Atajos Notas
Siempre Disponible
Todos AYUDA EN LINEA HELP F1 HELP imprimible en
formato PDF
APPLICATION SHORTCUTS m
Menu Funcién Funcién Atajos Notas
Edit Imprimir Print CTRL+P ol
Edit Cortar Cut CTRL+X roxk
Edit Copiar Copy CTRL+C rx
Edit Pegar Paste CTRL+V ok
Edit Guardar Save CTRL+S ok
*kk
View > Toolbars Pantalla completa Full Screen CTRL+U Toggle
View > Toolbars SEITE he"am'eF”Btgs fongelpEe FBD BAR CTRL+D Toggle
View > Toolbars barra he”am'ea;as lEnelUElfllEe LD BAR CTRL+A Toggle
View > Toolbars I herramlesrlw:tés iEmgpele e SFC BAR CTRL+Q Toggle
View > Toolbars barra herramientas proyecto PROJECT BAR ‘ CTRL+J Toggle
View > Toolbars barra herramientas red NETWORK CTRL+M Toggle
View > Toolbars barra herramientas documento DOCUMENT BAR ‘ CTRL+N Toggle
View > Tool Windows visualiza panel proyecto WORKSPACE CTRL+W Toggle
View > Tool Windows visualiza panel mensajes OUTPUT ‘ CTRL+R Toggle***
View > Tool Windows visualiza panel libreria LIBRARY CTRL+L Toggle
View > Tool Windows visualiza panel ventana watch WATCH WINDOW ‘ CTRL+T Toggle***
. . o . . ASYNC GRAPHIC o
View > Tool Windows visualiza panel osciloscopio WINDOW CTRL+K Toggle
en el caso de mas
PROJECT compilacién proyecto COMPILE F7 proyectos compila
solo el seleccionado
COMMUNICATION descarga cédigo a la aplicacién DOWNLOAD CODE F5
- . cuando la variable
DEBUG anade una variable al panel ADD SYMBOL TO F8 ests seleccionada
watch WATCH
(no vale drag & drop)
afade una variable al panel INSERTS NEW ITEMS seleccionado de un
DEBUG watch INTO WATCH SHIFT + F8 listado
1 en Device la visualizacién de los paneles es definida desde el meni View spuntando o no las singole voci
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PARAMETERS

PARAMETERS

PARAMETERS

lee los pardmetros seleccionados

escribe los parémetros
seleccionados

selecciona todos los pardmetros

*** yalido también para Application

WINDOW
READ SELECTED

WRITE SELECTED

SELECT ALL

Menu Funcion Funcién Atajos Notas
ADD SYMBOLTO A
PEEUG DEBUG WINDOW FY
INSERTS NEW ITEMS
DEBUG INTO A DEBUG SHIFT + F10
WINDOW
ADD/REMOVE
DEBUG BREAK POINT F12
ADD/REMOVE
e TEXT TRIGGER ko
ADD/REMOVE
DEBUG GRAPHICTRIGGER ~ “HIFT+F9
DEBUG REMOVE ALL TRIGGERS CTRL+F59H'FT "
DEBUG Trigger list CTRL+I
*** valido también para Device
DEVICE SHORTCUTS E
Menu Funcidon Funcién Atajos Notas
Edit Imprimir Print CTRL+P ool
Edit Cortar Cut CTRL+X Fork
Edit Copiar Copy CTRL+C bl
Edit Pegar Paste CTRL+V Fxk
View > Toolbars Pantalla completa Full Screen CTRL+U Toggle***
View > Tool Windows visualiza panel mensajes OUTPUT CTRL+R Toggle***
View > Tool Windows visualiza panel ventana watch WATCH WINDOW CTRL+T Toggle***
View > Tool Windows visualiza panel osciloscopio ARSI RIS CTRL+K Toggle***

CTRL+SHIFT+R los parémetros

seleccionados se

CTRL+SHIFT+R | destacan en amarillo

Operacién a efectuar
con cautela
La operacidn
siguiente podria
escribir todos los
pardmetros y/o
restaurar los valores
por defecto

CTRL+A
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IIEY evolution

USER INTERFACE SHORTCUTS

Menu Funcion Funcién Atajos Notas
CONFIGURATOR BAR nuevo proyecto NEW PROJECT CTRL+N okl
CONFIGURATOR BAR apertura proyecto OPEN PROJECT CTRL+O ol

Y GENERATE CODE
CONFIGURATOR BAR compilacién proyecto HMI (COMPILE) F7
*** valido también para Connection
CONNECTION SHORTCUTS o
Menu Funcién Funcién Atajos Notas
MAIN BAR nuevo proyecto NEW PROJECT CTRL+N ool
MAIN BAR apertura proyecto OPEN PROJECT CTRL+O ol
MAIN BAR Salva Save CTRL+S
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PROYECTO 1 - CONTADOR

A continuacién le mostraremos el procedimiento para escribir, testar y descargar en el FREE Smart un sencillo programa
COUNTER escrito en lenguaje ST que realiza un cémputo y visualiza en el osciloscopio un ‘diente de sierra’.

El programa COUNTER realiza el cobmputo de la variable local a de 0 a MAXSCALE1. Cuando a llega a MAXSCALE1 se reinicia-
lizaa-100.

Como se ha descrito anteriomente en el capitulo Primer Arranque,
e arranque Application,

e cree un nuevo proyecto CONTATORE

e cree un programa COUNTER en lenguaje ST

En la seccidon central Edit escriba el cédigo del programa COUNTER en lenguaje ST.
Programa COUNTER

if a>MAXSCALEl then
a:=-100;

else

a:=a+l;

b:=a*10;

end if;

count:=a;
counterl:=b;

Variables locales

En la seccidn variables creamos las variables a y b (utilice el menu desplegable Variables > Insert, o el icono Insert record)
locales de tipo DINT, asociando como valor inicial (Init Value) O (cero)
Las variables ay b no son dtiles fuera del programa COUNTER por lo que se las define como locales.

Variables y constantes globales

En el programa hemos definido ademés una constante que definiremos de modo ‘global”:

e la constante MAXSCALE1 se crea en el panel Project >Global Variables Costants que crearemos aqui del mismo modo
que se ha creado una variable local. MAXSCALE1 tiene un valor por defecto de -100 por lo que no es necesario definirla
como variable sino como constante.

Variables ‘compartidas’ (Global Shared)

Como deseamos visualizar el resultado del contador del target en el programa hemos definido ademas 1 variable que defini-
remos como 'Global shared"!:

La variable count, que crearemos, se obtiene en el panel Resources>Modbus Objects > Status variables y no de la seccién
Edit/Variables, introduciendo un nuevo registro.

En este caso tendremos que definir también como apareceré el nombre de la variable en el display de 7-segmentos de FREE Smart
(es decir etiqueta de 4 digitos maximo, por ejemplo CNT para count)y el mapeado entre Application Type y Device Type

En el programa COUNTER hemos definido otra variable counter 1 que definiremos del mismo modo.
En este caso no definimos como aparece en el display. El software propondré por defecto COUn (en lugar de COUnter) es
decir utilizara las primeras 4 letras que se visualizaran en el display de 4-segmentos.

1 Téngase en cuenta que la carpeta 'Global shared' aparece si y solo si definimos la variable en la pestafia Resources>Modbus Objects > Status variables

2 Téngase en cuenta que si hubiésemos creado una variable counter yno counterl enfase de compilacién habriamos tenido un error
(conflicto de nombre entre programa COUNTER y variable)
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Visualizacion principal
Haciendo click en Resources>FREE Smart elegimos qué deseamos mostrar en el display como visualizacién principalf®

Elegimos la variable count (que, recordemos, es el valor de la variable local 'a')
Actualizamos el programa introduciendo una alarma como siempre activa o siempre desactivada.

if alarma then
allarmel:=0;
else
allarmel:=1;
end 1if;

La variable de alarma se ha de definir como variable local - de tipo BOOL (booleano).

Por defecto se propone FALSE como valor inicial - para modificarlo basta escribir TRUE.

La alarma estaré siempre activa. Podemos introducir una descripcién del tipo 'Alarm always active' es decir alarma siempre
activa.

Allarme1 se define en el Panel Resources>Alarms. Como etiqueta introducimos ALM1

Creaciéon Menu

A este punto llegados podemos crear:

e el mend personalizado PRG1 para introducir posibles parametros definidos por el desarrollador (o utilizar los existentes de
BiOS)

e el menu personalizado SET1 para introducir las 2 variables count y counter1

Task

Volviendo a la pestafia Project situdndose sobre el task Timed afiadimos el programa COUNTER.

Compilacién
Compilamos el proyecto - menu desplegable Project >Compile (o F7)
Nota: el proyecto es compilado sin errores y sin la necesidad de utilizar un FREE Smart conectado al PC

recapitulando...
... veamos las pantallas
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Programa COUNTER - Project tab Programa COUNTER - Resources tab Programa COUNTER - Resources tab
visualizacion principal definicion Variables
3 Como se puede ver la seleccién comprende las I/0 por defecto + las variables creadas dicho fin por el desarrollador
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Programa COUNTER - Resources tab Programa COUNTER - Resources tab Programa COUNTER - Resources tab
menu Set (SET1) menu Alarms (Alarmas) definicién Variables
Note

en la pestafia Project las variables compartidas (Global shared) aparecen solo después de haberlas dado de alta en la pestana
Resources. En el ejemplo:

e Alarms = allarme

e  Parameters=> PAR1

e Variables = county counter1

Conexion a FREE Smart y descarga de aplicacion

Tras haber conectado FREE Smart a la DMl y al PC en el puerto USB y haber efectuado las debidas comprobaciones en la COM

y el baudrate (ver correspondiente capitulo) nos podemos conectar al dispositivo target:

e con el mend desplegable Communication > Connect o icono Connects to the target conéctese a FREE Smart

® sila conexion se ha realizado con éxito aparecera el mensaje en verde CONNECTED abajo a la derechal®

e ahora desde el menut desplegable Communication > Download code (F5) o icono Code download descargue la aplica-
cién al FREE Smart

® una o varias ventanas!®! de didlogo apareceréan para indicar que se esta descargando la aplicacién. La descarga podria
requerir algunos segundos

et Livrell}ree Stude Aglication =
o T wwact; . He e § e - =
T cartrus rn | :3 PLC el b vt i L sratemn, sobiense 7

= S sl

[T P — S S SR S -8

aplicacion IEC existente sobre el target PLC para resetear descarga de la aplicacién en curso
confirmar que sigue confirmar cambio

Ahora la aplicacién deberia funcionar en el FREE Smart

4 En caso contrario ver capitulo Download on target o troubleshooting
5 Dependiendo de si el target ya ha sido programado o no
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Watch y Osciloscopio

En el display del target aparece el valor de count!®! que va de -100 a +100.
Téngase en cuenta que aparece el LED de alarma en cuanto se activa la alarma.
En el menu de Estados se puede comprobar la presencia

e delacarpeta SET1 con las variables CNT y COUNt

e delacarpeta AL con la alarma ALM1 a 1

En Application se puede teste ar el valor de las variables y visualizarlas en modo texto o grafico simplemente arrastrando la
variable del codigo al panel Watch y Oscilloscope
Véase la siguiente pantalla
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e Véase como las variables locales ay b van en ciclos de -100 a 100 (x 10 para la variable b) y las correspondientes variables
county counter1 del mismo modo.

e Alarma es una variable boolena siempre verdadera (TRUE indicado en rojo!”!) y allarme1 vale 1

e Lavariable count se visualiza en el osciloscopio y se ve el 'diente de sierra'

Guardando proyecto
El proyecto se puede guardar como counter.ppjs o con un nombre a elegir, generar un fichero .rsm, proteger con contrasefay
exportar como objeto de libreria (.pll)

DEVICE

El proyecto se puede abrir con Device:

Se abrird la herramienta del mismo nombre, donde podra leer o escribir uno o varios pardmetros de BIOS, modificarlos y/o
descargar nuevamente el por defecto.

Se puede leer el valor actual de las variables definidas por el desarrollador pero no modificarlas.

Device no supone que el usuario tenga que saber ninglin lenguaje de programacién, el cédigo fuente no es visible.

Device supone que nos tengamos que conectar de nuevo al dispositivo target (haga click en su correspondiente icono). El pa-
nel central muestra las referencias del protocolo, direccidn etc. El nombre del dispositivo target es por defecto FREESmart_118l.
Cuando el dispositivo target se conecta se pueden leer los pardmetros o escribir los parametros por defecto o los modificados.

6 Count se configura como visualizacién fundamental. Si no se selecciona ninguna variable aparece el mensaje PLC.
Pulsando F5 se visualiza FREE y se puede acceder a las variables y parametros de BIOS

7 Modificando Alarma de TRUE a FALSE, recompilando y descargando la nueva aplicacién el LED de alarma se apaga y la variable se indicara en
verde en el panel Watch

8 Con un simple copiar-pegar se puede crear un proyecto gemelo FREESmart_2, modificar los parametros de BIOS y descargarlos en el target o

en un segundo target
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Lectura parametros

Supongamos que desea leer todos los parametros (Read all device parameters)
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Como se ve hay pardmetros de configuracion que tienen valores por defecto distintos de los presentes en el target (resaltados
en azul)

Visualizacién variables

Tal como sucede en Application , también en Device se pueden visualizar las variables simplemente arrastrandolas sobre los
paneles Watch y Oscilloscope.

Escritura de parametros

Supongamos que deseamos descargar todos y solo los pardmetros CL (BIOS locales).

Seleccione todos los pardmetros - menu desplegable Parameters>Select all (CTRL+A) o mediante el correspondiente
icono B, Los pardametros aparecen todos resaltados en amarillo. Escribir ment desplegable Parameters>Write selected
(CTRL+SHIFT+W) (0 mediante icono W)

Todos los pardmetros CL se cargaréan en el target.

carpeta CF Watch / Oscilloscope descarga parametros CL (todos) en
parametros CF31 y Ui26 con valores variables count y counter1 curso
por defecto distintos de la aplicacién

El proyecto se puede guardar como Counter.CFN o con el nombre que elija.
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PROYECTO 2 - CONTADOR2 FUNCTION BLOCK

Partiendo del programa COUNTER descrito en el ejemplo anterior creamos un bloque de funcién y modificamos la aplicacién
IEC afiadiendo cédigo para la conmutacién de un LED / relé

Guardado proyecto

Guardamos el proyecto COUNTER renombréndolo como COUNTER2:
En el menu desplegable File>Save project as el sistema propone la carpeta de trabajo COUNTER.
Suba un nivel, cree una nueva carpeta COUNTER2 y guarde el proyecto como COUNTERZ2.

Creacién bloque de funcién (function block)

Crear un nuevo bloque de funcion COUNTERST en lenguaje ST.
Copiar/pegar el programa COUNTER en el panel Edit del bloque de funcién con algunas variantes.

Programa (Bloque de funcién) COUNTERST
if a>MAX then

a:=-100;

elsif enable then

ar=a+l;

end 1if;

out:=ay

Variables locales, de entrada y de salida

En la seccion Bl variables creamos las variables:

e acomo variable local

¢ MAXYy enable como variables de entrada al bloque de funcién
e out como variable de salida al bloque de funciéon

El bloque de funcién tendré por tanto 2 variables de entrada, una variable de salida y una variable local que memorizara el
estado del contador en cada instancia del bloque de funcién.
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1 Ver capitulo Definicién Paneles Application
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Escribimos ahora el programa COUNTER2 donde se realizara la llamada del bloque de funcién.
El bloque de funciéon tendré 2 instancias CounterStl, CounterSt2 definidas como variables locales de tipo CounterSt

Mientras estamos escribiendo el cédigo téngase en cuenta que Application guia al desarrollador en la escritura del cédigo
proponendo las variables a pasar al bloque de funcién!?
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La variable booleana en este caso servird para conmutar

e unrelé debidamente configurado

e un LEDBl del target en funcién de una condicién definida
Ahora escribimos el nuevo cédigo COUNTER2

Programa COUNTER2
CounterStl (enable:=not Enable Counterl,MAX:=MAXSCALEL) ;
counterl:=CounterStl.out;

CounterSt2 (enable:=Enable Counter2,MAX:=MAXSCALE1l/2);
counter2:=CounterSt2.out;

alarma:=(counterl>counter?2);
if alarma then

allarmel:=1;
Alarm relay := TRUE;

else

allarmel:=0;
Alarm relay

FALSE;
end if;

if (counterl<=counter2) then

sysLocalleds[6] :=1;
else
sysLocalleds[6] :=0;
end if;
2 En el ejemplo 2 de entrada (identificadas por un icono con las flechas a izquierda, y la salida con las flechas a la derecha)
3 Explotamos la target variable sysLocalleds. Vercorrespondiente seccién
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En la pestafia Resources han de crearse y/o ser renombrados del proyecto anterior
los parédmetros de EEPROM, variables de estado etc
Ademas, si se desea, se han de anadir los recursos al ment Prg y menu set

En el menu I/0 mapping se pueden asociar los recursos a las entradas/salidas
Asociamos a una entrada digital Enable CounterlyaunasalidaAlarm relay
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Exportacién al dispositivo target

Le aconsejamos que desde el menu desplegable Developer>Export application to catalog exporte el proyecto al catdlogo
para permitir que Device pueda volverlo a utilizar para su descarga al dispositivo target

Antes de la exportacién al catdlogo es necesario desde el menu desplegable Project>Options proporcionar al proyecto una
release (ej. el mismo nombre counter2), una versién (ej. 1.0) y recompilar el proyecto

Esto permitird que Device reconozca la aplicacion IEC presente en el target cuando se descargue.
Compile el proyecto y descérguelo al target mediante Application o Device
El contador mostrara en el display un cémputo de -100 a 100 de modo analogo a como sucede en la aplicaciéon [EC COUNTER

descrita anteriormente.
En este caso el LED Alarma conmutara el LED del compresor!® una vez se alcanze el umbral definido.

4 SysLocalleds[6], IL LED alarma es SysLocalLeds[16]
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